Results 1 to 5 of 5

Thread: [12.10] Sound quietly on Laptop

  1. #1
    Join Date
    Jul 2011
    Beans
    27

    [12.10] Sound quietly on Laptop

    Hi,

    some strange behavior i came across regarding Sound in Xubuntu 12.10 on an Alienware M17x R3 Laptop.
    Using the internal Speakers, even on loudest settings (also checked alsamixer) is not nearly als loud as it is in Windows.
    Id also checked if there is any loudness Plugin or so running in Windows, and its not, so id guess its something in the used driver or so.
    Beside that, sound isnt as good as it is windows, it just has a lot more "power" there.

    lspci:
    Code:
    Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
    Audio device: Advanced Micro Devices [AMD] nee ATI Barts HDMI Audio [Radeon HD 6800 Series]
    lsmod |grep snd
    Code:
    snd_hda_codec_hdmi     31423  1 
    snd_hda_codec_idt      59761  1 
    snd_hda_intel          32515  7 
    snd_hda_codec         111547  3 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel
    snd_hwdep              13272  1 snd_hda_codec
    snd_pcm                80163  4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
    snd_seq_midi           13132  0 
    snd_rawmidi            25382  1 snd_seq_midi
    snd_seq_midi_event     14475  1 snd_seq_midi
    snd_seq                51255  2 snd_seq_midi,snd_seq_midi_event
    snd_timer              24411  2 snd_pcm,snd_seq
    snd_seq_device         14137  3 snd_seq_midi,snd_rawmidi,snd_seq
    snd                    61991  23 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
    soundcore              14599  1 snd
    snd_page_alloc         14036  2 snd_hda_intel,snd_pcm
    aplay -l
    Code:
    card 0: PCH [HDA Intel PCH], device 0: STAC92xx Analog [STAC92xx Analog]
      Subdevices: 0/1
      Subdevice #0: subdevice #0
    card 1: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    In the configuration in Xfce i have set "Barts HDMI Audio (Radeon HD 6800 Series)" to Off and "Built in Audio" to Analog Stereo Output".

    In Windows its running as "IDT High Definition Audio CODEC"

    Glad if anyone could help me on this
    Last edited by thyriel; November 19th, 2012 at 11:16 AM.

  2. #2
    Join Date
    Jul 2011
    Beans
    27

    Re: [12.10] Sound quietly on Laptop

    no one an Idea ?

  3. #3
    Join Date
    May 2009
    Location
    Wao Kele 'O Puna, Ola'a,
    Beans
    143

    Re: [12.10] Sound quietly on Laptop

    Here's how I tweaked an HP Envy with Beats Audio to sound louder.

    http://forums.gentoo.org/viewtopic-t-859769.html
    After editing the one file, you should be able to adjust volume for all channels in PulseAudio-volume-control.
    Subwoofer included.

    I found the link on AskUbuntu.

    Good luck!
    "640 K should be plenty of RAM for anybody..."

  4. #4
    Join Date
    Jul 2011
    Beans
    27

    Re: [12.10] Sound quietly on Laptop

    Pretty much forgot about this until i found it in my bookmarks again *shame*

    I managed to get it running correctly

    added to /etc/modprobe.d/alsa-base.conf
    options snd-hda-intel model=auto

    Also tried before with model=dell and model=alienware both resulting in no sound at all, but somehow auto works great

  5. #5
    Join Date
    Jun 2007
    Beans
    11,057

    Re: [12.10] Sound quietly on Laptop

    So without the model=auto line, it doesn't work at full volume? If so, you should report a bug so that other folks with this laptop know how to work around it (and maybe devs will suggest hard-coding the quirk into ALSA so no workaround is needed).

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •