Results 1 to 1 of 1

Thread: No Internet connection, Ubuntu 10.04

  1. #1
    Join Date
    Jun 2009

    No Internet connection, Ubuntu 10.04

    Hiya, all:

    I'm a relatively neophyte Linux user, and I've been running 64-bit LTS Ubuntu 10.04. After just moments ago fixing a failure to boot problem (thanks to oldfred and YannBuntu), I noticed that my wired Internet connection no longer works.

    How do I fix that?

    The task bar atop the desktop screen shows a connectivity icon with a red exclamation mark on it. Hovering over the icon indicates, “No network connection.” Left-clicking the icon shows a menu consisting of:

    Wired Network [non-clickable]
    disconnected [this is grayed out]
    VPN Connections [sub menu consisting of “Configure VPN...” and, “Disconnect VPN...” [grayed out]]

    Right-clicking this same taskbar icon shows a checkmark by “Enable Networking” and “Enable Notifications.” “Connection Information” is grayed out, and clicking on “Edit connections...” brings up a dialogue box for Network Connections. Under the Wired tab, under Name, I see, “Auto eth0,” and under Last Used, next to “Auto eth0,” I see, “never.”

    Not sure if that information is useful or not, but there it is. Any assistance on fixing this Internet connectivity issue will be greatly appreciated.

    Oh, and I just ran ...

    sudo gedit /etc/network/interfaces
    ...which generated this:

                     description: Ethernet interface  
                     product: 88E8056 PCI-E Gigabit Ethernet Controller  
                     vendor: Marvell Technology Group Ltd.  
                     physical id: 0  
                     bus info: pci@0000:02:00.0  
                     logical name: eth0  
                     version: 12  
                     serial: 00:22:15:ea:41:a0  
                     capacity: 1GB/s  
                     width: 64 bits  
                     clock: 33MHz  
                     capabilities: pm vpd msi pciexpress bus_master cap_list rom ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation  
                     configuration: autonegotiation=on broadcast=yes driver=sky2 driverversion=1.25 firmware=N/A latency=0 link=no multicast=yes port=twisted pair  
                     resources: irq:25 memory:feafc000-feafffff ioport:e800(size=256) memory:feac0000-feadffff(prefetchable)  
     - ---------------------------- -
     and down at the bottom, this
     - ---------------------------- -
     *-network DISABLED  
            description: Ethernet interface  
            physical id: 1  
            logical name: vboxnet0  
            serial: 0a:00:27:00:00:00  
            capabilities: ethernet physical  
            configuration: broadcast=yes multicast=yes 
    Thanks again for your insight.

    Mikhail Weiss
    Last edited by Mikhail Weiss; November 19th, 2012 at 04:29 PM.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts