Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: VLC Player has been removed, now I can't reinstall it

  1. #1
    Join Date
    Nov 2012
    Beans
    16

    VLC Player has been removed, now I can't reinstall it

    I don't know what happened. I clicked on update and it removed some stuff including VLC player. But now when I go to reinstall it I can't do it and I'm at a loss at what to do.

    This is what it said is Ubuntu Software center
    Package dependencies cannot be resolved
    This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time.
    The following packages have unmet dependencies:

    vlc: Depends: vlc-nox (= 2.0.1-4) but 2.0.1-4 is to be installed
    Depends: libavcodec-extra-53 (>= 4:0.8-1~) but 4:0.8.1ubuntu1 is to be installed
    Depends: libavutil-extra-51 (>= 4:0.8-1~) but 4:0.8.4ubuntu0.12.04.1 is to be installed
    Depends: libc6 (>= 2.15) but 2.15-0ubuntu10.3 is to be installed
    Depends: libfreetype6 (>= 2.2.1) but 2.4.8-1ubuntu2 is to be installed
    Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.3-1ubuntu5 is to be installed
    Depends: libqtcore4 (>= 4:4.8.0) but 4:4.8.1-0ubuntu4.3 is to be installed
    Depends: libqtgui4 (>= 4:4.7.0~beta1) but 4:4.8.1-0ubuntu4.3 is to be installed
    Depends: libstdc++6 (>= 4.6) but 4.6.3-1ubuntu5 is to be installed
    Depends: zlib1g (>= 1:1.2.3.3.dfsg) but 1:1.2.3.4.dfsg-3ubuntu4 is to be installed
    Terminal
    sudo apt-get install vlc
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies.
    vlc : Depends: vlc-nox (= 2.0.1-4) but it is not going to be installed
    Depends: libavcodec53 (>= 4:0.8-1~) but it is not going to be installed or
    libavcodec-extra-53 (>= 4:0.8-1~) but it is not going to be installed
    Recommends: vlc-plugin-notify (= 2.0.1-4) but it is not going to be installed
    Recommends: vlc-plugin-pulse (= 2.0.1-4) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    Also can't do it in Synaptic Manager
    Could not mark all upgrades for installation or upgrade
    The following packages have unresolvable dependencies.
    Make sure all the required repositories are addedand enabled in the 'Repositories' option under 'Settings'.
    vlc:
    Depends: vlc-nox but it is not going to be installed
    Depends: libavcodec53 but it is not going to be installed or
    libavcodec-extra-53 but it is not going to be installed
    Recommends: vlc-plugin-notify but it is not going to be installed
    Recommends: vlc-plugin-pulse but it is not going to be installed
    I'm running Ubuntu 12.04 on an Acer Aspire Revo if that helps out at all. Please help me, thank you in advance.

  2. #2
    Join Date
    Sep 2010
    Location
    Central Calif
    Beans
    1,208
    Distro
    Xubuntu 12.10 Quantal Quetzal

    Re: VLC Player has been removed, now I can't reinstall it

    Have you installed "Ubuntu restricted extras"? If not, find it in Software Center. It may help with some dependencies.
    Remember When Double-Dog dare ya's and water balloons were the ultimate weapon?

  3. #3
    Join Date
    Jan 2007
    Beans
    6,542
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: VLC Player has been removed, now I can't reinstall it

    Hmm, try refreshing your package lists and if that doesn't work try switching to a different download server. For some reason the one you're connected to isn't giving you the packages you need.

  4. #4
    Join Date
    Nov 2012
    Beans
    16

    Re: VLC Player has been removed, now I can't reinstall it

    Quote Originally Posted by critin View Post
    Have you installed "Ubuntu restricted extras"? If not, find it in Software Center. It may help with some dependencies.
    Quote Originally Posted by Paqman View Post
    Hmm, try refreshing your package lists and if that doesn't work try switching to a different download server. For some reason the one you're connected to isn't giving you the packages you need.
    Did both of these, hasn't solved the problem though.

  5. #5
    Join Date
    Sep 2012
    Location
    Gnome12o4/LXQt14o4
    Beans
    Hidden!

    Re: VLC Player has been removed, now I can't reinstall it

    "Make sure all the required repositories are added and enabled in the 'Repositories' option under 'Settings'."

    Do you have all of them checked?

    https://help.ubuntu.com/community/Re...u_Software_Tab

  6. #6
    Join Date
    Nov 2012
    Beans
    16

    Re: VLC Player has been removed, now I can't reinstall it

    Quote Originally Posted by ibjsb4 View Post
    "Make sure all the required repositories are added and enabled in the 'Repositories' option under 'Settings'."

    Do you have all of them checked?

    https://help.ubuntu.com/community/Re...u_Software_Tab
    Yep, have them all checked, still not playing ball with me though.

  7. #7
    Join Date
    Nov 2008
    Location
    BSAA Headquarters
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: VLC Player has been removed, now I can't reinstall it

    What PPAs do you have installed?
    Ubuntu Forums Moderation Staff || SandyDNET
    Twitter: @CatchesAStar | Last.fm
    Ubuntu Membership via Forum Contributions

  8. #8
    Join Date
    Nov 2012
    Beans
    16

    Re: VLC Player has been removed, now I can't reinstall it

    Quote Originally Posted by sandyd View Post
    What PPAs do you have installed?

  9. #9
    Join Date
    Jun 2007
    Beans
    12,997

    Re: VLC Player has been removed, now I can't reinstall it

    What doesn't look right from orig. post
    Depends: libavcodec-extra-53 (>= 4:0.8-1~) but 4:0.8.1ubuntu1 is to be installed
    Depends: libavutil-extra-51 (>= 4:0.8-1~) but 4:0.8.4ubuntu0.12.04.1 is to be installed
    libavcodec & libavutil should be the same version which currently is
    4:0.8.4ubuntu0.12.04.1

    Search libavcodec in synaptic & see if 4:0.8.4ubuntu0.12.04.1 is available

  10. #10
    Join Date
    Nov 2012
    Beans
    16

    Re: VLC Player has been removed, now I can't reinstall it

    Quote Originally Posted by mc4man View Post
    What doesn't look right from orig. post

    libavcodec & libavutil should be the same version which currently is
    4:0.8.4ubuntu0.12.04.1

    Search libavcodec in synaptic & see if 4:0.8.4ubuntu0.12.04.1 is available
    OK I was able to get both of those to be the same versions but it still won't let me install VLC player. Am I doing something wrong?

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •