Results 1 to 3 of 3

Thread: 12.04 LTS - Creative X-Fi soundcard - No subwoofer controls

  1. #1
    Join Date
    May 2010

    12.04 LTS - Creative X-Fi soundcard - No subwoofer controls

    I'm at a loss.

    I'm using Ubuntu 12.04 LTS x64, and have not installed any audio mixers, front ends, etc, beyond what shipped with 12.04. I've tried to keep the system clean as it makes it easier to troubleshoot.

    ALSA identifies this card correctly, but it has no controls for the subwoofer in alsamixer. Controls for Surround and Center are there and they all work fine. In the Pulse mixer that ships with 12.04 (the one you can access through the volume control on the taskbar) I can test sound channels and they all work, except the subwoofer, which just gives a low frequency noise I can barely hear.

    Does anyone have any tips for figuring this out? Between ALSA and Pulse I'm not sure exactly where the problem lies, but I'm leaning towards ALSA since it doesn't even have an entry for a subwoofer channel, but with past problems with Pulse I really am not sure.

    Trying to get this setup for Steam. Thank you for your time, and any help you can provide.

  2. #2
    Join Date
    May 2010

    Re: 12.04 LTS - Creative X-Fi soundcard - No subwoofer controls

    I'm marking this solved, because despite the lack of a subwoofer from the control panel, programs that make use of it seem to work just fine. It's odd, but it works, so I'll take it.

  3. #3
    Join Date
    Mar 2008
    Ubuntu 10.10 Maverick Meerkat

    Re: 12.04 LTS - Creative X-Fi soundcard - No subwoofer controls

    I've just gone from 12.04 and 12.10 with the exact same issue.

    I fixed it by editing "/etc/pulse/daemon.conf" and changing the line ";default-sample-channels = 2" to "default-sample-channels = 8" (note the removal of the leading ";")

    Then killing pulseaudio and letting it restart ("killall pulseaudio").

    The value "8" is for 7.1, it will be 6 for 5.1, 5 for 5.1 and 3 for 2.1.

    Next fire up ALSA mixer ("alsamixer") and check if the Centre/LFE channel is muted (it'll say "MM" at the bottom if it is). Not sure why, but that's how Ubuntu comes as default. To unmute, simply press "m".

    Do you have multiple sound cards (e.g. on-mobo and maybe HMDI out from the graphics card)? If so, install "pavucontrol" and disable the ones you are not using. I am not 100% sure if that is really needed, but it seems sensible enough to me. Also check the volume settings in there to be sure that some speakers are still not muted.

    That should be it. Run this to check all the speakers "speaker-test -c8 -l1 -twav". Againm this is for 7.1, change the value of "-c" to suit your set-up.

    Note: Always take a copy of any config files before editing them - just in case.
    Here is a test to find whether your mission on earth is finished: If you're alive, it isn't.
    Richard Bach, Illusions

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts