Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Manually Specify Resolution on nVIDIA laptop

  1. #1
    Join Date
    Mar 2006
    Location
    Oxford, OH, USA
    Beans
    1,002
    Distro
    Ubuntu 12.04 Precise Pangolin

    Question Manually Specify Resolution on nVIDIA laptop

    Hello,

    I'd like to manually specific a non-native resolution with the nVIDIA driver on a laptop.

    The xorg.conf file is attached. I'd like to specify 1280x800 for the LCD (laptop) as an option. Currently, only the 1600x900 (native/auto) option is available.

    How can I do this?

    Thanks,
    CH
    Attached Files Attached Files
    ________________________________
    DELL e6420 Laptop
    Ubuntu Pagolin Precise 12.04 LTS
    Linux Registered User #434330

  2. #2
    Join Date
    Jan 2008
    Location
    Nappanee, IN
    Beans
    602
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Manually Specify Resolution on nVIDIA laptop

    The use of a custom xorg.conf file has been deprecated since Ubuntu 9.10. The suggested alternative for setting resolution is to install the x11-xserver-utils package, then use xrandr to set the resolution (included in the package). In your case the following would be entered in a terminal to see if it sets properly:
    Code:
    $ cvt 1280 800
    # 1280x800 59.81 Hz (CVT 1.02MA) hsync: 49.70 kHz; pclk: 83.50 MHz
    Modeline "1280x800_60.00"   83.50  1280 1352 1480 1680  800 803 809 831 -hsync +vsync
    $ xrandr
    Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 4096 x 4096
    VGA-1 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
       1024x768       60.0* 
       800x600        60.3     56.2  
       848x480        60.0  
       640x480        59.9   
    $ xrandr --newmode 1280x800 83.50  1280 1352 1480 1680  800 803 809 831 -hsync +vsync
    $ xrandr --addmode VGA-1 1280x800
    $ xrandr --output VGA-1 --mode 1280x800
    Use in place of VGA-1 whatever is displayed in the second line of the response to xrandr on a line by itself. The $ indicates a new line prompt. If you get a response including 'xrandr: failed to get size of gamma for output default' and the replacement for VGA-1 is default, this procedure may not work, and I have a bug report on Launchpad #1078695.
    Last edited by cwsnyder; November 16th, 2012 at 12:41 AM. Reason: resolution shown which was not likely for laptop

  3. #3
    Join Date
    Mar 2006
    Location
    Oxford, OH, USA
    Beans
    1,002
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Manually Specify Resolution on nVIDIA laptop

    Quote Originally Posted by cwsnyder View Post
    The use of a custom xorg.conf file has been deprecated since Ubuntu 9.10. The suggested alternative for setting resolution is to install the x11-xserver-utils package, then use xrandr to set the resolution (included in the package). In your case the following would be entered in a terminal to see if it sets properly:
    Code:
    $ cvt 1280 800
    # 1280x800 59.81 Hz (CVT 1.02MA) hsync: 49.70 kHz; pclk: 83.50 MHz
    Modeline "1280x800_60.00"   83.50  1280 1352 1480 1680  800 803 809 831 -hsync +vsync
    $ xrandr
    Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 4096 x 4096
    VGA-1 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
       1024x768       60.0* 
       800x600        60.3     56.2  
       848x480        60.0  
       640x480        59.9   
    $ xrandr --newmode 1280x800 83.50  1280 1352 1480 1680  800 803 809 831 -hsync +vsync
    $ xrandr --addmode VGA-1 1280x800
    $ xrandr --output VGA-1 --mode 1280x800
    Use in place of VGA-1 whatever is displayed in the second line of the response to xrandr on a line by itself. The $ indicates a new line prompt. If you get a response including 'xrandr: failed to get size of gamma for output default' and the replacement for VGA-1 is default, this procedure may not work, and I have a bug report on Launchpad #1078695.
    You can have my xorg.conf file when you pry from my cold dead hands...


    Actually I tried your suggestion before and it doesn't work right - but I'll give another go!
    ________________________________
    DELL e6420 Laptop
    Ubuntu Pagolin Precise 12.04 LTS
    Linux Registered User #434330

  4. #4
    Join Date
    Mar 2006
    Location
    Oxford, OH, USA
    Beans
    1,002
    Distro
    Ubuntu 12.04 Precise Pangolin

    Question Re: Manually Specify Resolution on nVIDIA laptop

    Ok, got an error:

    Code:
    $ cvt 1280 800
    # 1280x800 59.81 Hz (CVT 1.02MA) hsync: 49.70 kHz; pclk: 83.50 MHz
    Modeline "1280x800_60.00"   83.50  1280 1352 1480 1680  800 803 809 831 -hsync +vsync
    $ xrandr
    Screen 0: minimum 8 x 8, current 1600 x 900, maximum 16384 x 16384
    VGA-0 disconnected (normal left inverted right x axis y axis)
    LVDS-0 connected 1600x900+0+0 (normal left inverted right x axis y axis) 310mm x 174mm
       1600x900       60.1*+   40.3  
    DP-0 disconnected (normal left inverted right x axis y axis)
    DP-1 disconnected (normal left inverted right x axis y axis)
    HDMI-0 disconnected (normal left inverted right x axis y axis)
    DP-2 disconnected (normal left inverted right x axis y axis)
    DP-3 disconnected (normal left inverted right x axis y axis)
    $ xrandr --newmode 1280x800 83.50  1280 1352 1480 1680  800 803 809 831 -hsync
    $ xrandr --addmode LVDS-0 1280x800
    X Error of failed request:  BadMatch (invalid parameter attributes)
      Major opcode of failed request:  153 (RANDR)
      Minor opcode of failed request:  18 (RRAddOutputMode)
      Serial number of failed request:  35
      Current serial number in output stream:  36
    Is this the error in the bug report?

    Thanks,
    CH
    ________________________________
    DELL e6420 Laptop
    Ubuntu Pagolin Precise 12.04 LTS
    Linux Registered User #434330

  5. #5
    Join Date
    Jan 2008
    Location
    Nappanee, IN
    Beans
    602
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Manually Specify Resolution on nVIDIA laptop

    No, the error does not match that of my bug report.

    I see why you need xorg.conf, to at the very least tell your computer what output to use! My mistake.

    In xorg.conf, see changes below:
    Code:
    Section "Monitor"
    	Identifier "Monitor0"
    	VendorName "Unknown"
    	ModelName "LGD"
    	HorizSync 41.3 - 54.8
    	VertRefresh 40.0 - 60.0
    	Option "DPMS"
    	ModeLine "1280x800_60" 83.50  1280 1352 1480 1680  800 803 809 831 -hsync +vsync
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device "Device0"
    	Monitor "Monitor0"
    	DefaultDepth 24
    	Option "RegistryDwords" "EnableBrightnessControl=1"
    	Option "RandRRotation" "True"
    	Option "Stereo" "0"
    	Option "nvidiaXineramaInfoOrder" "DFP-0"
    	Option "TwinViewXineramaInfoOrder" "DFP-0"
    	Option "TwinView" "0"	
    	Option "metamodes" "DFP: nvidia-auto-select +0+0"
    	SubSection "Display"
    		Depth 24
    		Modes "1280x800_60" 1600x900 1024x768
    	EndSubSection
    EndSection
    
    Section "InputDevice"
    	Identifier "Mouse0"
    	Driver "mouse"
    	Option "Protocol" "auto"
    	Option "Device" "/dev/psaux"
    	Option "Emulate3Buttons" "no"
    	Option "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
    	Identifier "mtev"
    	Driver "evdev"
    	Option "Device" "/dev/input/multitouch"
    	Option "Protocol" "auto-dev"
    EndSection
    
    Section "InputDevice"
    	Identifier "Keyboard0"
    	Driver "kbd"
    EndSection
    
    Section "ServerLayout"
    	Identifier "Layout0"
    	Screen 0 "Screen0" 0 0
    	InputDevice "Keyboard0" "CoreKeyboard"
    	InputDevice "Mouse0" "CorePointer"
    	Option "Xinerama" "0"
    	InputDevice "mtev" "SendCoreEvents"
    EndSection
    
    Section "Device"
    	Identifier "Device0"
    	Driver "nvidia"
    	VendorName "NVIDIA Corporation"
    	BoardName "NVS 4200M"
    	Option	"NoLogo"	"False"
    EndSection
    The modes in the Screen/Display subsection are suggestions only. I have no idea what modes are pertinent to your monitor, but the new modeline mode should be referred to here as well.

  6. #6
    Join Date
    Mar 2006
    Location
    Oxford, OH, USA
    Beans
    1,002
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Manually Specify Resolution on nVIDIA laptop

    Ok, I'll give this a go - I'm not in front of my dual head right now (laptop).

    Thanks,
    CH
    ________________________________
    DELL e6420 Laptop
    Ubuntu Pagolin Precise 12.04 LTS
    Linux Registered User #434330

  7. #7
    Join Date
    Mar 2006
    Location
    Oxford, OH, USA
    Beans
    1,002
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Manually Specify Resolution on nVIDIA laptop

    Ok, that broke X completely.

    - hmmmmm
    ________________________________
    DELL e6420 Laptop
    Ubuntu Pagolin Precise 12.04 LTS
    Linux Registered User #434330

  8. #8
    Join Date
    Nov 2012
    Beans
    3

    Re: Manually Specify Resolution on nVIDIA laptop

    I am in the same boat as you Cement. I am using my LCD TV as my display and it doesnt have an EDID or something so it just shows as a generic monitor with very few resolution options. The problem I am having specifically is overscan. I cant see the edges of the screen. In windows Nvidia has a utility that custom adjustsed the resolution to something like 1166x768 or something like that so I need to figure out how I can tell Ubuntu to set that resolution.

    All attempts at using xrandr have generated similiar errors as yours. There seems to be so many different ways people have tried to fix this problem and each one has you doing backflips through rings of fire that still dont seem to work.

    Anyways please do let me know if you manage to figure this out! Thanks

  9. #9
    Join Date
    Jan 2008
    Location
    Nappanee, IN
    Beans
    602
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Manually Specify Resolution on nVIDIA laptop

    Okay guys, I may have a fix. When I booted Linux Mint 14 Nadia Cinnamon desktop, I started getting similar problems with xrandr not working. In this case, I simply changed from the nouveau driver to the nvidia-current driver, which then let me use xrandr to set my video mode.

  10. #10
    Join Date
    Feb 2010
    Beans
    13

    Re: Manually Specify Resolution on nVIDIA laptop

    Has anyone made more progress with this? What were the resolutions you obtained?

    I'm running Ubuntu 12.04 x64, kernel 3.2.0-24-generic with an NVidia GTX460 and an Achieva Shimian QH270-Lite 2560 x 1440 monitor connected by a dual-link DVI cable.

    I've installed the nvidia-current 313-09 drivers from xorg-edgers (and tried the 310-19 from NVidia). Neither of these drivers read the EDID information from my monitor (/var/log/Xorg.0.log) and default to lower resolutions which my monitor will not display, resulting in a black screen. Full story here

    If I replace the high-res monitor with a lower resolution 1600 x 900 monitor it works fine.

    I want to force my video card to the resolution I need. NVidia's Xserver settings doesn't change anything. The xorg.conf configuration file is deprecated and the file is untouched by 12.04, so I tried xrandr with similar results to cement_head.

    First I queried the Modeline for my resolution:

    Code:
    john@Vivid01:~$ cvt 2560 1440 60
    # 2560x1440 59.96 Hz (CVT 3.69M9) hsync: 89.52 kHz; pclk: 312.25 MHz
    Modeline "2560x1440_60.00"  312.25  2560 2752 3024 3488  1440 1443 1448 1493 -hsync +vsync
    Then set up a new mode for it:

    Code:
    john@Vivid01:~$ xrandr --newmode "2560x1600_60.00"  348.50  2560 2760 3032 3504  1600 1603 1609 1658 -hsync +vsync
    And attempted to attach it to a display - with a similar error:

    Code:
    john@Vivid01:~$ xrandr --addmode DVI-I-1 "2560x1440_60.00"
    X Error of failed request:  BadMatch (invalid parameter attributes)
      Major opcode of failed request:  153 (RANDR)
      Minor opcode of failed request:  18 (RRAddOutputMode)
      Serial number of failed request:  31
      Current serial number in output stream:  32
    Perhaps xrandr doesn't allow complete customisation - or maybe it is built on code which is no longer relevant?

    Does anyone know how to get this to work for Ubuntu 12.04 and recent NVidia drivers?

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •