Results 1 to 6 of 6

Thread: Lubuntu 12.10 Mythtv dependencies

  1. #1
    Join Date
    May 2006
    Beans
    54

    Lubuntu 12.10 Mythtv dependencies

    Hi

    Trying to install mythtv on Lubuntu 12.10 through the Software Center but am getting a message saying that Package dependencies cannot be resolved.

    Through apt-get I get this output:

    john@john-desktop:~$ sudo apt-get install mythtv-frontend
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies.
    mythtv-frontend : Depends: mythtv-common but it is not going to be installed
    Depends: libmyth-0.25-0 (>= 2:0.25.2+fixes.20120802.46cab93) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.

    Has this happened to anyone else?

    Thanks

  2. #2
    Join Date
    Apr 2008
    Location
    Birmingham UK
    Beans
    419
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Lubuntu 12.10 Mythtv dependencies

    try

    Code:
    sudo apt-get update
    sudo apt-get upgrade
    first
    ****************************
    ****************************
    The sig between the asterisks is SO COOL that only REALLY COOL people can even see it!

  3. #3
    Join Date
    May 2006
    Beans
    54

    Re: Lubuntu 12.10 Mythtv dependencies

    Same result. Could it be that MythTV has not been updated in the repositories?

  4. #4
    Join Date
    Feb 2009
    Beans
    2

    Re: Lubuntu 12.10 Mythtv dependencies

    For me, libx264-120 was the root missing package. I manually downloaded and installed the appropriate *.deb file from https://launchpad.net/ubuntu/quantal...ge/libx264-120 after selecting the "Published Version" appropriate for my computer. After installing that, apt-get should be able to successfully install the mythtv-backend package and its remaining dependencies.

  5. #5
    Join Date
    May 2010
    Beans
    165

    Re: Lubuntu 12.10 Mythtv dependencies

    I also was having this issue when trying to update mythtv through the software updater. There is a dependence issue in the ubuntu repo, I had to add the mythbuntu 0.26 ppa. But the mythfrontend in 0.26 isn't as stable, it locks up every time I exit, I'm about to try downgrading libx264 to reinstall the version in the ubuntu repo.

  6. #6
    Join Date
    May 2006
    Beans
    54

    Re: Lubuntu 12.10 Mythtv dependencies

    Quote Originally Posted by ringzhz View Post
    For me, libx264-120 was the root missing package. I manually downloaded and installed the appropriate *.deb file from https://launchpad.net/ubuntu/quantal...ge/libx264-120 after selecting the "Published Version" appropriate for my computer. After installing that, apt-get should be able to successfully install the mythtv-backend package and its remaining dependencies.

    That worked. Thank you

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •