Results 1 to 3 of 3

Thread: 12.04 Sound not working through HDMI

  1. #1
    Join Date
    Nov 2012
    Beans
    18

    12.04 Sound not working through HDMI

    I have lubuntu 12.04 on Vaio VPCYB15AH laptop. I don't get any sound on TV when connected through HDMI. The corresponding control in alsamixer is unmuted (Screen below).



    ┌───────────────────────────── AlsaMixer v1.0.25 ─
    │ Card: HD-Audio Generic F1: Help │
    │ Chip: ATI R6xx HDMI F2: System information │
    │ View: F3:[Playback] F4: Capture F5: All F6: Select sound card
    │ Item: S/PDIF Esc: Exit │
    │ │
    │ ┌──┐ │
    │ │OO│ │
    │ └──┘ │
    │ < S/PDIF >



    My aplay-l output below:
    $ aplay -l

    **** List of PLAYBACK Hardware Devices ****
    card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 1: SB [HDA ATI SB], device 0: ALC269VB Analog [ALC269VB Analog]
    Subdevices: 0/1
    Subdevice #0: subdevice #0



    Any idea how to fix this ?



    Additional information w.r.t sound on this system :
    After installing lubuntu, I did not have any audio/sound output (Speaker, headphone, HDMI). I browsed the other forums and found that either of the solutions below enabled sound on speaker and headphone.

    1. http://askubuntu.com/questions/10622...u-installation
    First answer on swapping cards in alsa.conf worked for me

    2. http://forum.xbmc.org/showthread.php...025#pid1069025
    Editing .asoundrc file with hw:1.0 also worked


    So I can use both now with auto mute also working. But still unable to get audio working over HDMI even when video display over HDMI works fine.
    Last edited by svee; November 15th, 2012 at 07:42 AM.

  2. #2
    Join Date
    Nov 2012
    Beans
    18

    Re: 12.04 Sound not working through HDMI

    Following command does result in audio on TV connected over HDMI. So it is some kind of configuration issue where this device is not automatically selected even through monitor is enabled over HDMI ??

    $ aplay -D plughw:0,3 Front_Center.wav
    Playing WAVE 'Front_Center.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono

    Searching the other forums, I found this link. It describes process to automatically turning audio default to HDMI when cable is connected using udev and set of scripts.

    https://wiki.archlinux.org/index.php...udio_on_or_off


    Not tested it yet on my system. Hope to do so soon....
    Last edited by svee; November 15th, 2012 at 10:42 AM. Reason: Found more information

  3. #3
    Join Date
    Nov 2012
    Beans
    18

    Re: 12.04 Sound not working through HDMI

    Part of my original confusion was also because I was used to HDMI being selected as default sound output when I connect cable and use it as monitor.... Now I see that it is not automatic in lubuntu and I have to select myself.

    When I play video through Gnome, I can select audio output to be HDMI whenever cable is connected... So it works well... More easier to switch back to speaker as there is selection option in edit/preferences.
    b
    However when I play youtube or inside my browser , it takes the default audio device. Even if I play movie over HDMI, audio still plays with local speaker.

    Right now I work around this issue by editing .asoundrc file in my home directory and forcing alsa to reload.

    I don't see any option is alsamixer to select the default device.. Am I missing something ?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •