Results 1 to 4 of 4

Thread: Ubuntu 13.03 ethernet not working

  1. #1
    Join Date
    Jun 2013
    Beans
    16

    Ubuntu 13.03 ethernet not working

    When I plug the cable in, Ubuntu can detect it but it can not be conneted.

    Code:
    home@home-PC:~$ lspci -nnk | grep -iA2 net
    05:00.0 Network controller [0280]: Intel Corporation Centrino Wireless-N 1000 [Condor Peak] [8086:0084]
        Subsystem: Intel Corporation Centrino Wireless-N 1000 BGN [8086:1315]
        Kernel driver in use: iwlwifi
    08:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller [10ec:8168] (rev 03)
        Subsystem: Lenovo Device [17aa:2131]
        Kernel driver in use: r8169
    Code:
    home@home-PC:~$ lsmod
    Module                  Size  Used by
    usb_storage            47684  0 
    snd_hda_codec_hdmi     36186  1 
    btusb                  17986  0 
    joydev                 17097  0 
    coretemp               13131  0 
    kvm                   376505  0 
    arc4                   12543  2 
    parport_pc             27504  0 
    uvcvideo               71279  0 
    videobuf2_vmalloc      12920  1 uvcvideo
    bnep                   17669  2 
    radeon                875105  3 
    videobuf2_memops       13042  1 videobuf2_vmalloc
    thinkpad_acpi          69384  0 
    nvram                  13986  1 thinkpad_acpi
    rfcomm                 37420  0 
    iwldvm                220215  0 
    ppdev                  12817  0 
    videobuf2_core         39161  1 uvcvideo
    ttm                    71289  1 radeon
    mac80211              526519  1 iwldvm
    bluetooth             202226  11 bnep,btusb,rfcomm
    snd_hda_codec_realtek    63791  1 
    videodev               95806  2 uvcvideo,videobuf2_core
    snd_seq_midi           13132  0 
    snd_seq_midi_event     14475  1 snd_seq_midi
    drm_kms_helper         47545  1 radeon
    iwlwifi               155108  1 iwldvm
    snd_hda_intel          38307  5 
    snd_rawmidi            25114  1 snd_seq_midi
    microcode              18286  0 
    drm                   228489  5 ttm,drm_kms_helper,radeon
    lpc_ich                16925  0 
    cfg80211              436243  3 iwlwifi,mac80211,iwldvm
    snd_hda_codec         117617  3 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
    snd_hwdep              13272  1 snd_hda_codec
    psmouse                81065  0 
    snd_seq                51280  2 snd_seq_midi_event,snd_seq_midi
    i2c_algo_bit           13197  1 radeon
    snd_pcm                80890  3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
    serio_raw              13031  0 
    jmb38x_ms              17177  0 
    snd_page_alloc         14230  2 snd_pcm,snd_hda_intel
    snd_seq_device         14137  3 snd_seq,snd_rawmidi,snd_seq_midi
    memstick               15842  1 jmb38x_ms
    snd_timer              24411  2 snd_pcm,snd_seq
    snd                    56485  21 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,thinkpad_acpi,snd_seq_device
    wmi                    18590  0 
    soundcore              12600  1 snd
    video                  18894  0 
    mac_hid                13037  0 
    lp                     13299  0 
    parport                40753  3 lp,ppdev,parport_pc
    hid_generic            12484  0 
    usbhid                 41805  0 
    hid                    82666  2 hid_generic,usbhid
    r8169                  61543  0 
    sdhci_pci              18158  0 
    ahci                   25507  4 
    libahci                26108  1 ahci
    sdhci                  31824  1 sdhci_pci
    Code:
    home@home-PC:~$ ifconfig -a
    eth0      Link encap:Ethernet  HWaddr 60:eb:69:69:ba:0b  
              inet6 addr: fe80::62eb:69ff:fe69:ba0b/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:22 errors:0 dropped:0 overruns:0 frame:0
              TX packets:243 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:4146 (4.1 KB)  TX bytes:53116 (53.1 KB)
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:3768 errors:0 dropped:0 overruns:0 frame:0
              TX packets:3768 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:308666 (308.6 KB)  TX bytes:308666 (308.6 KB)
    
    wlan0     Link encap:Ethernet  HWaddr 00:26:c7:67:27:a8  
              inet addr:192.168.1.5  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::226:c7ff:fe67:27a8/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:18993 errors:0 dropped:0 overruns:0 frame:0
              TX packets:18978 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:13852229 (13.8 MB)  TX bytes:2795853 (2.7 MB)
    Code:
    home@home-PC:~$ cat /etc/resolv.conf
    # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
    #     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
    nameserver 127.0.1.1
    Code:
    home@home-PC:~$ route -n
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 wlan0
    192.168.1.0     0.0.0.0         255.255.255.0   U     9      0        0 wlan0

    Code:
    home@home-PC:~$ cat /etc/NetworkManager/NetworkManager.conf
    [main]
    plugins=ifupdown,keyfile
    dns=dnsmasq
    
    [ifupdown]
    managed=false
    Code:
    home@home-PC:~$ cat /var/lib/NetworkManager/NetworkManager.state
    [main]
    NetworkingEnabled=true
    WirelessEnabled=true
    WWANEnabled=true
    WimaxEnabled=true

  2. #2
    Join Date
    Mar 2011
    Location
    19th Hole
    Beans
    1,447
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Ubuntu 13.03 ethernet not working

    Thank you for posting with some info instead of just yelling for help. Good instincts and very commendable.

    Quote Originally Posted by tn88test View Post
    When I plug the cable in, Ubuntu can detect it but it can not be conneted.
    Please explain further what you mean by this. Ubuntu detects network cards (NIC), not cables. Since your NIC is being detected, the problem could simply be a mechanical one (i.e. defective cabling).

    1. Do you have another OS on your computer? If so, does this other OS connect to your router?
    2. I assume that your router acts as your dhcp server. Please confirm.
    3. Please try a different cable first. Then test any other cabling between your computer and your router (i.e. plug directly into your router with a known good cable).
    4. If you have another computer, does it connect to the router using exactly the same components?
    5. Is the cable connected firmly and properly to the NIC? If NIC is standalone card, is it seated properly in its slot?
    6. Is cable connected firmly and properly to router?
    Newb: How far must I jump to clear the ledge halfway down?
    Guru: It's bad to jump off cliffs. Let's look at better options.
    Newb: Stop harping about "best practices" and just let me jump.


  3. #3
    Join Date
    Jun 2013
    Beans
    16

    Re: Ubuntu 13.03 ethernet not working

    I just solve the problem by changing Ipv4 DHCP to static ip. But now I have another problem. I can't use wireless and ethernet at the same time. By the way it's no big deal. Thank you for your help!

  4. #4
    Join Date
    Feb 2008
    Location
    ɹǝpun uʍop
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: Ubuntu 13.03 ethernet not working

    Thread moved to Networking & Wireless.

    Please mark the thread as solved. Thanks. If you have any other problems, please start another thread for them.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •