Results 1 to 3 of 3

Thread: VPN and Internet Connection cannot Co-exist

  1. #1
    Join Date
    Nov 2010
    Beans
    7

    VPN and Internet Connection cannot Co-exist

    Hi,

    I have a PPTP VPN setup at my office. I'm trying to connect to it from my house on Ubuntu 12.10 x64. I can successfully connect, however when I do, I can only access remote resources (devices on the VPN). I can't access the internet.

    After some searching, I thought that if I checkded "Use this connection only for resources on its network" I would be set...that's not the case. When I checked this box, I was able to access the internet, but no remote resources.

    I know the VPN server is set correctly because I can successfully connect in this manner using a Windows computer. I've attached outputs of the route command in the various scenarios.

    Any help would be greatly appreciated.
    Attached Images Attached Images
    • File Type: png 1.png (39.6 KB, 6 views)
    • File Type: jpg 2.jpg (78.2 KB, 6 views)

  2. #2
    Join Date
    Nov 2010
    Beans
    7

    Re: VPN and Internet Connection cannot Co-exist

    I fixed it:

    I had to check "Ignore automatically obtained routes" and "Use this connection only for resources on its network" in the VPN routes configuration and I had to manually add the route for the remote network:

    sudo route add -net 192.168.1.0 netmask 255.255.255.0 gw 74.7.X.X

    Where 192.168.1.0 is the remote network and 74.7.X.X is the public IP of the remote network. After that it worked like a charm.

  3. #3
    Join Date
    Jan 2009
    Beans
    1

    Smile Re: VPN and Internet Connection cannot Co-exist

    Quote Originally Posted by rdp870 View Post
    I fixed it:

    I had to check "Ignore automatically obtained routes" and "Use this connection only for resources on its network" in the VPN routes configuration and I had to manually add the route for the remote network:

    sudo route add -net 192.168.1.0 netmask 255.255.255.0 gw 74.7.X.X

    Where 192.168.1.0 is the remote network and 74.7.X.X is the public IP of the remote network. After that it worked like a charm.
    This works, thanks

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •