Results 1 to 4 of 4

Thread: Xubuntu fails to communicate with cups

  1. #1
    Join Date
    Jun 2010
    Beans
    4

    Xubuntu fails to communicate with cups

    Hi!

    I use Xubuntu 12.10 and can't print. Cups is installed and running
    Code:
    status cups
    cups start/running, process 3759
    The Web interface at localhost:631 is working as well.

    But in the Settings Manager | Printers I get the message:
    "Printing service not available. Start the service on this computer or connect to another server."
    As a consequence I can't print in any applications since no printers show up.

    Any help is very much appreciated!

    Thanks,
    Martin

  2. #2
    Join Date
    Jun 2006
    Beans
    Hidden!
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Xubuntu fails to communicate with cups

    From looking around, it seems like the fix is to go into System / Printing and Delete your printer. Then reboot and add the printer back.

  3. #3
    Join Date
    Jun 2010
    Beans
    4

    Re: Xubuntu fails to communicate with cups

    At the moment I don't have a printer installed.
    Adding a printer in the cups web interface works fine - I just can't use it in any XFCE printing dialogues.

  4. #4
    Join Date
    Jun 2010
    Beans
    4

    Re: Xubuntu fails to communicate with cups

    I have found the problem. For the record the problem was that in ~/.cups/client.conf contained a wrong port number. I am not sure how that happend, but changing it to
    Code:
    ServerName localhost:631
    made it work again.

    rai4shu2, thank you for your help!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •