Hi!, ryanvade,

You Posted:
Is it because I am using the liquorix kernel?
Liquorix is not something I know about; what version is it?

Have you checked that the correct linux-headers and linux-source are installed, as well as build-essential, prior to installing or re-installing the driver ??

If not, install them, remove --purge the installed nvidia driver and re-install it - or a later version.

Chao!, bogan.