Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Need help with bind9, permission denied

  1. #11
    Join Date
    Nov 2012
    Beans
    10

    Re: Need help with bind9, permission denied

    Ok, good Idea,
    This is how looks now my named.conf.local file:
    Code:
    //logging {
    //    channel query.log {
    //        file "/var/log/query.log";
    //        severity debug 3;
    //    };
    //    category queries { query.log; };
    //};
    // Consider adding the 1918 zones here, if they are not used in your
    // organization
    //include "/etc/bind/zones.rfc1918";
    //include "/etc/bind/rndc.key";
     
    zone "middle-earth.local" {
      type master;
      file "/etc/bind/db.middle-earth.local";
      //allow-transfer { 127.0.0.1; 172.20.100.0/24; };
      allow-transfer {"none";};
      //allow-update { key "rndc-key" };
      notify yes;
    };
    zone "100.20.172.in-addr.arpa" {
      type master;
      file "/etc/bind/db.172.20.100";
      allow-transfer {"none";}; //{ 127.0.0.1; 172.20.100.0/24; };
      //allow-update { key "rndc-key" };
      notify yes;
    };
    unfortunately the error is the same, permission denied and connection refused on rndc.

    Isn't there any command to disable rndc or unlink it from bind?
    Actually there aren't any references to rndc in the named config files....
    Should I try to reinstall compleetly bind9 ? purge bind9 and then reinstall?
    Last edited by mixwe; November 16th, 2012 at 11:06 AM.

  2. #12
    Join Date
    Feb 2011
    Location
    Coquitlam, B.C. Canada
    Beans
    1,466
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Need help with bind9, permission denied

    Sorry, I am out of ideas to try to help. For the port listenting part, I get this when bind starts:
    Code:
    .
    .
    .
    Nov 14 07:48:54 doug-64 named[32670]: automatic empty zone: B.E.F.IP6.ARPA
    Nov 14 07:48:54 doug-64 named[32670]: automatic empty zone: 8.B.D.0.1.0.0.2.IP6.ARPA
    Nov 14 07:48:54 doug-64 named[32670]: command channel listening on 127.0.0.1#953
    Nov 14 07:48:54 doug-64 named[32670]: zone 0.in-addr.arpa/IN: loaded serial 1
    Nov 14 07:48:54 doug-64 named[32670]: zone 10.in-addr.arpa/IN: loaded serial 1
    Nov 14 07:48:54 doug-64 named[32670]: zone 127.in-addr.arpa/IN: loaded serial 1
    .
    .
    .

  3. #13
    Join Date
    Nov 2012
    Beans
    10

    Re: Need help with bind9, permission denied

    Thank you very much for your help,
    I think I will go trough the process reinstalling the machine from scratch and show if it will work, I will try to install only bind9 an see if I can make it run.

    I will let you know.

  4. #14
    Join Date
    Nov 2012
    Beans
    10

    Re: Need help with bind9, permission denied

    So, I just reinstalled the server an I began direcly to install bind and dnsutils.

    I just configured some basic settings in named.conf.local
    named.conf.options
    and 2 db files.

    The result is:

    Code:
    sudo service bind9 restart
     * Stopping domain name service... bind9                                                                                         rndc: connect failed: 127.0.0.1#953: connection refused
                                                                                                                              [ OK ]
     * Starting domain name service... bind9                                                                                  [ OK ]
    I still get the error about rndc, but the service starts.

    I'm trying to configure some more settings and show it it will work correctly.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •