Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: nvidia 295.xx for Ubuntu 12.10

  1. #1
    Join Date
    May 2009
    Beans
    16

    nvidia 295.xx for Ubuntu 12.10

    Does anyone has working deb drivers for nvidia cards for 12.10 from 295.xx family? I literally searched whole internet by now.


    N00bslab has apparantly created debs
    http://www.noobslab.com/2012/06/nvid...ction-for.html
    but they need xorg-video-abi which is not in 12.10 repo.

    Ideas?

  2. #2
    Join Date
    Dec 2010
    Location
    Fukuoka, Japan
    Beans
    1,062
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: nvidia 295.xx for Ubuntu 12.10

    http://www.geforce.com/drivers/beta-legacy

    You dont need a .deb file. Just download the drivers from Nvidia, kill your X server, and run the script from the command line. Beware that you may break your system.

  3. #3
    Join Date
    May 2009
    Beans
    16

    Re: nvidia 295.xx for Ubuntu 12.10

    But I will still have to reinstall nvidia each time kernel update, right?

  4. #4
    Join Date
    Feb 2010
    Location
    WI USA
    Beans
    10,434
    Distro
    Ubuntu Development Release

    Re: nvidia 295.xx for Ubuntu 12.10

    The date of that post concerns me a bit. That site has listed items as being compatible with versions of which they are not. I have found this to be true with their theme ppas. Since it's a deb. package the most that can happen is that the dependencies won't be found and it won't install.
    Infinite diversity in infinite combination.

    Ubuntu Documentation Search: Popular Pages
    Ubuntu: Security Basics
    Ubuntu: Manual

  5. #5
    Join Date
    Dec 2010
    Location
    Fukuoka, Japan
    Beans
    1,062
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: nvidia 295.xx for Ubuntu 12.10

    Quote Originally Posted by Majki-Fajki View Post
    But I will still have to reinstall nvidia each time kernel update, right?
    That I dont know about. I know that Ive never had to reinstall a driver after a kernel update though.

  6. #6
    Join Date
    May 2006
    Location
    Milwaukee,WI
    Beans
    6,281
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: nvidia 295.xx for Ubuntu 12.10

    Quote Originally Posted by whatthefunk View Post
    That I dont know about. I know that Ive never had to reinstall a driver after a kernel update though.
    if a module (driver) is installed its compiled against the currently installed kernel at that time. the nvidia driver from the website in fact does this, it's a script that builds the driver against your current kernel. So, YES, if you're running an nvidia driver from their website that gets installed via their script, it will need to be reinstalled when a kernel upgrade occurs so that it can be compiled against the new kernel.

  7. #7
    Join Date
    Dec 2010
    Location
    Fukuoka, Japan
    Beans
    1,062
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: nvidia 295.xx for Ubuntu 12.10

    Quote Originally Posted by dannyboy79 View Post
    if a module (driver) is installed its compiled against the currently installed kernel at that time. the nvidia driver from the website in fact does this, it's a script that builds the driver against your current kernel. So, YES, if you're running an nvidia driver from their website that gets installed via their script, it will need to be reinstalled when a kernel upgrade occurs so that it can be compiled against the new kernel.
    Learn something new every day

  8. #8
    Join Date
    Feb 2010
    Location
    Nr BrandsHatch, S'oaks UK
    Beans
    1,241
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: nvidia 295.xx for Ubuntu 12.10

    Hi!, dannyboy79, et alia,

    YOU Posted:
    So, YES, if you're running an nvidia driver from their website that gets installed via their script, it will need to be reinstalled when a kernel upgrade occurs so that it can be compiled against the new kernel.
    That was true for the 295.xxx nvidia drivers and before, but not for 304.xx onwards.

    The recent nvidia.com drivers are DKMS compatible, so the kernal module gets updated, just as it does with the Ubuntu ppa nvidia-current drivers.

    Chao!, bogan.
    "Better Solutions may bring Worsened Problems": After Lao Tse, b. circa 405BC. a contemporary of Confucius, who died circa 600BC.
    They did things differently in those days, apparently!!

  9. #9
    Join Date
    May 2009
    Beans
    16

    Re: nvidia 295.xx for Ubuntu 12.10

    Well, I installed 12.04 again. I really wanted to have 3.4+ kernel

    Thanks guys.

  10. #10
    Join Date
    May 2006
    Location
    Milwaukee,WI
    Beans
    6,281
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: nvidia 295.xx for Ubuntu 12.10

    Quote Originally Posted by Majki-Fajki View Post
    Well, I installed 12.04 again. I really wanted to have 3.4+ kernel

    Thanks guys.
    if you really wanted the 3.4+ kernel then why did you give up?

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •