Page 1 of 4 123 ... LastLast
Results 1 to 10 of 36

Thread: USB adapter doesn’t connect

  1. #1
    Join Date
    Mar 2010
    Beans
    26

    Question USB adapter doesn’t connect

    I’m recently installed ubuntu 12.10 side by windows 7. My USB adapter doesn’t connect to internet with ubuntu but with windows it’s OK. I’m not that much familiar with ubuntu OS Adapter model No D-Link DWM-156 please help me

  2. #2
    Join Date
    Sep 2012
    Location
    Gnome12o4/LXQt14o4
    Beans
    Hidden!

    Re: USB adapter doesn’t connect


  3. #3
    Join Date
    Mar 2010
    Beans
    26

    Re: USB adapter doesn’t connect

    That page didn’t help me

  4. #4
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,300
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: USB adapter doesn’t connect

    Connect the adapter to the computer, then open the terminal, run the following command and post back its output -
    Code:
    lsusb
    And did you attempt the fix suggested at this link indicated on the bug report page ibjsb4 linked to ?
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  5. #5
    Join Date
    Mar 2010
    Beans
    26

    Re: USB adapter doesn’t connect

    us 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
    Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 003: ID 067b:2305 Prolific Technology, Inc. PL2305 Parallel Port
    Bus 001 Device 004: ID 07d1:7e11 D-Link System
    Bus 001 Device 005: ID 046d:c016 Logitech, Inc. Optical Wheel Mouse
    Bus 002 Device 003: ID 0951:1624 Kingston Technology DataTraveler G2 4GB Pen Drive

  6. #6
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,300
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: USB adapter doesn’t connect

    Quote Originally Posted by modernhenry View Post
    Bus 001 Device 004: ID 07d1:7e11 D-Link System
    These are your adapter's vendor and product IDs respectively.

    So what happens after plugging in the adapter ? Do you notice any change anywhere in the system ?

    Please also post -
    Code:
    dmesg | tail -20
    usb-devices | grep -iB2 -A10 7e11
    lsmod
    about 4-6 seconds after plugging in the adapter.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  7. #7
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,300
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: USB adapter doesn’t connect

    Just found a possible solution reported to be working for this chip. Regardless, please post the outputs I asked above anyway, then try this -
    http://ubuntuforums.org/showthread.php?p=12132847

    And let us know the outcome.

    Thanks.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  8. #8
    Join Date
    Mar 2010
    Beans
    26

    Re: USB adapter doesn’t connect

    This is the output
    Thanks.
    henry@henry-desktop:~$ dmesg | tail -20
    [ 325.465009] scsi 7:0:0:0: >CD-ROM HSPA USB SCSI CD-ROM 2.31 PQ: 0 ANSI: 2
    [ 325.468776] sr1: scsi-1 drive
    [ 325.468957] sr 7:0:0:0: >Attached scsi CD-ROM sr1
    [ 325.469105] sr 7:0:0:0: >Attached scsi generic sg3 type 5
    [ 326.727462] usb 1-1.2: >USB disconnect, device number 5
    [ 326.924161] usb 1-1.2: >new high-speed USB device number 6 using ehci_hcd
    [ 327.018691] usb 1-1.2: >New USB device found, idVendor=07d1, idProduct=7e11
    [ 327.018696] usb 1-1.2: >New USB device strings: Mfr=3, Product=2, SerialNumber=4
    [ 327.018699] usb 1-1.2: >Product: D-Link WCDMA Technologies MSM
    [ 327.018702] usb 1-1.2: >Manufacturer: D-Link,Incorporated
    [ 327.018705] usb 1-1.2: >SerialNumber: MF112DDLKD010000
    [ 327.021988] scsi8 : usb-storage 1-1.2:1.2
    [ 328.019144] scsi 8:0:0:0: >CD-ROM HSPA USB SCSI CD-ROM 2.31 PQ: 0 ANSI: 2
    [ 328.019841] scsi 8:0:0:1: >Direct-Access D-Link MMC Storage 2.31 PQ: 0 ANSI: 2
    [ 328.024296] sr1: scsi-1 drive
    [ 328.024523] sr 8:0:0:0: >Attached scsi CD-ROM sr1
    [ 328.024702] sr 8:0:0:0: >Attached scsi generic sg3 type 5
    [ 328.025225] sd 8:0:0:1: >Attached scsi generic sg4 type 0
    [ 328.027632] sd 8:0:0:1: >[sdc] Attached SCSI removable disk
    [ 330.020586] usb_modeswitch_[2324]: segfault at 0 ip b7631ee1 sp bfcc385c error 4 in libc-2.15.so[b75b4000+1a3000]
    henry@henry-desktop:~$ usb-devices | grep -iB2 -A10 7e11
    T: Bus=01 Lev=02 Prnt=02 Port=01 Cnt=02 Dev#= 6 Spd=480 MxCh= 0
    D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
    P: Vendor=07d1 ProdID=7e11 Rev=00.00
    S: Manufacturer=D-Link,Incorporated
    S: Product=D-Link WCDMA Technologies MSM
    S: SerialNumber=MF112DDLKD010000
    C: #Ifs= 4 Cfg#= 1 Atr=e0 MxPwr=500mA
    I: If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
    I: If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
    I: If#= 2 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
    I: If#= 3 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)

    T: Bus=01 Lev=02 Prnt=02 Port=03 Cnt=03 Dev#= 4 Spd=1.5 MxCh= 0
    henry@henry-desktop:~$ lsmod
    Module Size Used by
    nls_utf8 12493 1
    nls_iso8859_1 12617 1
    isofs 39210 1
    snd_hda_codec_hdmi 31423 1
    snd_hda_codec_realtek 63356 1
    bnep 17707 2
    rfcomm 37276 0
    bluetooth 183228 10 bnep,rfcomm
    coretemp 13168 0
    kvm_intel 126745 0
    kvm 357806 1 kvm_intel
    ppdev 12817 0
    snd_hda_intel 32515 3
    snd_hda_codec 111547 3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_i ntel
    snd_hwdep 13272 1 snd_hda_codec
    snd_pcm 80163 3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
    snd_seq_midi 13132 0
    snd_rawmidi 25382 1 snd_seq_midi
    usblp 17751 0
    snd_seq_midi_event 14475 1 snd_seq_midi
    microcode 18209 0
    parport_pc 31968 1
    snd_seq 51255 2 snd_seq_midi,snd_seq_midi_event
    serio_raw 13031 0
    snd_timer 24411 2 snd_pcm,snd_seq
    snd_seq_device 14137 3 snd_seq_midi,snd_rawmidi,snd_seq
    snd 61991 16 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_i ntel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,s nd_seq,snd_timer,snd_seq_device
    mac_hid 13037 0
    soundcore 14599 1 snd
    snd_page_alloc 14036 2 snd_hda_intel,snd_pcm
    lpc_ich 16925 0
    i915 457161 3
    drm_kms_helper 45271 1 i915
    drm 230463 4 i915,drm_kms_helper
    i2c_algo_bit 13197 1 i915
    video 18847 1 i915
    mei 35796 0
    lp 13299 0
    parport 40753 3 ppdev,parport_pc,lp
    hid_generic 12445 0
    usbhid 41702 0
    hid 82142 2 hid_generic,usbhid
    e1000e 174645 0
    usb_storage 39350 1
    henry@henry-desktop:~$

    When I plugging the adapter their is no any changes. thanks

  9. #9
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,300
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: USB adapter doesn’t connect

    So it is properly detected but not identified as a modem yet. Please try the solution I linked to in my previous post and let us know how it goes.

    Feel free to ask if you have any troubles in understanding or implementing it.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  10. #10
    Join Date
    Mar 2010
    Beans
    26

    Re: USB adapter doesn’t connect

    Page No 61 in your link this the output

    henry@henry-desktop:~$ cp /usr/shaer/usb_modeswitch/configpack.tag.gz /home/testcp: cannot stat `/usr/shaer/usb_modeswitch/configpack.tag.gz': No such file or directory
    henry@henry-desktop:~$
    I went through but did not,thank you so much you are spend your valuable time for me

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •