Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Avidemux

  1. #1
    Join Date
    Jul 2012
    Location
    EU - Slovenia
    Beans
    60
    Distro
    Ubuntu 12.04 Precise Pangolin

    Avidemux

    Hello...

    I tried to capture some tv show from my DVB-T receiver. The kaffeine does work's nicely.
    But the recorded file is m2t type and with a lot of commercials.
    So I try AviDemux 2.6.0 (r8273) in my ubuntu 12.04.
    The cutting works nice. Well if I don't forget to align all cut's in I frame. But it's ok.
    The problem is that I have standalone DVD/Player/recorder capable to play divx. But I can't produce the right one with avidemux. Is it possible at all?
    the unit is LG RH265.

    For now I can produce playable file only with mencorder with that settings:
    mencoder test.m2t -o test.avi -ovc lavc -oac mp3lame -ffourcc DX50

    Is it possible to make same output with Avidemux to avoid double conversion?

    Thanks.

    p.s.
    It's really question for avidemux forum but I can't register as no new registration is accepted.

  2. #2
    Join Date
    Apr 2009
    Location
    Aotearoha
    Beans
    2,661
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Avidemux

    Your recorded files are mpeg2-ts transport stream..

    Lots of programs call DivX Xvid by the real name mpeg4/layer2 or mpeg4-visual or ASP &/or leave off the layer2 or -asp (just to add confusion).

    So mpeg4/layer10 is H264AVC (H264)
    mpeg4-visual is mpeg4/2 is mpeg4-asp is DivX Xvid etc (MPEG4).
    (likely avidemux labels)

  3. #3
    Join Date
    Jul 2012
    Location
    EU - Slovenia
    Beans
    60
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Avidemux

    Well I know that naming scheme for divx is al little mess.
    And my DVD recorder is a little bit picky. I tried a lot of variant made with different programs but only that made with mencoder are digestible for them.
    But I tryed just short examples. Yesterday I try to convert bigger file but mencoder give me a error.

    Code:
    1 duplicate frame(s)!
    Pos: 184.9s   8413f (10%) 71.76fps Trem:  16min 448mb  A-V:-0.042 [1911:243]
    
    1 duplicate frame(s)!
    Pos: 185.2s   8423f (10%) 71.75fps Trem:  16min 448mb  A-V:-0.042 [1911:243]
    
    1 duplicate frame(s)!
    Pos: 185.3s   8431f (10%) 71.74fps Trem:  16min 448mb  A-V:-0.038 [1912:243]
    
    Too many audio packets in the buffer: (4096 in 2359296 bytes).
    Maybe you are playing a non-interleaved stream/file or the codec failed?
    For AVI files, try to force non-interleaved mode with the -ni option.
    
    Flushing video frames.
    Writing index...
    Writing header...
    ODML: vprp aspect is 16384:9004.
    Setting audio delay to 0.024s.
    
    Video stream: 1912.263 kbit/s  (239032 B/s)  size: 44302348 bytes  185.340 secs  8431 frames
    
    Audio stream:  243.901 kbit/s  (30487 B/s)  size: 5666304 bytes  185.856 secs
    so actually I have no solution how to prepare video for my player.
    The only way working is to make DVD disc. But it's space inefficient.
    HELP..

    Slavko

  4. #4
    Join Date
    Apr 2009
    Location
    Aotearoha
    Beans
    2,661
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Avidemux

    I don't ever use AVI file container & avoid XVid etc..
    I use MythTV & generate a cutlist & cut the original HD h264 files & play them on a HTPC.

    There could be multiple problems..
    1. AVI container with advanced video codecs (any MPEG4) is a ugly hack because the container does not support out of order frames.
    So there are multiple hacks like packed B-frames etc
    Basically .avi is obsolete.

    2. Discovering the player requirements..
    - for the container
    - for the DivX codec (& the audio codec)

    3.AviDeMUX 2.5 does not work with mpeg4/10 h264/avc..you must have mpeg2 video over dvb-t
    The latest AviDeMux 2.6 purports to work h264.

    Does your TV or DVD/BD player support DLNA?

  5. #5
    Join Date
    Jul 2012
    Location
    EU - Slovenia
    Beans
    60
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Avidemux

    I think I'm loocked to avi due player restriction.

    Is it there some example files for different containers and codecs to easy test if player works on that

    DLNA what is?

  6. #6
    Join Date
    Jul 2012
    Location
    EU - Slovenia
    Beans
    60
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Avidemux

    Now I know little more.
    I can transcode video in windows version of avidemux.

    Under linux there are no xvid available for video.

    The resulting video stream that works on my player (as is reported in Mediainfo) made with Avidemux 2.6.0 windows) is:
    8711 Kbps, 720*576 (5:4), at 25 fps, MPEG-4 Visual (DivX 4) (PAL) (Advanced Simple@L4) (BVOP2)

    And closest possible made in ubuntu with Avidemux 2.6.0 (r8273) is :
    1531 Kbps, 720*576 (5:4), at 25 fps, MPEG-4 Visual (DivX 4) (PAL) (Advanced Simple@L1) (BVOP2)

    So the difference is in @L1 vs @L4. Audio works as MP3 or AC3.
    (Windows version had xvid in dropdown menu)

    Really want to leave windoze....

    Any solution?

  7. #7
    Join Date
    Apr 2009
    Location
    Aotearoha
    Beans
    2,661
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Avidemux

    There was some discussion about the DivX encoder on the avidemux.org forums in the linux or experimental 2.6 section..
    http://avidemux.org/smuf/index.php/topic,11546.0.html

    http://avidemux.org/smuf/index.php/topic,11402.0.html
    That thread is rambling & confusing..

    Your info suggests there is a DivX encoder but has the wrong/different configuration. The bitrates are very different.

    A DVD is allowed 10Mbps for sum of all streams.

  8. #8
    Join Date
    Jul 2012
    Location
    EU - Slovenia
    Beans
    60
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Avidemux

    I tryed many bitrates.. from 1000 to 8000kbps with same results. Over 8000 motion come jerky and audio distorted.

  9. #9
    Join Date
    Apr 2009
    Location
    Aotearoha
    Beans
    2,661
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Avidemux

    If latest avidemux has broken the Xvid encode then just use the old 2.5 version..

    Or use it to cut the video file & leave the video as mpeg2video..
    Then convert with mencoder or ffmpeg (real one not avconv)

    ffmpeg -i input.mpg -c:a libmp3lame -c:v mpeg4 -mbd rd -vtag xvid -flags +ilme+ildct+mv4+aic -trellis 2 -cmp 2 -subcmp 2 -g 300 out.avi

    I just made this cmd up..could need some work..

  10. #10
    Join Date
    Jul 2012
    Location
    EU - Slovenia
    Beans
    60
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Avidemux

    I tried few options but still not get usable result.

    and command fail...
    Code:
    slavko@ePodstresnik:~/DVB_RECORDS$ ffmpeg -i minuta.mp4 -c:a libmp3lame -c:v mpeg4 -mbd rd -vtag xvid -flags +ilme+ildct+mv4+aic -trellis 2 -cmp 2 -subcmp 2 -g 300 out.avi
    ffmpeg version 0.8.4-4:0.8.4-0ubuntu0.12.04.1, Copyright (c) 2000-2012 the Libav developers
      built on Nov  6 2012 16:51:33 with gcc 4.6.3
    *** THIS PROGRAM IS DEPRECATED ***
    This program is only provided for compatibility and will be removed in a future release. Please use avconv instead.
    [mov,mp4,m4a,3gp,3g2,mj2 @ 0x20019a0] multiple edit list entries, a/v desync might occur, patch welcome
        Last message repeated 1 times
    Seems stream 0 codec frame rate differs from container frame rate: 50.00 (50/1) -> 50.00 (50/1)
        Last message repeated 1 times
    Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'minuta.mp4':
      Metadata:
        major_brand     : isom
        minor_version   : 512
        compatible_brands: isomiso2avc1mp41
        encoder         : Lavf54.29.104
      Duration: 00:01:00.17, start: 0.129000, bitrate: 1726 kb/s
        Stream #0.0(und): Video: h264 (Main), yuv420p, 720x576 [PAR 12:11 DAR 15:11], 1530 kb/s, 25.02 fps, 50 tbr, 50k tbn, 50 tbc
        Stream #0.1(und): Audio: mp2, 48000 Hz, 2 channels, s16, 192 kb/s
    Unrecognized option 'c:a'
    Failed to set value 'libmp3lame' for option 'c:a'
    slavko@ePodstresnik:~/DVB_RECORDS$
    The options I managed to make readable file is:

    Code:
    mencoder test.m2t -o out003.avi -ovc lavc -oac mp3lame -ffourcc DX50
    or

    Code:
    ffmpeg -i test.m2t -f avi -b 2500k -vcodec msmpeg4 out008.avi
    But the problems with both is that works for short files. On longer ones both output errors

    Mencoder:
    Code:
    snip snip
    
    
    1 duplicate frame(s)!
    Pos: 114.7s   5215f (12%) 175.55fps Trem:   3min 112mb  A-V:-0.041 [814:242]
    
    1 duplicate frame(s)!
    Pos: 114.9s   5225f (12%) 175.51fps Trem:   3min 112mb  A-V:-0.041 [814:242]
    
    1 duplicate frame(s)!
    Pos: 115.1s   5235f (13%) 175.54fps Trem:   3min 112mb  A-V:-0.041 [814:242]
    
    1 duplicate frame(s)!
    Pos: 115.3s   5245f (13%) 175.56fps Trem:   3min 112mb  A-V:-0.041 [814:242]
    
    1 duplicate frame(s)!
    Pos: 115.6s   5255f (13%) 175.55fps Trem:   3min 112mb  A-V:-0.041 [814:242]
    
    1 duplicate frame(s)!
    Pos: 115.8s   5265f (13%) 175.54fps Trem:   3min 112mb  A-V:-0.041 [813:242]
    
    1 duplicate frame(s)!
    Pos: 116.0s   5275f (13%) 175.54fps Trem:   3min 111mb  A-V:-0.041 [813:242]
    
    1 duplicate frame(s)!
    Pos: 116.2s   5285f (13%) 175.62fps Trem:   3min 112mb  A-V:-0.041 [813:242]
    
    1 duplicate frame(s)!
    Pos: 116.4s   5295f (13%) 175.54fps Trem:   3min 112mb  A-V:-0.041 [817:242]
    
    1 duplicate frame(s)!
    Pos: 116.7s   5305f (13%) 175.46fps Trem:   3min 112mb  A-V:-0.041 [818:243]
    
    1 duplicate frame(s)!
    Pos: 116.9s   5315f (13%) 175.37fps Trem:   3min 112mb  A-V:-0.041 [819:243]
    
    1 duplicate frame(s)!
    Pos: 117.1s   5325f (13%) 175.26fps Trem:   3min 112mb  A-V:-0.041 [821:243]
    
    1 duplicate frame(s)!
    Pos: 117.3s   5335f (13%) 175.19fps Trem:   3min 112mb  A-V:-0.041 [822:243]
    
    1 duplicate frame(s)!
    Pos: 117.5s   5345f (13%) 175.18fps Trem:   3min 112mb  A-V:-0.041 [823:243]
    
    1 duplicate frame(s)!
    Pos: 117.8s   5355f (13%) 175.14fps Trem:   3min 112mb  A-V:-0.041 [824:243]
    
    1 duplicate frame(s)!
    Pos: 118.0s   5365f (13%) 175.04fps Trem:   3min 112mb  A-V:-0.041 [825:243]
    
    1 duplicate frame(s)!
    Pos: 118.2s   5375f (13%) 175.01fps Trem:   3min 112mb  A-V:-0.041 [825:243]
    
    1 duplicate frame(s)!
    Pos: 118.4s   5385f (13%) 175.02fps Trem:   3min 112mb  A-V:-0.041 [824:243]
    
    1 duplicate frame(s)!
    Pos: 118.6s   5395f (13%) 174.99fps Trem:   3min 112mb  A-V:-0.041 [823:243]
    
    1 duplicate frame(s)!
    Pos: 118.9s   5405f (13%) 175.02fps Trem:   3min 112mb  A-V:-0.041 [823:243]
    
    1 duplicate frame(s)!
    Pos: 119.1s   5415f (13%) 175.00fps Trem:   3min 112mb  A-V:-0.041 [822:243]
    
    1 duplicate frame(s)!
    Pos: 119.3s   5425f (13%) 174.99fps Trem:   3min 112mb  A-V:-0.041 [821:243]
    
    1 duplicate frame(s)!
    Pos: 119.5s   5435f (13%) 174.97fps Trem:   3min 112mb  A-V:-0.041 [821:243]
    
    1 duplicate frame(s)!
    Pos: 119.7s   5445f (13%) 174.96fps Trem:   3min 112mb  A-V:-0.041 [820:243]
    
    1 duplicate frame(s)!
    Pos: 120.0s   5455f (13%) 174.95fps Trem:   3min 112mb  A-V:-0.041 [820:243]
    
    1 duplicate frame(s)!
    Pos: 120.2s   5465f (13%) 174.96fps Trem:   3min 111mb  A-V:-0.041 [820:243]
    
    1 duplicate frame(s)!
    Pos: 120.4s   5475f (13%) 174.91fps Trem:   3min 111mb  A-V:-0.041 [820:243]
    
    1 duplicate frame(s)!
    Pos: 120.6s   5485f (13%) 174.90fps Trem:   3min 111mb  A-V:-0.041 [820:243]
    
    1 duplicate frame(s)!
    Pos: 120.8s   5495f (13%) 174.87fps Trem:   3min 111mb  A-V:-0.041 [820:243]
    
    1 duplicate frame(s)!
    Pos: 120.9s   5499f (13%) 174.84fps Trem:   3min 111mb  A-V:-0.029 [820:243]
    
    Too many audio packets in the buffer: (4096 in 2359296 bytes).
    Maybe you are playing a non-interleaved stream/file or the codec failed?
    For AVI files, try to force non-interleaved mode with the -ni option.
    
    Flushing video frames.
    Writing index...
    Writing header...
    ODML: Aspect information not (yet?) available or unspecified, not writing vprp header.
    
    Video stream:  820.349 kbit/s  (102543 B/s)  size: 12401621 bytes  120.940 secs  5499 frames
    
    Audio stream:  243.940 kbit/s  (30492 B/s)  size: 3703008 bytes  121.440 secs
    slavko@ePodstresnik:~/DVB_RECORDS$

    ffmpeg got multiple times something like:
    Code:
    [h264 @ 0x1152dc0] reference picture missing during reorder
    [h264 @ 0x1152dc0] Missing reference picture
    [msmpeg4 @ 0x13faa00] warning, clipping 1 dct coefficients to -127..127ts/s
    and out of sync audio at the end of the file.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •