Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: Cannot install LibreOffice on Ubuntu 10.04 Lucid

  1. #11
    Join Date
    Dec 2009
    Beans
    29
    Distro
    Ubuntu

    Re: Cannot install LibreOffice on Ubuntu 10.04 Lucid

    hello. I also I have ubuntu lucid. and also had the same problem. the problem itself is with repositories of libreoffice only packages are available for versions 11.10, 12.04 and 12.10. you just need to remove the repository of libreoffice and add this new repository if it works:

    Code:
    sudo add-apt-repository ppa:ricotz/ppa
    Code:
    sudo aptitude update
    Code:
    sudo apt-get install libreoffice libreoffice-gnome
    This repository will install version 3.5.7.2. but at least this version works great.

    NOTE: These are official repositories. packages are made ​​by the same who run the repository libreoffice: Rico Tzschichholz. Just in case you can check the repository Launchpad page you suggest and official page LibreOffice repository.

    https://launchpad.net/~ricotz/+archive/ppa

    https://launchpad.net/~libreoffice/+archive/ppa
    Last edited by ercherramon; November 13th, 2012 at 02:59 AM. Reason: give a little more argument in my comment.

  2. #12
    Join Date
    May 2009
    Location
    Indiana
    Beans
    1,757
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Cannot install LibreOffice on Ubuntu 10.04 Lucid

    There are two official PPAs for LibreOffice.

    For test builds and backports:
    Code:
    sudo add-apt-repository ppa:libreoffice/ppa
    For a more stable experience:
    Code:
    sudo add-apt-repository ppa:libreoffice/libreoffice-3-5
    Both should work on Lucid:
    https://launchpad.net/~libreoffice/+...s_filter=lucid
    https://launchpad.net/~libreoffice/+...s_filter=lucid
    Jane, stop this crazy thing!

  3. #13
    Join Date
    Dec 2009
    Beans
    29
    Distro
    Ubuntu

    Re: Cannot install LibreOffice on Ubuntu 10.04 Lucid

    Quote Originally Posted by newb85 View Post
    There are two official PPAs for LibreOffice.

    For test builds and backports:
    Code:
    sudo add-apt-repository ppa:libreoffice/ppa
    For a more stable experience:
    Code:
    sudo add-apt-repository ppa:libreoffice/libreoffice-3-5
    Both should work on Lucid:
    https://launchpad.net/~libreoffice/+...s_filter=lucid
    https://launchpad.net/~libreoffice/+...s_filter=lucid
    thanks for pointing out the case of the repositories, but I would also say that the repository I mentioned above is also official and has nothing unusual as it was also done by the same officers up libreoffice packages. the matter is that unfortunately libreoffice has not updated great packages for Ubuntu Lucid and therefore gives errors with the upgrade package libreoffice-core

  4. #14
    Join Date
    Nov 2006
    Beans
    216

    Re: Cannot install LibreOffice on Ubuntu 10.04 Lucid

    hi
    someone that knows how should probably fix this page
    https://wiki.ubuntu.com/LibreOffice#...3de3dfb5639851

    to reflect monkeybrain2012 solution to this problem also about the difference in the PPAs

  5. #15
    Join Date
    Mar 2010
    Location
    Basque Country
    Beans
    15
    Distro
    Ubuntu UNR

    Wink Re: Cannot install LibreOffice on Ubuntu 10.04 Lucid

    Quote Originally Posted by ercherramon View Post
    hello. I also I have ubuntu lucid. and also had the same problem. the problem itself is with repositories of libreoffice only packages are available for versions 11.10, 12.04 and 12.10. you just need to remove the repository of libreoffice and add this new repository if it works:

    Code:
    sudo add-apt-repository ppa:ricotz/ppa
    Code:
    sudo aptitude update
    Code:
    sudo apt-get install libreoffice libreoffice-gnome
    This repository will install version 3.5.7.2. but at least this version works great.

    NOTE: These are official repositories. packages are made ​​by the same who run the repository libreoffice: Rico Tzschichholz. Just in case you can check the repository Launchpad page you suggest and official page LibreOffice repository.

    https://launchpad.net/~ricotz/+archive/ppa

    https://launchpad.net/~libreoffice/+archive/ppa
    Thank you very much! Definitely this works. I was getting crazy all the time trying to install OOo and/or LibreOffice from the other repositories. With your help now it works great.

  6. #16
    Join Date
    Dec 2006
    Location
    France
    Beans
    1,007
    Distro
    Xubuntu 13.10 Saucy Salamander

    Re: Cannot install LibreOffice on Ubuntu 10.04 Lucid

    Or instead of messing up with repositories, better use the official .debs provided on their websites, they allow to install and run AOO and LibO in parallel.

    See [Ubuntu] Installing OOo on Debian and Co.
    Ubuntu user # 14396

  7. #17
    Join Date
    Oct 2012
    Beans
    5

    Cool Re: Cannot install LibreOffice on Ubuntu 10.04 Lucid

    Quote Originally Posted by newb85 View Post

    For a more stable experience:
    Code:
    sudo add-apt-repository ppa:libreoffice/libreoffice-3-5

    I can confirm, this works perfectly for Ubuntu 10.04.4.

    So,
    Code:
    sudo apt-get purge openoffice*
    ... removed Openoffice
    I added this repo line in Terminal, then:
    Code:
    sudo apt-get update && sudo apt-get install libreoffice
    This installed a fully functional Libreoffice.

    THANK YOU!

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •