Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Cannot install LibreOffice on Ubuntu 10.04 Lucid

  1. #1
    Join Date
    Jun 2012
    Beans
    22

    Cannot install LibreOffice on Ubuntu 10.04 Lucid

    Hello everyone,

    I'm running into a bit of trouble, and i can't seem to figure out the problem. I have tried adding the key for LibreOffice and was successful in doing so. however, after updating and trying to install Libre, it is producing the following error.

    "libreoffice:
    Depends: libreoffice-core but it is not going to be installed
    Depends: libreoffice-writer but it is not going to be installed
    Depends: libreoffice-calc but it is not going to be installed
    Depends: libreoffice-impress but it is not going to be installed
    Depends: libreoffice-draw but it is not going to be installed
    Depends: libreoffice-math but it is not going to be installed
    Depends: libreoffice-base but it is not going to be installed
    Depends: libreoffice-filter-mobiledev but it is not going to be installed
    Depends: libreoffice-java-common but it is not going to be installed
    Recommends: libreoffice-gnome but it is not going to be installed or
    libreoffice-kde but it is not going to be installed"

    I haven't a clue as to why this continues to come up. It's quite vague.
    Attached is the screenshot of the error.

    Can anyone help me out?

    Thank you,
    Attached Images Attached Images

  2. #2
    Join Date
    May 2009
    Location
    Indiana
    Beans
    1,784
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Cannot install LibreOffice on Ubuntu 10.04 Lucid

    Quote Originally Posted by markless View Post
    I have tried adding the key for LibreOffice and was successful in doing so.
    What do you mean by this? Are you referring to the GPG key? Or perhaps you meant that you added the LibreOffice PPA?
    Jane, stop this crazy thing!

  3. #3
    Join Date
    Nov 2005
    Location
    Lincolnshire, UK
    Beans
    1,461
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Cannot install LibreOffice on Ubuntu 10.04 Lucid

    markless: Can I ask why you wish to do this?

    The default office suite in Lucid is OpenOffice, rather than LibreOffice, and so this should already be installed.

    Leaving "politics" aside, OpenOffice and LibreOffice are basically the same application with effectively identical functionality.

    Is there anything you consider can be done with LibreOffice that you currently cannot do with OpenOffice?

  4. #4
    Join Date
    Oct 2012
    Beans
    874

    Re: Cannot install LibreOffice on Ubuntu 10.04 Lucid

    10.04 comes with OpenOffice.org which is in conflict with LibreOffice, you have to remove it first. To get rid of everything in the terminal type

    sudo apt-get autoremove openoffice*

    See if you can install LibreOffice afterwards.

  5. #5
    Join Date
    Oct 2012
    Beans
    874

    Re: Cannot install LibreOffice on Ubuntu 10.04 Lucid

    Quote Originally Posted by Zill View Post
    markless: Can I ask why you wish to do this?

    The default office suite in Lucid is OpenOffice, rather than LibreOffice, and so this should already be installed.

    Leaving "politics" aside, OpenOffice and LibreOffice are basically the same application with effectively identical functionality.

    Is there anything you consider can be done with LibreOffice that you currently cannot do with OpenOffice?
    Yes, Lucid comes with a really old version of OpenOffice, I don't know about the new apache OpenOffice (never use it) but Libreoffice is definitely a lot faster than the Lucid version, among other things.

    @OP why are you still using Lucid? I remember what it was like, it is like ancient history now.
    Last edited by monkeybrain2012; November 10th, 2012 at 11:41 PM.

  6. #6
    Join Date
    May 2009
    Location
    Indiana
    Beans
    1,784
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Cannot install LibreOffice on Ubuntu 10.04 Lucid

    Quote Originally Posted by Zill View Post
    Leaving "politics" aside, OpenOffice and LibreOffice are basically the same application with effectively identical functionality
    Leaving politics aside would obscure a minor point of contention with your general comparison. If a large contingent of developers left OpenOffice for LibreOffice because OpenOffice's new owners were hampering development, it stands to reason there would be differences between the programs.
    Jane, stop this crazy thing!

  7. #7
    Join Date
    Nov 2005
    Location
    Lincolnshire, UK
    Beans
    1,461
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Cannot install LibreOffice on Ubuntu 10.04 Lucid

    Quote Originally Posted by monkeybrain2012 View Post
    ...Libreoffice is definitely a lot faster than the Lucid version, among other things...
    As they both started out with the same code-base I would be surprised if LO is much faster than OOo. Any difference in speed is probably due to different versions of the programs and, as you say, the Lucid version is quite old now.
    Quote Originally Posted by monkeybrain2012 View Post
    ...@OP why are you still using Lucid? I remember what it was like, it is like ancient history now.
    Lucid is a LTS release and so remains supported until April 2013. Some of us prefer stability to the latest "bells & whistles" so stick to LTS releases. It works for me.

  8. #8
    Join Date
    May 2009
    Location
    Indiana
    Beans
    1,784
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Cannot install LibreOffice on Ubuntu 10.04 Lucid

    Quote Originally Posted by Zill View Post
    As they both started out with the same code-base I would be surprised if LO is much faster than OOo. Any difference in speed is probably due to different versions of the programs and, as you say, the Lucid version is quite old now.
    With the initial release of LibreOffice, the developers reduced memory requirements, reduced reliance on Java, and switched to using Cairo for font rendering. I would imagine these also contribute to the speed.
    Jane, stop this crazy thing!

  9. #9
    Join Date
    Jun 2012
    Beans
    22

    Re: Cannot install LibreOffice on Ubuntu 10.04 Lucid

    Hello all,

    I have tried removing all of OpenOffice in the beginning before I installed Libre. I knew that it had to be removed, so I did just as -monkeybrain2012- had mentioned, "sudo apt-get autoremove openoffice"

    It has removed "OO", however I am unable to install Libre, or even re-install OO as well.
    I continue to get the same error message each time, just a bit different wording, obviously.

    Thank you,

  10. #10
    Join Date
    Oct 2012
    Beans
    874

    Re: Cannot install LibreOffice on Ubuntu 10.04 Lucid

    This is going to be painful. When that happens try to use synaptic to install those packages that it says won't be install and look at the error messages (say libreoffice-core) and repeat the process, usually after a few trials you will be nail down the conflict, chances are you might have added some ppas so some dependencies several steps down the road may be screwed up.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •