Results 1 to 3 of 3

Thread: Gateway NV53A - Wireless Disabled by Hardware Switch

  1. #1
    Join Date
    Jan 2010
    Beans
    4

    Gateway NV53A - Wireless Disabled by Hardware Switch

    During installation of Ubuntu 12.10, my wireless worked. Post-installation Network Manager showed "Wireless Disabled by Hardware Switch".

    Long story short I had to black-listed the acer_wmi module.

    Code:
    sudo nano /etc/modprobe.d/blacklist.conf
    Add the following at the end of the file:

    Code:
    # Acer Wireless Module
    acer_wmi
    Reboot and if all goes well, the wireless should work.

    This solution should apply to Gateway laptops [manufactured by Acer] and Acer laptops.

    Note: I've noticed in other post people not able to find the *-wmi module, try an underscore instead, *_wmi.

  2. #2
    Join Date
    Jan 2010
    Beans
    4

    Re: Gateway NV53A - Wireless Disabled by Hardware Switch

    Quote Originally Posted by h0nd0 View Post
    During installation of Ubuntu 12.10, my wireless worked. Post-installation Network Manager showed "Wireless Disabled by Hardware Switch".

    Long story short I had to black-listed the acer_wmi module.

    Code:
    sudo nano /etc/modprobe.d/blacklist.conf
    Add the following at the end of the file:

    Code:
    # Acer Wireless Module
    acer_wmi
    Reboot and if all goes well, the wireless should work.

    This solution should apply to Gateway laptops [manufactured by Acer] and Acer laptops.

    Note: I've noticed in other post people not able to find the *-wmi module, try an underscore instead, *_wmi.
    *****UPDATE*****
    The code for blacklisting the module should read
    Code:
    # Acer Wireless Module
    blacklist acer_wmi
    My apologies for missing that.

  3. #3
    Join Date
    Sep 2010
    Beans
    3

    Re: Gateway NV53A - Wireless Disabled by Hardware Switch

    It's now June 1st 2013 and I have run into a similar problem trying to get networking going on a Gateway NV53A, that has a Realtek rtl8192SE chip.

    It's a friends laptop that I've just installed Ubuntu 12.10 onto and it's running right next to my laptop which is also running Ubuntu 12.10 and connecting just fine to the same wireless routers.

    It sees the available wireless routers, but fails to connect to any of them.

    I've blacklisted acer_wmi as you suggested, but it still doesn't work.

    However ifconfig wlan0
    shows
    RX packetes:2649 errors: 0

    So it's getting something back from the router just not connecting.

    Any suggestions?

    -Pete

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •