Page 3 of 3 FirstFirst 123
Results 21 to 24 of 24

Thread: System won't shut down; Logs off instead

  1. #21
    Join Date
    Apr 2013
    Beans
    1

    Re: System won't shut down; Logs off instead

    I'm on a fresh install of 12.10 (wubi) and I got this problem every couple shutdown or restart. Thanks to the answer given, that really helps coz I'm going nuts trying to shut this damn thing down.

  2. #22
    Join Date
    Jun 2007
    Location
    Puerto Rico
    Beans
    159
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: System won't shut down; Logs off instead

    I have the same problem. It started a couple of weeks ago. Using 12.04 since it came out. I have done a couple fresh installs during the year. Mostly a vanilla configuration with Geographical Information Software and DarkTable (photographt) repositories added. I am the only user configured in the computer. sudo shutdown -P now works OK.
    ¡Levántate!, ¡Revuélvete!, ¡Resiste!
    Haz como el toro acorralado: ¡muge!
    O como el toro que no muge: ¡EMBISTE!
    - José de Diego, En la brecha -

  3. #23
    Join Date
    May 2007
    Beans
    59

    Re: System won't shut down; Logs off instead

    Quote Originally Posted by Dabo Ross View Post
    I am getting this in 12.10. It is a relatively new install, and this problem started 2 days ago. I re-installed Ubuntu 2-3 weeks ago.
    I am the only user on the computer. When I click shutdown or restart in menu, I end up on log-in screen, with no error message.
    When I try shutdown or restart from the login screen nothing happens.
    I have been just hibernating for the past few days, to get around this problem.

    I am getting This in /var/log/syslog:
    Apr 5 10:48:43 DaboUbuntu gnome-session[30423]: WARNING: Unable to stop system: Authorization is required
    When I try to shutdown.

    I think I found what was happening to me. Someone had logged on to the guest account, and hadn't logged off.
    Logging into then out of the guest account fixed it for me.


    Oh, and BTW, I found these other things on this bug:
    http://askubuntu.com/questions/71506...ithout-console
    https://bugs.launchpad.net/ubuntu/+s...er/+bug/861171
    http://askubuntu.com/questions/24363...to-greeter-now

    And that last one has a solution:

    Create a file named /etc/polkit-1/localauthority/50-local.d/usershutdown.pkla (the name must end in .pkla) and put the following in it:

    [Allow Shutdown]
    Identity=unix-user:*
    Action=org.freedesktop.consolekit.system.stop-multiple-users
    ResultAny=yes
    ResultInactive=yes
    ResultActive=yes

    [Allow Restart]
    Identity=unix-user:*
    Action=org.freedesktop.consolekit.system.restart-multiple-users
    ResultAny=yes
    ResultInactive=yes
    ResultActive=yes
    I had the same problem, it started after upgrading from 12.10 to 13.04, so if someone is hoping the upgrade to 13.04 will fix it, don't hold your breath...
    Anyway, this solution proposed by Dabo Ross worked for me!
    Thanks!
    Last edited by zivley; June 14th, 2013 at 03:55 PM.

  4. #24
    Join Date
    Nov 2009
    Location
    New Hampshire, USA
    Beans
    12

    Re: System won't shut down; Logs off instead

    Quote Originally Posted by offgridguy View Post
    Do you have more than one user account? If yes, you have to log out each user account to
    shutdown.
    Since this thread is still alive and the bug hasn't been fixed, I'll hop on here and share my similar problem that always seems to have been there. I have 12.04 LTS, always fully updated, on a year-old Acer laptop; 12.04 was fresh installed dual-boot with Windows 7 when the laptop was just a day or so old.

    I have this shutdown problem only when there is another user logged on. Even Windows allows you to log off even if there are other users logged on.

    Thanks to this thread I just tried sudo poweroff and it worked.

    Is this a bug, or a dangerous undocumented feature?!

Page 3 of 3 FirstFirst 123

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •