Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: ubuntu 12.10 bugs (downgrade?)

  1. #1
    Join Date
    Sep 2011
    Location
    Dixie
    Beans
    53
    Distro
    Ubuntu 12.04 Precise Pangolin

    ubuntu 12.10 bugs (downgrade?)

    Hello all,

    Okay, I recently upgraded to Ubuntu 12.10 from 12.04, and over all it has been very buggy, including the following bugs:

    1. not being able to change desktop environments (i.e. changing from gnome to unity)
    2. I cannot login from GUI mode,(it just redirects back to login page,I have to CTRL-ALT-F1 and login through terminal, then run starx)

    3. I cannot logout, I have to restart.

    4. wifi only works when it wants to.

    and it is very slow, and choppy

    to get these fixed:

    should I ther down-grade back to 12.04 (if so, how?), or should the next updates fix these bugs?

    I do not remember other non-LTS versions being this buggy.

    Right now I'm stuck in using gnome (I think 3.6), i like the changes, but over all it is not usable.

    I am actually on a bootable drive right now...


    Thanks for any help in advance,

    -Pierce
    Last edited by pierceTN; November 8th, 2012 at 12:05 AM.

  2. #2
    Join Date
    Feb 2008
    Location
    Funky Town, AUS
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: ubuntu 12.10 bugs (downgrade?)

    Do an update now. Try in a terminal:

    sudo apt-get update
    sudo apt-get upgrade

    This last command will NOT upgrade your OS, but the packages and software in it (if required).

    There is no 'downgrade' option so going back to 12.04 LTS (if it ain't broke don't fix it) means a full reinstall.

  3. #3
    Join Date
    Sep 2011
    Location
    Dixie
    Beans
    53
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: ubuntu 12.10 bugs (downgrade?)

    Quote Originally Posted by Bucky Ball View Post
    Do an update now. Try in a terminal:

    sudo apt-get update
    sudo apt-get upgrade

    This last command will NOT upgrade your OS, but the packages and software in it (if required).

    There is no 'downgrade' option so going back to 12.04 LTS (if it ain't broke don't fix it) means a full reinstall.
    I have updated and upgraded in the terminal. ---to no avail

    How often are updates released?

  4. #4
    Join Date
    Feb 2008
    Location
    Funky Town, AUS
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: ubuntu 12.10 bugs (downgrade?)

    For 12.10? Often. It has only been out two or three weeks. I would set to update daily rather than weekly right now.

  5. #5
    Join Date
    Jun 2010
    Beans
    167
    Distro
    Ubuntu

    Re: ubuntu 12.10 bugs (downgrade?)

    Re-installing takes only about a few minutes and have 0 worries. Also, to avoid messy kernel updates refer to this guide: http://www.howtogeek.com/howto/10606...tes-in-ubuntu/

  6. #6
    Join Date
    Jul 2011
    Beans
    3,037
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: ubuntu 12.10 bugs (downgrade?)

    should I ther down-grade back to 12.04 (if so, how?), or should the next updates fix these bugs?
    You cannot downgrade, the only option would be to do a fresh install of 12.04. Considering all your problems, it may be the better option. With respect to problems 1. and 2. I would assume that they could be related to the graphics card. What graphics card do you have and what driver do you use?

  7. #7
    Join Date
    Sep 2011
    Location
    Dixie
    Beans
    53
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: ubuntu 12.10 bugs (downgrade?)

    Quote Originally Posted by 2F4U View Post
    You cannot downgrade, the only option would be to do a fresh install of 12.04. Considering all your problems, it may be the better option. With respect to problems 1. and 2. I would assume that they could be related to the graphics card. What graphics card do you have and what driver do you use?


    when I go to settings>detils>graphics, it says my graphic driver is "Gallium 0.4 on llvmpipe (LLVM 0x301)" I do not know what Grphics card it is. But It is on a Dell Latitude D630.

    Did graphic card requirements change with 12.10?

    Before the upgrade, every thing was working fine. I think I'm going for a 12.04 fresh install.


    @Anathaen

    When I go to synaptic, it shows my kernel up to date.

    and am probably going to do a re-install
    Last edited by pierceTN; November 8th, 2012 at 05:26 PM.

  8. #8
    Join Date
    Jul 2011
    Beans
    3,037
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: ubuntu 12.10 bugs (downgrade?)

    when I go to settings>detils>graphics, it says my graphic driver is "Gallium 0.4 on llvmpipe (LLVM 0x301)" I do not know what Grphics card it is. But It is on a Dell Latitude D630.
    In order to find your graphics card, execute

    Code:
    lspci | grep VGA
    in a terminal.

  9. #9
    Join Date
    Jul 2011
    Beans
    3,037
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: ubuntu 12.10 bugs (downgrade?)

    Did graphic card requirements change with 12.10?
    Yes, they did change. Unity requires 3D and OpenGL:

    http://www.phoronix.com/scan.php?pag...tem&px=MTA5OTA
    http://askubuntu.com/questions/13434...g-discontinued

  10. #10
    Join Date
    Sep 2011
    Location
    Dixie
    Beans
    53
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: ubuntu 12.10 bugs (downgrade?)

    Quote Originally Posted by 2F4U View Post
    this is what it gave me when I executed 'lspci | grep VGA':
    "00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c)"


    also, I did not use unity 2D in 12.04, so would the same driver/graphics card work for the "regular" unity in 12.04, as it would for the "only" unity for 12.10?

    I have not been able to use unity though in 12.10, because I was using the gnome desktop last when I upgraded, and it will not let me change. so,apparently, I am stuck using gnome. So I cant figure out if unity 3d will work or not.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •