Results 1 to 10 of 10

Thread: Problem running steam

Hybrid View

  1. #1
    Join Date
    May 2010
    Beans
    20

    Problem running steam

    Hi, I'm running 32-bit 12.04 with Classic Gnome. I downloaded the deb file available at http://media.steampowered.com/client...ller/steam.deb and installed it with
    sudo dpkg -i steam.deb
    sudo apt-get install -f

    But when i launch steam nothing happens. The terminal gives me this output:

    $ steam
    ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
    X Error of failed request: BadName (named color or font does not exist)
    Major opcode of failed request: 45 (X_OpenFont)
    Serial number of failed request: 12
    Current serial number in output stream: 13

    I have no idea what this means or why it is happening. Please help.

  2. #2
    Join Date
    Apr 2008
    Location
    England
    Beans
    210
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Problem running steam

    They probably are but you could make sure that xfonts are installed to the newest version:

    Code:
    sudo apt-get install xfonts-100dpi
    Chris

    My blog

  3. #3
    Join Date
    May 2010
    Beans
    20

    Re: Problem running steam

    Din't help

  4. #4
    Join Date
    Apr 2008
    Location
    England
    Beans
    210
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Problem running steam

    Hmmm - it definately looks to be a problem with the fonts. Can you run the following and post the output:

    Code:
    dpkg --get-selections | grep font
    Chris

    My blog

  5. #5
    Join Date
    May 2010
    Beans
    20

    Re: Problem running steam

    Thanks for your reply

    Here's the output:

    Code:
    fontconfig					install
    fontconfig-config				install
    fonts-liberation				install
    fonts-open-sans					install
    fonts-raleway					install
    gsfonts						install
    libfont-afm-perl				install
    libfontconfig1					install
    libfontconfig1-dev				install
    libfontenc1					install
    libxfont1					install
    ttf-freefont					install
    xfonts-100dpi					install
    xfonts-base					install
    xfonts-encodings				install
    xfonts-utils					install

  6. #6
    Join Date
    Apr 2008
    Location
    England
    Beans
    210
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Problem running steam

    Comparing yours with mine I can see one obvious difference although I don't run steam so don't know if it is the cause of the problem. You could try installing the 75dpi fonts:

    Code:
    sudo apt-get install xfonts-75dpi
    Chris

    My blog

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •