Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: UEFI - only boots into Windows

  1. #1
    Join Date
    Dec 2009
    Beans
    38

    Question UEFI - only boots into Windows

    I've tried Boot Repair and still cannot seem to fix my drive in Windows 8. ONLY boots into Windows 8. Please advise.

    Here is my boot repair info

    http://paste.ubuntu.com/1340112

  2. #2
    Join Date
    Jun 2006
    Location
    UK
    Beans
    Hidden!
    Distro
    Ubuntu 15.04 Vivid Vervet

    Re: UEFI - only boots into Windows

    Moved to own thread.

    @zengeos, please start your own threads.
    Ubuntu 15.04 Desktop Guide - Ubuntu 14.04 Desktop Guide - Forum Guide to BBCode - IRC #ubuntuforums

    Member: Not Canonical Team

    Please do not PM me about your forum account unless you have been asked to. The correct place to contact an admin about your account is here.

  3. #3
    Join Date
    Dec 2009
    Beans
    38

    Re: UEFI - only boots into Windows

    Thanks for moving the post coffeecat. I didn't want to overpopulate message threads so added to closest sounding existing thread.

  4. #4
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: UEFI - only boots into Windows

    Did you copy your efi partition or something?

    You can only have one efi partition and you have two. Both sda2 & sda4 are flagged as efi partitions and both are in the fstab in sda8. Only one is in the fstab of the install in sda11.

    Boot-Repair may have duplicated the entries in fstab if it saw two efi partitions which it would not expect to see.

    Are you getting a grub menu when you try to boot Ubuntu?

    Are you booting Windows directly from the UEFI menu?
    For info on UEFI boot install & repair - Updated Mar 2015:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  5. #5
    Join Date
    Dec 2009
    Beans
    38

    Re: UEFI - only boots into Windows

    Thanks for your response. No Grub menu comes up. Should I force Grub Repair to use sda2 then? If so, should I NOT format it?
    sda 2 is l;isted as boot, hidden. Can I still use it or do I need to make it unhidden somehow?


    I think the hidden flag caused Boot Repair to prompt me to create a boot partition. If I remove that flag, will that fix things?

    I am totally unfamiliar with efi and Win 8 as you can see :/

  6. #6
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: UEFI - only boots into Windows

    You should only have one boot flag which in gpt partitioning means the efi partition.

    In GPT fdisk, ESPs have a type code of EF00. In libparted-based tools, you mark the ESP as such by setting its "boot flag." Note that the libparted "boot flag" means something entirely different under MBR, and you should not set the "boot flag" on any OS partition under GPT! (just the one efi partition).
    For info on UEFI boot install & repair - Updated Mar 2015:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  7. #7
    Join Date
    Dec 2009
    Beans
    38

    Re: UEFI - only boots into Windows

    Quote Originally Posted by oldfred View Post
    You should only have one boot flag which in gpt partitioning means the efi partition.

    In GPT fdisk, ESPs have a type code of EF00. In libparted-based tools, you mark the ESP as such by setting its "boot flag." Note that the libparted "boot flag" means something entirely different under MBR, and you should not set the "boot flag" on any OS partition under GPT! (just the one efi partition).

    OK I am flailing in EFI land here, so I removed the boot flag on sda4. I unhid sda 2 and re-ran boot repair.

    Unfortunately, this did not fix things and Windows actually ran Windows Repair. Here is the new log

    http://paste.ubuntu.com/1340584/

  8. #8
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: UEFI - only boots into Windows

    If you go into UEFI does it not give several boot choices like ubuntu, windows?

    And if you boot ubuntu does it not give a grub menu?

    Or it then could be video issues.
    For info on UEFI boot install & repair - Updated Mar 2015:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  9. #9
    Join Date
    Dec 2009
    Beans
    38

    Re: UEFI - only boots into Windows

    Quote Originally Posted by oldfred View Post
    If you go into UEFI does it not give several boot choices like ubuntu, windows?

    And if you boot ubuntu does it not give a grub menu?

    Or it then could be video issues.
    Yes, uefi gives several options including 2 Ubuntus. If I select the first it goes into Windows. If I select the 2nd Ubuntu item it flashes up a message that Ubuntu has been blocked, then continues to Windows Repair.

  10. #10
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: UEFI - only boots into Windows

    Is this the new secure boot that only lets you boot Windows?

    You can either turn off secure boot, and maybe some other settings in UEFI. Or install the very new grub2 2.00that supposedly works with secure boot.

    Secure Boot
    http://web.dodds.net/~vorlon/wiki/bl..._Ubuntu_12.10/
    http://www.linuxfoundation.org/publi...open-platforms
    For info on UEFI boot install & repair - Updated Mar 2015:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •