Results 1 to 10 of 21

Thread: Lenovo g560 eth0 no wireless extensions

Hybrid View

  1. #1
    Join Date
    Jul 2011
    Beans
    6

    Unhappy Lenovo g560 eth0 no wireless extensions

    After some updates that required restart, the wireless stopped working.
    My wireless card: is Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 02)


    Can someone please point me to the right direction into solving this?

    Thanks!
    Petre

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,283
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Lenovo g560 eth0 no wireless extensions

    You posted details about your wired ethernet card. Please run and post:
    Code:
    lspci -nn | grep 0280
    rfkill list all
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #3
    Join Date
    Jul 2011
    Beans
    6

    Smile Re: Lenovo g560 eth0 no wireless extensions

    Sure

    Code:
    05:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)
    AND

    Code:
    0: ideapad_wlan: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    1: ideapad_bluetooth: Bluetooth
        Soft blocked: no
        Hard blocked: no
    2: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
    This part was:
    Code:
    0: ideapad_wlan: Wireless LAN
        Soft blocked: yes
    But I run this: rfkill unblock all and now is: Soft blocked: no


    Thanks for your reply!
    Petre

  4. #4
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,283
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Lenovo g560 eth0 no wireless extensions

    Your Broadcom works best with the STA driver. Let's try to re-install it and see if we can get it going.
    Code:
    sudo apt-get install --reinstall bcmwl-kernel-source
    sudo modprobe wl
    iwconfig
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  5. #5
    Join Date
    Jul 2011
    Beans
    6

    Re: Lenovo g560 eth0 no wireless extensions

    After the first command I got lots of data, but something went wrong:

    Code:
    FATAL: Module wl not found.
    Second:
    Code:
    FATAL: Module wl not found.
    Still:

    Code:
    eth0      no wireless extensions.
    lo        no wireless extensions.

  6. #6
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,283
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Lenovo g560 eth0 no wireless extensions

    After the first command I got lots of data, but something went wrong:
    It will be helpful to see the exact errors. Can you please run it again and copy and paste the terminal output here? May we see:
    Code:
    lsb_release -d
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  7. #7
    Join Date
    May 2013
    Beans
    1

    Re: Lenovo g560 eth0 no wireless extensions

    Hi I am using Toshiba PORTEGE R930
    I am very new to UBUNTU and I followed steps in this post but I couldn't solve the problem

    Any help will be greatly appreciated............

    Thank You in advance

    for this command

    lspci -nn | grep 0280


    I got this output

    04:00.0 Network controller [0280]: Intel Corporation Device [8086:088e] (rev 24)

    For this command

    rfkill list all

    I got the following output

    0: Toshiba Bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
    1: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

  8. #8
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,283
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Lenovo g560 eth0 no wireless extensions

    Quote Originally Posted by praveenmg View Post
    Hi I am using Toshiba PORTEGE R930
    I am very new to UBUNTU and I followed steps in this post but I couldn't solve the problem

    Any help will be greatly appreciated............

    Thank You in advance

    for this command

    lspci -nn | grep 0280


    I got this output

    04:00.0 Network controller [0280]: Intel Corporation Device [8086:088e] (rev 24)

    For this command

    rfkill list all

    I got the following output

    0: Toshiba Bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
    1: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
    You don't have a Broadcom wireless device, so none of this helps you. Please start a new thread and tell us what is not working and what you tried that we may have to undo.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •