Results 1 to 8 of 8

Thread: Bug at autofs/automount?

  1. #1
    Join Date
    Mar 2012
    Beans
    22

    Bug at autofs/automount?

    Hi people!

    I'm really stucked with such a simple thing like configuring autofs5 on Ubuntu Precise using 3.2.0-26-generic-pae kernel.

    Remotely I have a samba server which I want to access from a client.

    On the client side, I installed autofs:

    Code:
    # apt-get install autofs
    In /etc/auto.master I added the following line:

    Code:
    /mnt/shared   /etc/auto.shared   --timeout=60
    Content of auto.shared is:

    Code:
    shared   -fstype=cifs,uid=localuser,gid=localuser,iocharset=utf8,credentials=/etc/credentials,nosetuids,noperm   ://192.168.0.99/shared
    I'm pretty sure the /etc/credentials file has the right credentials.

    After this, I restarted autofs and directory /mnt/shared exists but it's empty...

    Code:
    root@monitorize:/mnt/shared# ll
    total 4
    drwxr-xr-x 2 root root    0 nov  6 19:22 ./
    drwxr-xr-x 3 root root 4096 nov  6 19:22 ../
    On the server side this directory has a lot of files. Curiously using smbclient I can connect to the remote server and I see the files (using the same credentials file). Even mounting manually or via fstab this samba-point it works properly. It's just autofs/automount that fails... Absolutely nothing in the logs. I tried to teardown apparmor and didn't work, and also to find something about this but I didn't see any relevant, nor in this forum, what makes me think this can be some kind of bug.

    Also tried to specify manually username and password parameters in auto.shared, and still doesn't work.

    Any ideas about this?

    Thanks a lot!

  2. #2
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    6,906
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Bug at autofs/automount?

    Hi absoord.

    Since you are using an indirect map you should just reference '/mnt' on the master and 'shared' on the indirect map.

    As for now, I think your are mapping /mnt/shared/shared.

    Could you try this:
    Code:
    cd /mnt/shared/shared
    Let us know how it goes.
    Regards.

  3. #3
    Join Date
    Mar 2012
    Beans
    22

    Re: Bug at autofs/automount?

    First off, thanks for your reply!

    The command you wrote doesn't work:

    Code:
    root@monitorize:~# cd /mnt/shared/shared
    bash: cd: /mnt/shared/shared: No existe el archivo o el directorio
    I knew it's mapped this way but I can't access it... also tried it just referencing /mnt in the master and doesn't work either. So weird...

  4. #4
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    6,906
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Bug at autofs/automount?

    I just test your settings, and they work on my system.

    I just had to replace localuser, localuser for the actual values (in my case 1000 and 1000).

    Are you using those literally or are you hiding the actual values you are using?

    Regards.

  5. #5
    Join Date
    Mar 2012
    Beans
    22

    Re: Bug at autofs/automount?

    Both user and group exist:

    Code:
    root@monitorize:/mnt# cat /etc/passwd | grep localuser
    localuser:x:1002:1002::/home/localuser:/bin/sh
    
    root@monitorize:/mnt# cat /etc/group | grep localuser
    localuser:x:1002:
    I'm also confused since I've also reproduced this same configuration in other Ubuntu systems and it worked... I don't know what am I doing wrong now!

    Thanks again!

  6. #6
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    6,906
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Bug at autofs/automount?

    Don't use the names, use the number values, i.e., 1002 for both.

  7. #7
    Join Date
    Mar 2012
    Beans
    22

    Re: Bug at autofs/automount?

    Still the same

    I could give an additional step... I found out there's one message in the syslog related with automount:

    Code:
    Nov  6 20:40:24 monitorize automount[27553]: syntax error in nsswitch config near [ syntax error ]
    Researching a bit about this it looks like a bug...

    https://bugs.launchpad.net/ubuntu/+s...s5/+bug/488696

    None of the solutions have worked for me, so I guess I'll have to wait for the official package fix...

    Thanks for the help!

  8. #8
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    6,906
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Bug at autofs/automount?

    Another difference was that my credential file is in my home directory (I used 10.04 btw)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •