Results 1 to 9 of 9

Thread: Missing icons

  1. #1
    Join Date
    Oct 2010
    Beans
    249

    Missing icons

    After the todays update all my icons are gone. I remember that one package complained about the icon cache and showed me a command with a redirector (I think it was gtk-update-icon-cache). libgtk2.0-bin wasn't installed at this time and after installing it the command gtk-update-icon-cache hasn't helped me. Has somebody an idea how to fix this? I'm using LXDE and reinstalling lxde-icon-theme hasn't helped too.

  2. #2
    dino99's Avatar
    dino99 is offline Ubuntu addict and loving it
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Missing icons

    try: lxpanel --replace
    Last edited by dino99; November 14th, 2012 at 08:21 AM.

  3. #3
    Join Date
    Oct 2010
    Beans
    249

    Re: Missing icons

    This command wasn't available on my system and even after installing it it hasn't helped. But I have upgraded now my virtual machine to look to the exact error message. After the trigger for an icon theme this appears:

    Code:
    (gtk-update-icon-cache-3.0:7343): GdkPixbuf-WARNING **: Cannot open pixbuf loader module file '/usr/lib/i386-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache': Datei oder Verzeichnis nicht gefunden
    
    This likely means that your installation is broken.
    Try running the command
      gdk-pixbuf-query-loaders > /usr/lib/i386-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
    to make things work again for the time being.
    After installing libgdk-pixbuf2.0 and running the command (the last 2 directories were missing) nothing changed. All icons are still invisible or have an error symbol. Curiously my virtual machine got this error message too but is unaffected by this bug.

    Edit: Your edited command doesn't know the argument --replace.
    Last edited by Sworddragon; November 14th, 2012 at 08:27 AM.

  4. #4
    Join Date
    Nov 2010
    Location
    India
    Beans
    4,821
    Distro
    Ubuntu Development Release

    Re: Missing icons

    Quote Originally Posted by Sworddragon View Post
    After the todays update all my icons are gone. I remember that one package complained about the icon cache and showed me a command with a redirector (I think it was gtk-update-icon-cache). libgtk2.0-bin wasn't installed at this time and after installing it the command gtk-update-icon-cache hasn't helped me. Has somebody an idea how to fix this? I'm using LXDE and reinstalling lxde-icon-theme hasn't helped too.

    How about re-isntalling LXDE with
    Code:
    sudo apt-get install --reinstall lxde
    Raja

    రాజ శేఖర్ రెడ్డి

  5. #5
    Join Date
    Oct 2010
    Beans
    249

    Re: Missing icons

    lxde was never installed but lxde-core. I have reinstalled it but it hasn't helped. I have even removed all icon-themes and installed them again but without any difference. I have now updated the icon cache for all folders in /usr/share/icons but this hasn't solved the problem too.

  6. #6
    Join Date
    Nov 2010
    Location
    India
    Beans
    4,821
    Distro
    Ubuntu Development Release

    Re: Missing icons

    Ok do this in your terminal
    Code:
    sudo cp /usr/share/lxpanel/profile/LXDE/panels ~/.config/lxpanel/LXDE/panels
    If changes are not applied instantly then re-login/restart your system.
    Raja

    రాజ శేఖర్ రెడ్డి

  7. #7
    Join Date
    Oct 2010
    Beans
    249

    Re: Missing icons

    I have now downgraded my system to Quantal and all is working fine. Now I will figure out first which package is triggering this bug.

  8. #8
    Join Date
    Nov 2010
    Location
    India
    Beans
    4,821
    Distro
    Ubuntu Development Release

    Re: Missing icons

    Quote Originally Posted by Sworddragon View Post
    I have now downgraded my system to Quantal and all is working fine. Now I will figure out first which package is triggering this bug.

    and dont forget reporting it to launchpad .

    Thank you .

    Have you tried what i have given ?
    Raja

    రాజ శేఖర్ రెడ్డి

  9. #9
    Join Date
    Oct 2010
    Beans
    249

    Re: Missing icons

    Quote Originally Posted by raja.genupula View Post
    and dont forget reporting it to launchpad .
    Sure, as the ~100 reports I have already made there


    Quote Originally Posted by raja.genupula View Post
    Have you tried what i have given ?
    I will try it after I have upgraded to Raring again.


    Edit: The upgrade is now complete and I couldn't find a package which is making troubles because all is working fine now.
    Last edited by Sworddragon; November 14th, 2012 at 10:01 AM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •