Results 1 to 9 of 9

Thread: Dell studio 1558 high fan speed issue

  1. #1
    Join Date
    Nov 2007
    Beans
    51

    Dell studio 1558 high fan speed issue

    Hi, I have 2011 dell studio 1558 with core i3, 8 gb ram and 128gb ssd.i noticed that my CPU fan runs on high speed most of the time., I searched around and saw that it could be due to the bios or the video driver. In my case I have the latest bios.. a12 and my system only has the intel graphics card. I even opened up the machine cleaned the dust.. But it did not help.. My core temp shows around 55 degrees.. Any help would be appreciated

  2. #2
    Join Date
    Jul 2011
    Beans
    3,037
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Dell studio 1558 high fan speed issue

    The 55 degree seems to be not too high, so my guess would be a faulty fan management due to a wrong ACPI implementation by Dell. You can try some additional tweaks not implemented in the Ubuntu default configuration:

    https://wiki.ubuntu.com/Kernel/Power...erSavingTweaks

  3. #3
    Join Date
    Nov 2007
    Beans
    51

    Re: Dell studio 1558 high fan speed issue

    Quote Originally Posted by 2F4U View Post
    The 55 degree seems to be not too high, so my guess would be a faulty fan management due to a wrong ACPI implementation by Dell. You can try some additional tweaks not implemented in the Ubuntu default configuration:

    https://wiki.ubuntu.com/Kernel/Power...erSavingTweaks
    Thanks 2F4U,
    I will try that tonight hopefully it will work.
    On a site node, I used "Jupiter" to get my temperature readings etc. I will check it again after updating the ACPI impl.

  4. #4
    Join Date
    Jul 2011
    Beans
    3,037
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Dell studio 1558 high fan speed issue

    What version of Ubuntu are you running? Ubuntu 12.10 now requires 3D capable graphics hardware and can place quite some burden on the graphics card and maybe also on the processor. Therefore, you should open Sytem Monitor and see if the there is a considerable CPU activity.

  5. #5
    Join Date
    Oct 2008
    Location
    Truckee, CA
    Beans
    98
    Distro
    Kubuntu

    Re: Dell studio 1558 high fan speed issue

    Interesting; I'm running Kubuntu 12.04 on the same model laptop (except mine's a bit differently-configured; i5, 500GB platter-stack HDD, Radeon HD graphics) and don't really see much fan use difference between Windows 7 and Kubuntu (if anything, Kubuntu seems to have less).

    So, adding to the previous forum-goer's inquiry regarding the version of Ubuntu, are you using Unity or a different desktop manager (like KDE or Xfce)? Also, if you're on 12.10, were you having the same issue on older versions?

  6. #6
    Join Date
    Nov 2007
    Beans
    51

    Re: Dell studio 1558 high fan speed issue

    Thanks for the comment guys,
    I am running Ubuntu 12.10.

    I tried by adding
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.i915_enable_rc6=1"
    as mentioned in the link but it didnt do anything.

    i have the default Intel graphics 3000 HD on this thing (not ATI radion or nVidia).

    I have had this issue with both 12.04 and 12.10. Perhaps even tried mint13 and this issue persist, i guess since mint is based on ubuntu, it wouldnt have made any difference anyway.

    Also, I had to make following entry on my grub file because w/o that entry, my screen would be on max brightness and i wasn't able to control it. After adding following line my brightness control worked.
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

    any suggestions at this point?

    I checked the system monitor and CPU usage is less than 10% on each core but my CPU temp is 78 degrees according to "Jupiter".

  7. #7
    Join Date
    Jul 2011
    Beans
    3,037
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Dell studio 1558 high fan speed issue

    You could try one or both kernel parameters acpi.power_nocheck=1 OR acpi_osi=linux:

    https://help.ubuntu.com/community/Bo...Kernel_Options

  8. #8
    Join Date
    Nov 2007
    Beans
    51

    Re: Dell studio 1558 high fan speed issue

    Quote Originally Posted by 2F4U View Post
    You could try one or both kernel parameters acpi.power_nocheck=1 OR acpi_osi=linux:

    https://help.ubuntu.com/community/Bo...Kernel_Options
    Thanks 2F4U, I really appreciate your help on this. more I look online seems like a issue with acpi. Most people were referring to ATI or nVidia graphics card driver and no one talked about intel graphics card which is the case for me. Hope this works.
    I will test it tonight.

  9. #9
    Join Date
    Nov 2007
    Beans
    51

    Re: Dell studio 1558 high fan speed issue

    Quote Originally Posted by bond17_007 View Post
    Thanks 2F4U, I really appreciate your help on this. more I look online seems like a issue with acpi. Most people were referring to ATI or nVidia graphics card driver and no one talked about intel graphics card which is the case for me. Hope this works.
    I will test it tonight.
    Thanks again.. i tried acpi.power_nocheck=1, also acpi_osi=linux and even acpi=off, but did not help. I am still noticing the same fan issue

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •