Results 1 to 3 of 3

Thread: removing notifications from Jupiter

Hybrid View

  1. #1
    Join Date
    May 2006
    Location
    Copenhagen
    Beans
    160
    Distro
    Xubuntu 13.04 Raring Ringtail

    removing notifications from Jupiter

    I have installed Jupiter on my xubuntu. It works flawlessly but every time I open my computer it gives notifications about the screen. I would like to deactivate these if possible. Does any one know a way to do this?

  2. #2
    Join Date
    May 2006
    Location
    Copenhagen
    Beans
    160
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: removing notifications from Jupiter

    found a thread in askubuntu about this subject but no solution there either.
    http://askubuntu.com/questions/20773...t-disappearing

  3. #3
    Join Date
    May 2006
    Location
    Copenhagen
    Beans
    160
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: removing notifications from Jupiter

    Got the answer from xubuntugeek

    After some digging on Jupiter's code I found out that the problem isn't in Jupiter itself. Jupiter sends desktop notifications using the "notify-send" command. notify-send has the "-t" parameter which sets the timeout, if you don't use it the notification vanishes after a few seconds, however, if you do use it the notification lasts forever; it's a bug I guess.

    So it's easy to fix Jupiter; just remove the -t parameter from each call. This command does just that:

    sudo sed -i 's/-t [0-9]\+//g' /usr/lib/jupiter/scripts/notify

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •