Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: how to install texworks-0.4.4

  1. #11
    Join Date
    Jul 2012
    Location
    Germany
    Beans
    107
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: how to install texworks-0.4.4

    Quote Originally Posted by newb85 View Post
    Well, I don't know if this will work, but I would try
    Code:
    sudo mkdir /usr/share/tex-common
    sudo touch /usr/share/tex-common/05TeXMF.cnf
    sudo apt-get install texworks
    here is the output:

    Code:
     sudo apt-get install texworks
    
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    texworks is already the newest version.
    You might want to run 'apt-get -f install' to correct these:
    The following packages have unmet dependencies:
     texlive-base : Depends: tex-common (>= 3) but 2.10 is to be installed
     texlive-binaries : Depends: tex-common (>= 3) but 2.10 is to be installed
                        Recommends: ruby
     texlive-common : Depends: tex-common (>= 3) but 2.10 is to be installed
     texlive-doc-base : Depends: tex-common (>= 3) but 2.10 is to be installed
     texlive-fonts-recommended : Depends: tex-common (>= 3) but 2.10 is to be installed
                                 Recommends: texlive-fonts-recommended-doc but it is not going to be installed
                                 Recommends: tex-gyre but it is not going to be installed
     texlive-generic-recommended : Depends: tex-common (>= 3) but 2.10 is to be installed
     texlive-latex-base : Depends: tex-common (>= 3) but 2.10 is to be installed
                          Recommends: texlive-latex-base-doc but it is not going to be installed
     texlive-latex-recommended : Depends: tex-common (>= 3) but 2.10 is to be installed
                                 Recommends: texlive-latex-recommended-doc but it is not going to be installed
                                 Recommends: prosper (>= 1.00.4+cvs.2006.10.22) but it is not going to be installed
     tipa : Depends: tex-common (>= 3) but 2.10 is to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

  2. #12
    Join Date
    May 2009
    Location
    Indiana
    Beans
    1,817
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: how to install texworks-0.4.4

    Try the suggestion:
    Code:
    sudo apt-get -f install
    Jane, stop this crazy thing!

  3. #13
    Join Date
    Jul 2012
    Location
    Germany
    Beans
    107
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: how to install texworks-0.4.4

    Quote Originally Posted by newb85 View Post
    Try the suggestion:
    Code:
    sudo apt-get -f install
    output:

    Code:
    sudo apt-get -f install
    
    [sudo] password for ******: 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Correcting dependencies... Done
    The following packages were automatically installed and are no longer required:
      libreoffice-help-en-gb libreoffice-help-en-us libunistring0 mythes-en-au
      mythes-en-us libqt4-test language-pack-kde-zh-hans-base hyphen-en-us
      po-debconf intltool-debian firefox-locale-zh-hans libgconf2-4:i386 gettext
      libqt4-help python-qt4 python-sip kde-l10n-engb libqtassistantclient4
      libgettextpo0 language-pack-zh-hans-base libreoffice-l10n-zh-cn
      kde-l10n-zhcn language-pack-zh-hans language-pack-kde-zh-hans
      libmail-sendmail-perl libreoffice-help-zh-cn libsys-hostname-long-perl
      libnss3-1d:i386 libreoffice-l10n-en-gb openoffice.org-hyphenation
      libreoffice-l10n-en-za
    Use 'apt-get autoremove' to remove them.
    The following extra packages will be installed:
      jadetex latex-sanskrit tex-common
    Suggested packages:
      docbook-dsssl debhelper
    The following packages will be upgraded:
      jadetex latex-sanskrit tex-common
    3 upgraded, 0 newly installed, 0 to remove and 18 not upgraded.
    20 not fully installed or removed.
    Need to get 0 B/1,981 kB of archives.
    After this operation, 600 kB disk space will be freed.
    Do you want to continue [Y/n]? y
    Setting up tex-common (2.10) ...
    Replacing config file /etc/texmf/texmf.d/05TeXMF.cnf with new version
    Error: The new file /usr/share/tex-common/15Plain.cnf does not exist!
    dpkg: error processing tex-common (--configure):
     subprocess installed post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of texlive-common:
     texlive-common depends on tex-common (>= 3); however:
      Version of tex-common on system is 2.10.
    dpkg: error processing texlive-common (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of texlive-binaries:
     texlive-binaries depends on texlive-common (>= 2011); however:
      Package texlive-common is not configured yet.
     texlive-binaries depends on tex-common (>= 3); however:
      Version of tex-common on system is 2.10.
    dpkg: error processing texlive-binaries (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of texlive-doc-base:
     texlive-doc-base depends on texlive-common (>= 2012.20120516); however:
      Package texlive-common is not configured yet.
     texlive-doc-base depends on tex-common (>= 3); however:
      Version of tex-common on system is 2.10.
    dpkg: error processing texlive-doc-base (--configure):
     dependency problemNo apport report written because the error message indicates its a followup error from a previous failure.
                                                 No apport report written because the error message indicates its a followup error from a previous failure.
                                                                           No apport report written because MaxReports is reached already
                                                         No apport report written because MaxReports is reached already
                                       No apport report written because MaxReports is reached already
                     No apport report written because MaxReports is reached already
                                                                                   No apport report written because MaxReports is reached already
                                                                 No apport report written because MaxReports is reached already
                                               No apport report written because MaxReports is reached already
                             No apport report written because MaxReports is reached already
           No apport report written because MaxReports is reached already
                                                                         No apport report written because MaxReports is reached already
                                                       No apport report written because MaxReports is reached already
                                     s - leaving unconfigured
    dpkg: dependency problems prevent configuration of texlive-base:
     texlive-base depends on texlive-doc-base (>= 2012.20120516); however:
      Package texlive-doc-base is not configured yet.
     texlive-base depends on texlive-binaries (>= 2012.20120516); however:
      Package texlive-binaries is not configured yet.
     texlive-base depends on texlive-common (>= 2012.20120516); however:
      Package texlive-common is not configured yet.
     texlive-base depends on tex-common (>= 3); however:
      Version of tex-common on system is 2.10.
    dpkg: error processing texlive-base (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of texlive-latex-base:
     texlive-latex-base depends on texlive-binaries (>= 2012-0); however:
      Package texlive-binaries is not configured yet.
     texlive-latex-base depends on texlive-common (>= 2012.20120516); however:
      Package texlive-common is not configured yet.
     texlive-latex-base depends on tex-common (>= 3); howNo apport report written because MaxReports is reached already
                                       No apport report written because MaxReports is reached already
                     No apport report written because MaxReports is reached already
                                                                                   No apport report written because MaxReports is reached already
                                                                 No apport report written because MaxReports is reached already
                                               No apport report written because MaxReports is reached already
                             ever:
      Version of tex-common on system is 2.10.
     texlive-latex-base depends on texlive-base (>= 2012.20120516); however:
      Package texlive-base is not configured yet.
    dpkg: error processing texlive-latex-base (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of texlive-fonts-recommended:
     texlive-fonts-recommended depends on texlive-common (>= 2012.20120516); however:
      Package texlive-common is not configured yet.
     texlive-fonts-recommended depends on tex-common (>= 3); however:
      Version of tex-common on system is 2.10.
     texlive-fonts-recommended depends on texlive-base (>= 2012.20120516); however:
      Package texlive-base is not configured yet.
    dpkg: error processing texlive-fonts-recommended (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of texlive-latex-recommended:
     texlive-latex-recommended depends on texlive-binaries (>= 2012-0); however:
      Package texlive-binaries is not configured yet.
     texlive-latex-recommended depends on texlive-latex-base (>= 2012.20120516); however:
      Package texlive-latex-base is not configured yet.
     texlive-latex-recommended depends on texlive-common (>= 2012.20120516); however:
      Package texlive-common is not configured yet.
     texlive-latex-recommended depends on tex-common (>= 3); however:
      Version of tex-common on system is 2.10.
    dpkg: error processing texlive-latex-recommended (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of texlive-generic-recommended:
     texlive-generic-recommended depends on texlive-common (>= 2012.20120516); however:
      Package texlive-common is not configured yet.
     texlive-generic-recommended depends on tex-common (>= 3); however:
      Version of tex-common on system is 2.10.
     texlive-generic-recommended depends on texlive-base (>= 2012.20120516); however:
      Package texlive-base is not configured yet.
    dpkg: error processing texlive-generic-recommended (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of tipa:
     tipa depends on texlive-latex-base; however:
      Package texlive-latex-base is not configured yet.
     tipa depends on texlive-base-bin; however:
      Package texlive-base-bin is not installed.
      Package texlive-binaries which provides texlive-base-bin is not configured yet.
     tipa depends on tex-common (>= 3); however:
      Version of tex-common on system is 2.10.
    dpkg: error processing tipa (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of jadetex:
     jadetex depends on tex-common (>= 2.00); however:
      Package tex-common is not configured yet.
     jadetex depends on texlive-latex-base; however:
      Package texlive-latex-base is not configured yet.
     jadetex depends on texlive-fonts-recommended; however:
      Package texlive-fonts-recommended is not configured yet.
     jadetex depends on texlive-latex-recommended; however:
      Package texlive-latex-recommended is not configured yet.
     jadetex depends on tipa; however:
      Package tipa is not configured yet.
    dpkg: error processing jadetex (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of latex-sanskrit:
     latex-sanskrit depends on tex-common (>= 2.00); however:
      Package tex-common is not configured yet.
     latex-sanskrit depends on texlive-base; however:
      Package texlive-base is not configured yet.
    dpkg: error processing latex-sanskrit (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of preview-latex-style:
     preview-latex-style depends on tex-common; however:
      Package tex-common is not configured yet.
    dpkg: error processing preview-latex-style (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of auctex:
     auctex depends on preview-latex-style; however:
      Package preview-latex-style is not configured yet.
    dpkg: error processing auctex (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of hevea:
     hevea depends on texlive-base; however:
      Package texlive-base is not configured yet.
     hevea depends on tex-common (>= 2.00); however:
      Package tex-common is not configured yet.
    dpkg: error processing hevea (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of pgf:
     pgf depends on tex-common (>= 2.00); however:
      Package tex-common is not configured yet.
     pgf depends on texlive-latex-recommended; however:
      Package texlive-latex-recommended is not configured yet.
    dpkg: error processing pgf (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of latex-beamer:
     latex-beamer depends on pgf (>= 1.00-1); however:
      Package pgf is not configured yet.
     latex-beamer depends on texlive-latex-base; however:
      Package texlive-latex-base is not configured yet.
    dpkg: error processing latex-beamer (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of tex4ht-common:
     tex4ht-common depends on texlive-base-bin; however:
      Package texlive-base-bin is not installed.
      Package texlive-binaries which provides texlive-base-bin is not configured yet.
    dpkg: error processing tex4ht-common (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of tex4ht:
     tex4ht depends on texlive-base-bin; however:
      Package texlive-base-bin is not installed.
      Package texlive-binaries which provides texlive-base-bin is not configured yet.
     tex4ht depends on tex4ht-common (= 20090611-1.1); however:
      Package tex4ht-common is not configured yet.
    dpkg: error processing tex4ht (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of texlive:
     texlive depends on texlive-latex-base (>= 2012.20120516); however:
      Package texlive-latex-base is not configured yet.
     texlive depends on texlive-fonts-recommended (>= 2012.20120516); however:
      Package texlive-fonts-recommended is not configured yet.
     texlive depends on texlive-latex-recommended (>= 2012.20120516); however:
      Package texlive-latex-recommended is not configured yet.
    dpkg: error processing texlive (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     tex-common
     texlive-common
     texlive-binaries
     texlive-doc-base
     texlive-base
     texlive-latex-base
     texlive-fonts-recommended
     texlive-latex-recommended
     texlive-generic-recommended
     tipa
     jadetex
     latex-sanskrit
     preview-latex-style
     auctex
     hevea
     pgf
     latex-beamer
     tex4ht-common
     tex4ht
     texlive
    E: Sub-process /usr/bin/dpkg returned an error code (1

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •