Results 1 to 7 of 7

Thread: How do I allocate more memory to Java?

  1. #1
    Join Date
    Jul 2010
    Beans
    20

    How do I allocate more memory to Java?

    RuneScape client runs slow on Ubuntu 12.04. Would allocating more memory to Java increase it's frames/per/second? How do I do this?

  2. #2
    Join Date
    Feb 2009
    Location
    Paris
    Beans
    27
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: How do I allocate more memory to Java?

    I'm not familiar with any Runescape client but concerning java you can specify the amount of memory allocated like this:
    Code:
    java -Xmx256m ...
    You'll have to find the launching script and edit it to include the Xmx part.

  3. #3
    Join Date
    Jun 2010
    Location
    Ann Arbor, Michigan, USA
    Beans
    1,421

    Re: How do I allocate more memory to Java?

    don't use the client.
    Steam: ubuntugamer( Add me ) | Gaming: Left 4 Dead 2, Metro Last Light, Assassin's Creed 4, Forced

  4. #4
    Join Date
    Dec 2009
    Location
    Australia
    Beans
    253
    Distro
    Xubuntu

    Re: How do I allocate more memory to Java?

    Quote Originally Posted by Alvina View Post
    RuneScape client runs slow on Ubuntu 12.04. Would allocating more memory to Java increase it's frames/per/second? How do I do this?
    What graphics card are you running, and have you installed the correct drivers? For example, if you are using an AMD graphics card, are you using the Catalyst drivers, or the open source Radeon drivers?
    Holding a LAN party? Check out LAN Party Mania (detailed LAN information for games)
    http://lanpartymania.com

  5. #5
    Join Date
    Oct 2011
    Beans
    15

    Re: How do I allocate more memory to Java?

    depends on which client you use.
    are you using the windows client in wine or are you using the native port?

    for the windows client you should look in
    ~/.wine/drive_c/jagexlauncher/jagexlauncher/runescape

    and open the file named runescape.prm

    then edit the line saying
    -Xmx256m

    and change it to -Xmx512m
    that will change the memory allocated to java 512mb, which is more than enough in most cases, an absolute max would be 1024mb but that may cause odd issues on some computers.
    ----

    If you use the native port of the client then just launch the "Runescape Client Settings" and just change the memory in the "Client Settings" tab


  6. #6
    Join Date
    Nov 2012
    Beans
    3

    Exclamation Re: How do I allocate more memory to Java?

    I have a related/unrealated problem actually... I've downloaded the newest version of IcedTea that I can find, and don't know where the hell to put it lol I just extracted it to the desktop, I'm just trying to update, Runescape bugs out on me too... Really not too familiar with Linux based systems yet, but I'm workin' on it.

  7. #7
    Join Date
    Dec 2008
    Beans
    176
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: How do I allocate more memory to Java?

    Check out the RSU Client:
    http://services.runescape.com/m=rswi...Native_Clients

    It works great on 32-bit Ubuntu. There are some errors with 64-bit, though, which can lead to some lag issues. All the instructions can be found at the link above. All I did was install the wrapper and I was able to get Runescape running great with my installation of Java 7.

    Edit:
    Look at that, didn't notice that HikariKnight replied above. Thumbs up for the client.
    Last edited by Carpentr; November 9th, 2012 at 08:19 AM.
    Pentium IV 3.2 GHz, 4 GB DDR, NVIDIA 610 1GB

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •