Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Need Help Installing Wine

  1. #11
    Join Date
    Oct 2012
    Beans
    10

    Re: Need Help Installing Wine

    Code:
    rtwaller@ubuntu:~$ sudo apt-get install wine1.4-amd64
    [sudo] password for rtwaller: 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     wine1.4-amd64 : Depends: wine1.4-common (= 1.4.1-0ubuntu1) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    rtwaller@ubuntu:~$

  2. #12
    Join Date
    Feb 2012
    Location
    el_GR
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Need Help Installing Wine

    OK , lets examine something else here.

    Give the results of this command please

    Code:
    find /etc/apt -name '*.list' -exec bash -c 'echo -e "\n$1\n"; cat -n "$1"' _ '{}' \;



  3. #13
    Join Date
    Oct 2012
    Beans
    10

    Re: Need Help Installing Wine

    Code:
    rtwaller@ubuntu:~$ find /etc/apt -name '*.list' -exec bash -c 'echo -e "\n$1\n"; cat -n "$1"' _ '{}' \;
    
    /etc/apt/sources.list
    
         1	deb http://archive.ubuntu.com/ubuntu/ quantal main restricted universe multiverse
         2	deb http://security.ubuntu.com/ubuntu/ quantal-security main restricted universe multiverse
         3	deb http://archive.ubuntu.com/ubuntu/ quantal-updates main restricted universe multiverse
    
    /etc/apt/sources.list.d/jonoomph-openshot-edge-quantal.list
    
         1	deb http://ppa.launchpad.net/jonoomph/openshot-edge/ubuntu quantal main
         2	deb-src http://ppa.launchpad.net/jonoomph/openshot-edge/ubuntu quantal main
    
    /etc/apt/sources.list.d/dropbox.list
    
         1	deb http://linux.dropbox.com/ubuntu precise main
    
    /etc/apt/sources.list.d/ubuntu-wine-ppa-quantal.list
    
         1	# deb-src http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu quantal main
         2	# deb http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu quantal main
    
    /etc/apt/sources.list.d/pidgin-ppa.list
    
         1	deb http://ppa.launchpad.net/pidgin-developers/ppa/ubuntu quantal main
         2	deb-src http://ppa.launchpad.net/pidgin-developers/ppa/ubuntu quantal main
    rtwaller@ubuntu:~$

  4. #14
    Join Date
    Feb 2012
    Location
    el_GR
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Need Help Installing Wine

    I think you messed around with sources.list and PPAs. (?) . You have to know that your system can be corrupted very easy (especially the package manager) and especially if a release (like 12.10) is new and you don't know if and what PPAs supported (yet).

    We will try some things . You can add all these PPAs later if you want.

    Code:
    sudo ppa-purge ppa:jonoomph/openshot-edge
    sudo ppa-purge ppa:pidgin-developers/ppa
    sudo rm /etc/apt/sources.list.d/*.list 
    sudo wget "http://pastebin.com/raw.php?i=ymiVFerb" -O /etc/apt/sources.list 
    sudo apt-get update 
    sudo apt-get dist-upgrade
    make all the upgrades (If any, I guess they will be some) and then try again to install wine
    Code:
    sudo apt-get install wine
    Thanks

  5. #15
    Join Date
    Oct 2012
    Beans
    10

    Re: Need Help Installing Wine

    I don't know if it could matter or not, but I used Wubi to install Ubuntu a couple weeks ago and it had wine installed fine, but then just recently I used Wubi again to reinstall Ubuntu. I assumed it did a fresh install though?

    Anyways this is what I got back. I also got frustrated and tried installing it again in the software center and I will show you the error message I got below the code.

    Code:
    rtwaller@ubuntu:~$ sudo ppa-purge ppa:jonoomph/openshot-edge
    [sudo] password for rtwaller: 
    Updating packages lists
    PPA to be removed: jonoomph openshot-edge
    Package revert list generated:
     openshot/quantal openshot-doc/quantal
    
    Disabling jonoomph PPA from 
    /etc/apt/sources.list.d/jonoomph-openshot-edge-quantal.list
    Updating packages lists
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    openshot is already the newest version.
    openshot-doc is already the newest version.
    Selected version '1.4.3-1' (Ubuntu:12.10/quantal [all]) for 'openshot'
    Selected version '1.4.3-1' (Ubuntu:12.10/quantal [all]) for 'openshot-doc'
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    PPA purged successfully
    rtwaller@ubuntu:~$ sudo ppa-purge ppa:pidgin-developers/ppa
    Updating packages lists
    PPA to be removed: pidgin-developers ppa
    Package revert list generated:
     libpurple0/quantal libpurple-bin/quantal pidgin/quantal pidgin-data/quantal 
    pidgin-ppa/quantal
    
    Disabling pidgin-developers PPA from /etc/apt/sources.list.d/pidgin-ppa.list
    Updating packages lists
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    E: Release 'quantal' for 'pidgin-ppa' was not found
    Unable to find an archive "quantal" for the package "pidgin-ppa"
    Unable to find an archive "quantal" for the package "pidgin-ppa"
    No packages will be installed, upgraded, or removed.
    0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0 B of archives. After unpacking 0 B will be used.
                                             
    PPA purged successfully using aptitude fallback
    rtwaller@ubuntu:~$ sudo rm /etc/apt/sources.list.d/*.list 
    rtwaller@ubuntu:~$ sudo wget "http://pastebin.com/raw.php?i=ymiVFerb" -O /etc/apt/sources.list 
    --2012-11-02 13:26:24--  http://pastebin.com/raw.php?i=ymiVFerb
    Resolving pastebin.com (pastebin.com)... 66.252.2.46
    Connecting to pastebin.com (pastebin.com)|66.252.2.46|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: unspecified [text/plain]
    Saving to: `/etc/apt/sources.list'
    
        [ <=>                                   ] 595         --.-K/s   in 0s      
    
    2012-11-02 13:26:24 (34.6 MB/s) - `/etc/apt/sources.list' saved [595]
    
    rtwaller@ubuntu:~$ sudo apt-get update 
    Ign http://us.archive.ubuntu.com quantal InRelease
    Ign http://us.archive.ubuntu.com quantal-security InRelease                    
    Ign http://us.archive.ubuntu.com quantal-updates InRelease                     
    Ign http://us.archive.ubuntu.com quantal-backports InRelease                   
    Get:1 http://us.archive.ubuntu.com quantal Release.gpg [933 B]
    Ign http://extras.ubuntu.com quantal InRelease                                 
    Ign http://archive.canonical.com quantal InRelease
    Get:2 http://us.archive.ubuntu.com quantal-security Release.gpg [933 B]
    Get:3 http://us.archive.ubuntu.com quantal-updates Release.gpg [933 B]         
    Get:4 http://us.archive.ubuntu.com quantal-backports Release.gpg [933 B]       
    Get:5 http://extras.ubuntu.com quantal Release.gpg [72 B]                      
    Get:6 http://archive.canonical.com quantal Release.gpg [933 B]                 
    Get:7 http://us.archive.ubuntu.com quantal Release [49.6 kB]                   
    Get:8 http://extras.ubuntu.com quantal Release [11.9 kB]                      
    Get:9 http://archive.canonical.com quantal Release [7,078 B]                   
    Get:10 http://us.archive.ubuntu.com quantal-security Release [49.6 kB]         
    Get:11 http://us.archive.ubuntu.com quantal-updates Release [49.6 kB]          
    Get:12 http://us.archive.ubuntu.com quantal-backports Release [49.6 kB]        
    Get:13 http://us.archive.ubuntu.com quantal/main amd64 Packages [1,137 kB]     
    Get:14 http://archive.canonical.com quantal/partner amd64 Packages [2,981 B]   
    Get:15 http://extras.ubuntu.com quantal/main amd64 Packages [745 B]            
    Get:16 http://us.archive.ubuntu.com quantal/restricted amd64 Packages [8,369 B]
    Get:17 http://us.archive.ubuntu.com quantal/universe amd64 Packages [5,274 kB] 
    Ign http://extras.ubuntu.com quantal/main Translation-en_US                    
    Ign http://archive.canonical.com quantal/partner Translation-en_US             
    Ign http://extras.ubuntu.com quantal/main Translation-en                       
    Ign http://archive.canonical.com quantal/partner Translation-en
    Get:18 http://us.archive.ubuntu.com quantal/multiverse amd64 Packages [131 kB]
    Get:19 http://us.archive.ubuntu.com quantal/main Translation-en [660 kB]
    Get:20 http://us.archive.ubuntu.com quantal/multiverse Translation-en [100 kB]
    Get:21 http://us.archive.ubuntu.com quantal/restricted Translation-en [2,575 B]
    Get:22 http://us.archive.ubuntu.com quantal/universe Translation-en [3,648 kB]
    Get:23 http://us.archive.ubuntu.com quantal-security/main amd64 Packages [27.6 kB]
    Get:24 http://us.archive.ubuntu.com quantal-security/restricted amd64 Packages [14 B]
    Get:25 http://us.archive.ubuntu.com quantal-security/universe amd64 Packages [5,042 B]
    Get:26 http://us.archive.ubuntu.com quantal-security/multiverse amd64 Packages [14 B]
    Get:27 http://us.archive.ubuntu.com quantal-security/main Translation-en [10.5 kB]
    Get:28 http://us.archive.ubuntu.com quantal-security/multiverse Translation-en [14 B]
    Get:29 http://us.archive.ubuntu.com quantal-security/restricted Translation-en [14 B]
    Get:30 http://us.archive.ubuntu.com quantal-security/universe Translation-en [3,150 B]
    Get:31 http://us.archive.ubuntu.com quantal-updates/main amd64 Packages [46.7 kB]
    Get:32 http://us.archive.ubuntu.com quantal-updates/restricted amd64 Packages [14 B]
    Get:33 http://us.archive.ubuntu.com quantal-updates/universe amd64 Packages [19.9 kB]
    Get:34 http://us.archive.ubuntu.com quantal-updates/multiverse amd64 Packages [14 B]
    Get:35 http://us.archive.ubuntu.com quantal-updates/main Translation-en [21.5 kB]
    Get:36 http://us.archive.ubuntu.com quantal-updates/multiverse Translation-en [14 B]
    Get:37 http://us.archive.ubuntu.com quantal-updates/restricted Translation-en [14 B]
    Get:38 http://us.archive.ubuntu.com quantal-updates/universe Translation-en [10.3 kB]
    Get:39 http://us.archive.ubuntu.com quantal-backports/main amd64 Packages [14 B]
    Get:40 http://us.archive.ubuntu.com quantal-backports/restricted amd64 Packages [14 B]
    Get:41 http://us.archive.ubuntu.com quantal-backports/universe amd64 Packages [1,066 B]
    Get:42 http://us.archive.ubuntu.com quantal-backports/multiverse amd64 Packages [14 B]
    Get:43 http://us.archive.ubuntu.com quantal-backports/main Translation-en [14 B]
    Get:44 http://us.archive.ubuntu.com quantal-backports/multiverse Translation-en [14 B]
    Get:45 http://us.archive.ubuntu.com quantal-backports/restricted Translation-en [14 B]
    Get:46 http://us.archive.ubuntu.com quantal-backports/universe Translation-en [1,265 B]
    Ign http://us.archive.ubuntu.com quantal/main Translation-en_US                
    Ign http://us.archive.ubuntu.com quantal/multiverse Translation-en_US          
    Ign http://us.archive.ubuntu.com quantal/restricted Translation-en_US          
    Ign http://us.archive.ubuntu.com quantal/universe Translation-en_US            
    Ign http://us.archive.ubuntu.com quantal-security/main Translation-en_US       
    Ign http://us.archive.ubuntu.com quantal-security/multiverse Translation-en_US 
    Ign http://us.archive.ubuntu.com quantal-security/restricted Translation-en_US 
    Ign http://us.archive.ubuntu.com quantal-security/universe Translation-en_US   
    Ign http://us.archive.ubuntu.com quantal-updates/main Translation-en_US        
    Ign http://us.archive.ubuntu.com quantal-updates/multiverse Translation-en_US  
    Ign http://us.archive.ubuntu.com quantal-updates/restricted Translation-en_US  
    Ign http://us.archive.ubuntu.com quantal-updates/universe Translation-en_US    
    Ign http://us.archive.ubuntu.com quantal-backports/main Translation-en_US      
    Ign http://us.archive.ubuntu.com quantal-backports/multiverse Translation-en_US
    Ign http://us.archive.ubuntu.com quantal-backports/restricted Translation-en_US
    Ign http://us.archive.ubuntu.com quantal-backports/universe Translation-en_US  
    Fetched 11.3 MB in 24s (462 kB/s)                                              
    Reading package lists... Done
    rtwaller@ubuntu:~$ sudo apt-get dist-upgrade
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Calculating upgrade... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    rtwaller@ubuntu:~$ sudo apt-get install wine
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     wine : Depends: wine1.4 but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    rtwaller@ubuntu:~$
    Package dependencies cannot be resolved
    This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time.

    The following packages have unmet dependencies:

    wine1.4: PreDepends: dpkg (>= 1.15.7.2~) but 1.16.7ubuntu6 is to be installed
    Depends: libc6 (>= 2.14) but 2.15-0ubuntu20 is to be installed
    Depends: wine1.4-amd64 (= 1.4.1-0ubuntu1) but 1.4.1-0ubuntu1 is to be installed
    Depends: wine1.4-i386 (= 1.4.1-0ubuntu1) but it is not going to be installed

  6. #16
    Join Date
    Jul 2007
    Location
    UK
    Beans
    16,922
    Distro
    Ubuntu Development Release

    Re: Need Help Installing Wine

    Wubi is just meant to trial ubuntu not for a permanent install.

    I would consider dual booting as you could spend ages getting wine plus apps to work and just be wasting your time.

    See limitations. http://en.wikipedia.org/wiki/Wubi_%2...u_installer%29

    From the developer
    Agostino: Wubi actually wasn’t designed to do long-term installations. The main aim was really to let people try out Ubuntu with confidence. Normally, users that start with Wubi tend to upgrade to a full installation to a dedicated partition at the next release cycle.
    http://howsoftwareisbuilt.com/2009/0...o-wubi-ubuntu/
    Last edited by philinux; November 2nd, 2012 at 08:09 PM.

  7. #17
    Join Date
    Feb 2012
    Location
    el_GR
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Need Help Installing Wine

    I don't know if Wubi have something to do with your problem , but if you had said that (wubi) from the start I would not answer at all. I cannot handle Wubi installations , they are virtual installations and I never used wubi and I really don't know how this installation ... behaves. (I only know that wubi is for testing Ubuntu)

    Please consider to do a regular dual boot (alongside Windows) . It is very-very faster and more-more reliable (in my opinion).

    Thanks

  8. #18
    Join Date
    Oct 2012
    Beans
    10

    Re: Need Help Installing Wine

    Thanks everyone for the replies. I had no clue that a wubi install was so much different. I just assumed it was another method of getting the OS.

    Sorry for the confusion and thanks for the help.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •