Page 1 of 6 123 ... LastLast
Results 1 to 10 of 53

Thread: No suspend after upgrade

  1. #1
    Join Date
    Apr 2007
    Location
    Århus, Denmark
    Beans
    233
    Distro
    Ubuntu 13.04 Raring Ringtail

    No suspend after upgrade

    How to troubleshoot broken suspend after upgrade to 12.04/12.10


    Hi.
    I got Ubuntu 12.10 Desktop AMD64 on Ideapad s205 AMD E-450.
    After upgrading to 12.04 and now to 12.10, suspend stopped working, it just locks up my laptop and I have to unplug it and remove the battery to get it back up and running.
    The newest kernels don't fix it, and I reported bugs on launchpad that haven't caught anybodies attention.
    AMD Catalyst Centre caused the locks when I installed it on 11.10, but after upgrading to 12.04 and 12.10 the laptop also locks up when using the Radeon driver.


    What can I do to get it to work, it a bother to have to shut it down all the time.
    Thanks.

  2. #2
    Join Date
    Apr 2007
    Location
    Århus, Denmark
    Beans
    233
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: No suspend after upgrade

    -Nobody?

  3. #3
    Join Date
    Jun 2012
    Beans
    20

    Re: No suspend after upgrade

    I can reproduce this on my S205 with 12.10 amd64 and fglrx. Both suspend and hibernate are broken.

  4. #4
    Join Date
    Apr 2007
    Location
    Århus, Denmark
    Beans
    233
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: No suspend after upgrade

    I can reproduce this on my S205 with 12.10 amd64 and fglrx. Both suspend and hibernate are broken.
    -But I'm just so glad that I'm not I only one on this planet with this problem.

    I got a bug report here:
    https://bugs.launchpad.net/ubuntu/+s...x/+bug/1022974

    Have you had any luck finding out how to go on solving this?
    Thank you.

  5. #5
    Join Date
    Jun 2012
    Beans
    20

    Re: No suspend after upgrade

    I tried blacklisting acer_wmi, switching back and forth between radeon (from xorg-edgers PPA) and fglrx (9.010 from PPA and 12.11 beta from here) and installing vanilla kernels from here (3.7 daily 201211030405).
    No luck so far.

  6. #6
    Join Date
    Apr 2007
    Location
    Århus, Denmark
    Beans
    233
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: No suspend after upgrade

    Have you ever had it working? -I did at som point on 11.10, but some update broke it. Unfortunatly it's to long ago and i can't remember the details.
    If i try running 11.10 live session it does not work.
    Have you got any idea why it is so hard getting help solving this issue, is it because everybody but me knows that it is unsolveable?

  7. #7
    Join Date
    Jun 2012
    Beans
    20

    Re: No suspend after upgrade

    It worked for me in 12.04. I didn't use my S205 for a while so I can't tell when it stopped working. As far as I know, it doesn't work in 12.04 today, either.

    I just shuffled through some old 3.2.0 kernels in 12.10, versions 3.2.0-23 to -32. Nothing works. Which is strange because it definitely worked with -23 under 12.04.

    I don't feel like reinstalling again - would you try Ubuntu 12.04 with this Kernel (and these headers)? You may have to remove linux-headers-generic and linux-image-generic because they always depend on the latest kernel available.

    Edit: One could also try Suspend while running the old 12.04 Live-CD
    Last edited by ppq; November 4th, 2012 at 03:33 PM.

  8. #8
    Join Date
    Apr 2007
    Location
    Århus, Denmark
    Beans
    233
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: No suspend after upgrade

    Thank you for your reply.
    I have a smaller partition with Quantal on for testing purpose, and i will test the kernels you suggest as soon as possible. If we can find the exact kernel where the break is, i think that we have a good chance to get it fixed. Are there any difference if it is 32 or 64 bit?

  9. #9
    Join Date
    Jun 2012
    Beans
    20

    Re: No suspend after upgrade

    I tested it in Quantal (12.10), but I don't have 12.04 (Precise) installed. Would you try it in Precise with the mentioned kernels?

    I only tried 64bit.

  10. #10
    Join Date
    Sep 2009
    Beans
    68
    Distro
    Ubuntu

    Re: No suspend after upgrade

    I can't get it working cleanly in 12.04 - keeps crashing, whether on suspend or on resume - no discernable patter to it so far.

    I have pm-suspend logs that refer to NetworkManager55 failure to suspend, though I think that should just result in loss of network connectivity at resume, as opposed to complete system freeze. I was running nouveau but changed to proprietary Nvidia - one of the newer ones, 300-something (I'm not at home) and the problem still remains. I woke up this morning to find screen frozen with small band of colour across the top...

Page 1 of 6 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •