I just did a clean install of Ubuntu 12.10, 64-bit.

My laptop's video card is an ATI FirePro M7740, which is apparently a Radeon HD 4xxx -series chip. So to use a proprietary driver, I installed the appropriate PPA and the "fglrx_legacy" package.

However, I now have a watermark in the bottom-right of my screen which reads "AMD Unsupported hardware".

Does anyone know how to remove this? I've found a few shell scripts which purport to, but they haven't been effective.