Results 1 to 5 of 5

Thread: Ubuntu 11.04+Canon LBP 2900 - installation issue

  1. #1
    Join Date
    Jun 2010
    Beans
    3

    Ubuntu 11.04+Canon LBP 2900 - installation issue

    Hi,

    I'm new to ubuntu. Installation of Canon LBP 2900 seems to be not working on ubuntu. After going through various posts I've come to notice that this is a teething issue for many ubuntu users.

    I've downloaded a driver raducotescuCanonCAPTDriverRelease 2.4-0- and installed the same. The installation was successful, the printer is recognized by the system. Print Jobs are being pushed to the queue. But nothing is getting printed. The readme file along with driver says it is installing CAPT v2.00 driver. But printer properties show that the capt driver version is 1.5

    Please help..

  2. #2
    Join Date
    Apr 2005
    Beans
    2,068

    Re: Ubuntu 11.04+Canon LBP 2900 - installation issue

    I suggest you delete the printer drivers that you have installed with the radonescu script

    If I offer the advice below:

    Ubuntu make good help available

    https://help.ubuntu.com/community/CanonCaptDrv190

    the essence is

    1) download and install the drivers

    ...........go here........

    http://support-asia.canon-asia.com/c...900772424.html

    to download the package that is CAPT Printer Driver for Linux Version 2.40

    ....the package comes down as Linux_CAPT_PrinterDriver_V240_uk_EN.tar.gz

    I suggest to SAVE the file to your downloads directory; and then open the directory; when you click on the file it should offer to open with ARCHIVE MANAGER; let it;

    go to the Debian folder; open 32bit or 64bit depending on which you have installed.....

    ....now the action............. install the drivers ......

    .........first install the common driver (cndrvcups-common.deb)...........and then the capt driver (cndrvcups-capt.deb).....make sure you do it in that order

    2) tell the system where to find the necessary bits:

    which for you would be

    Register the printer

    sudo /usr/sbin/lpadmin -p LBP2900 -m CNCUPSLBP2900CAPTK.ppd -v ccp://localhost:59787 -E

    ............................in Ubuntu 12.04 it is said ........"Ubuntu 12.04 has again blacklisted the usblp module"..........I didn't find this to be so with Mint, so my printer works by ignoring this ubuntu-specific advice...........



    In post #4 of this thread

    http://ubuntuforums.org/showthread.php?t=1982917

    Sivella, who is very good on the LBP continues the story that I have described above:

    3) Register the printer with ccpd daemon:

    sudo /usr/sbin/ccpdadmin -p LBP2900 -o /dev/usb/lp0


    4) Start ccpd daemon:

    sudo /etc/init.d/ccpd start


    Test install:

    captstatusui -P LBP2900


    will open the Statusmonitor window. If the message "Ready to print" is displayed --> all is OK.

    Try to print something.

    a) I have tried to put in quotes all the things you should copy and paste into a terminal............. you know how to open a terminal ?? ...... I use the menu command in the terminal as copy-c etc does not work in a terminal............

    b) if you get printing, as above; you need to automate the process: Sivella tells how in post #6 of the thread above

    have a read through it; please post back for help if it all looks tricky; I can try to help you through it
    Last edited by pdc; October 25th, 2012 at 11:28 PM.

  3. #3
    Join Date
    Jun 2010
    Beans
    3

    Re: Ubuntu 11.04+Canon LBP 2900 - installation issue

    Thank you Pdc for your elaborate reply. I followed your advise and did the following things.

    1. Removed the existing raducotescu drivers
    2. downloaded the gz file from canon
    3. opened the gz with archive manager
    4. installed the common and cups debs in that order
    5. connected the printer
    6. registered the printer as suggested
    7. ccpd start
    8. checked the status


    When checked the status it did open the status window, but there was no message. It was blank. what to do now?

    by the by, went thru seville's post. Think the instructions given are manageable, even if i do not understand many of them. But i have to reach that stage.

    pl help..

  4. #4
    Join Date
    Apr 2005
    Beans
    2,068

    Re: Ubuntu 11.04+Canon LBP 2900 - installation issue

    but there was no message. It was blank. what to do now?
    did you try

    Try to print something.

  5. #5
    Join Date
    Jun 2010
    Beans
    3

    Re: Ubuntu 11.04+Canon LBP 2900 - installation issue

    Try to print something.
    Yes..I tried to print a file from the text editor. Incidentally, the setup has created another printer "LBP2900-2" and has marked it as default printer. Initially, I tried printing keeping this as the default printer. Since the printing did not work out, I changed the default printer to "LBP2900" (did not delete the other printer) and tried printing again. In both cases, it shows that the job is being processed. Meanwhile, the "captstatusui -P LBP2900" command from terminal after passing the file to print still displays the status window blank.

    what to do now?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •