Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: radeon ati power saving

  1. #1
    Join Date
    Oct 2012
    Beans
    3

    Question radeon ati power saving

    Hi everybody,
    i've just passed to Ubuntu 12.10. I had windows 7 before. The problem is that now the pc is overheating and this is because of the GPU. On windows i could switch to "power saving" GPU but now i CANT. I've read that the solution is executing this 2 lines:
    echo profile > /sys/class/drm/card0/device/power_method
    echo low > /sys/class/drm/card0/device/power_profile

    but i got: "Not such file or directory" because this files dont exist on the file system. Anybody has tha same problem or know the answer? THANKS A LOT
    Last edited by sebastian3310; October 24th, 2012 at 11:26 PM.

  2. #2
    Join Date
    Mar 2011
    Location
    New Zealand
    Beans
    443
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: radeon ati power saving

    Hi, I also have switchable graphics on my system, it also got really hot.

    I had the same problem: 'no such file or directory' when I did the command.
    A clean install fixed it for me (I think something changes when you install a driver).
    Anyway test it on a livecd/liveusb and see if that works if it does then you might want to do a reinstall.
    It did the trick for me

  3. #3
    Join Date
    Mar 2011
    Location
    New Zealand
    Beans
    443
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: radeon ati power saving

    These are the instructions I followed:
    I have an HP dv7-6b78us with hybrid graphics - an ATI Radeon and an Intel graphics card.
    They're both on by default and the Intel is more than enough power for my use.
    Here's how I managed to turn off the Radeon and save massive battery life:

    First, make sure you've uninstalled any proprietary graphics drivers.
    There's a proprietary driver thingy in the administrative menu for that.

    Next, add these to /etc/rc.local above the 'exit 0' line (e.g. sudo nano /etc/rc.local from the terminal):
    Code:
    modprobe radeon
    echo OFF > /sys/kernel/debug/vgaswitcheroo/switch
    And then add this to /etc/modprobe.d/blacklist-local.conf, also as sudo:
    Code:
    blacklist fglrx
    Reboot. Verify by doing the following:
    Code:
    sudo cat /sys/kernel/debug/vgaswitcheroo/switch
    You should see something like this:
    Code:
    0:IGD:+:Pwr:0000:00:02.0
    1:DIS: :Off:0000:01:00.0
    IGD is the Intel chip, the + means it's the one in use, and Pwr means it's on.
    DIS is the ATI card and if it says Off, you're saving a ton of battery.

    This is a permanent fix that lasts across reboots.
    Let us know how it goes

  4. #4
    Join Date
    Oct 2012
    Beans
    3

    Re: radeon ati power saving

    Hi Johny, thanks for your answer. But i dont want to switch the graphic card from radeon to Inten, i just have readeon on my pc. I want to tell radeon to work with LESS POWER and avoid overheating!! maybe i dont find the files: power_profile and power_method because i dont have installed the open source driver???? how can i do that?? Please help!!!!

  5. #5
    Join Date
    Nov 2009
    Beans
    Hidden!
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: radeon ati power saving

    what are the system specs?
    Easy to understand Ubuntu manual with lots of pics: http://ubuntu-manual.org/
    Do i need antivirus/firewall in linux?
    User friendly disk backup: Redobackup

  6. #6
    Join Date
    Mar 2011
    Location
    New Zealand
    Beans
    443
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: radeon ati power saving

    What graphics card do you have? if you do
    Code:
    lspci
    in the terminal it will spit out a list of devices attached to your computer. If you do
    Code:
    lspci | grep "ATI"
    it will only grap lines with the word ATI. Anyway that should let you know what card you have. As for the driver search for it in synaptic package manager and simply install the package (at least I think its that simple). Not sure what package you need but we can look into it when we know what card you have.

    As for the no such file or directory error I'm stumped. You could try run the command on a livecd just to see if it works on a fresh system.

  7. #7
    Join Date
    Nov 2005
    Beans
    46

    Re: radeon ati power saving

    I use AMDOverdriveCTRL which you can pickup from

    http://sourceforge.net/projects/amdovdrvctrl/

    It works like a charm with my 6770. I have 2 profiles saved, 1 low and 1 medium and use it's bezier model for FanCtrl. I keep it on low for desktop and my GPU temp is identical to windows 7.

    Before installing my GPU was hitting 70 degrees and up on normal desktop usage.

    Just make a note of low settings and set medium and high to match and save them as a power save or desktop profile and load them when it starts. Should sort things out for you. Oh I'm using the AMD Drivers and not the Open Source ones.

  8. #8
    Join Date
    Oct 2012
    Beans
    3

    Re: radeon ati power saving

    Hi psychobudgie,
    i tried the program but it says driver catalyst is not installed..should i install them?
    This is the output of the command: lspci | grep "ATI":

    01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Madison [Radeon HD 5000M Series]
    01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Redwood HDMI Audio [Radeon HD 5000 Series]


    any idea??? my pc is burning ;(

  9. #9
    Join Date
    Dec 2008
    Location
    Middle o'nowhere
    Beans
    451
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: radeon ati power saving

    Ditto for me:

    :>)@Inspiron-620s:~$ lspci | grep "ATI"

    01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Caicos [Radeon HD 6450]
    01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Caicos HDMI Audio [Radeon HD 6400 Series]


    :>)@Inspiron-620s:~$ AMDOverdriveCtrl

    ERR: Error: Could not Init library.
    WRN: Adapter index out of range. Index forced to zero.
    INF: Adapter index 0 choosen.
    INF: Nr. of Performance Levels: 0
    ERR: ADL does not report default performance levels.

  10. #10
    Join Date
    Mar 2011
    Location
    New Zealand
    Beans
    443
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: radeon ati power saving

    The open source drivers are known for getting reallly hot.
    Thanks for the info Psychobudgie! Thanks a lot.
    I also have an Radeon 6700M with switchable graphics and found the only solution to be to not use the 6700m and switch to integrated. I may use the Radeon after all
    Psychobudgie do you have catalyst installed?
    @Sebastian you can get catalyst control centre from amds website with their proprietary driver with which I have had no luck.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •