Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: xvidenc syntax

  1. #1
    Join Date
    Aug 2006
    Beans
    311

    xvidenc syntax

    Apologies for the inanity of this ... but I am not able to figure out the syntax (nor can I find it anywhere) for encoding a file.

    xvidenc figures my filename is an option ... or a preset.

    Can anyone help.

    TIA

  2. #2
    Join Date
    Dec 2006
    Beans
    6,815

    Re: xvidenc syntax

    The options can all be seen with:

    Code:
    xvidenc -help
    There is an example in there to start with:

    Code:
    xvidenc -2p -p ehq
    which might provide a suitable starting point. The file or dvd is then selected interactively.
    You think that's air you're breathing now?

  3. #3
    Join Date
    Aug 2006
    Beans
    311

    Re: xvidenc syntax

    Thank you for your help.

    It now looks like it will work. But ... the input has me baffled.

    If I try to encode a DVD I get the message "No such block device" whatever I input.

    And if I try to encode a VIDEO_TS I get the message "Directory not specified or does not exist" regardless of what "path" I type in.

    Can you explain what's missing or what's required?

    Thanks in anticipation.

  4. #4
    Join Date
    Dec 2006
    Beans
    6,815

    Re: xvidenc syntax

    Concerning the DVD you should be able to test as follows:

    Code:
    andrew@skamandros~$ xvidenc -scan 
    
    Would you like to scan a video file or a DVD? [file/vcd/dvd]: dvd
    
    -> Found device: /dev/sr1
    -> Found device: /dev/sr0
    -> Found symbolic link to DVD device: /dev/dvd -> sr0
    -> Found symbolic link to DVD device: /dev/dvd0 -> sr0
    -> Found symbolic link to DVD device: /dev/dvd1 -> sr1
    -> Found symbolic link to DVD device: /dev/dvdr -> sr0
    -> Found symbolic link to DVD device: /dev/dvdr0 -> sr0
    -> Found symbolic link to DVD device: /dev/dvdr1 -> sr1
    -> Found symbolic link to DVD device: /dev/dvdrw -> sr0
    -> Found symbolic link to DVD device: /dev/dvdrw0 -> sr0
    -> Found symbolic link to DVD device: /dev/dvdrw1 -> sr1
    -> Found symbolic link to DVD device: /dev/dvdwriter -> sr0
    -> Found symbolic link to DVD device: /dev/dvdwriter0 -> sr0
    -> Found symbolic link to DVD device: /dev/dvdwriter1 -> sr1
    
    Specify the DVD Device [default is /dev/dvd]:
    and on my system the field should be /dev/dvd , it may be different on yours...
    You think that's air you're breathing now?

  5. #5
    Join Date
    Aug 2006
    Beans
    311

    Re: xvidenc syntax

    Thanks.

    It shows up using "xvidenc -scan *".


    However it does NOT show up with "xvidenc -scan" - which is what I had already used.


    Thanks again.

  6. #6
    Join Date
    Dec 2006
    Beans
    6,815

    Re: xvidenc syntax

    So it works for you now?
    You think that's air you're breathing now?

  7. #7
    Join Date
    Aug 2006
    Beans
    311

    Re: xvidenc syntax

    Well ... yes and no.

    The first dvd I encoded produced no audio.

    I wasn't sure if this was perhaps "my fault" ... chose an incorrect option or whatever.

    So I tried again with a different dvd ... and it was fine.

    Went back to the first, "carefully" ... and got the same "no audio" result.

    What does this mean? I haven't a clue.

  8. #8
    Join Date
    Dec 2006
    Beans
    6,815

    Re: xvidenc syntax

    Try the following command and see if you need to add a few libraries:

    Code:
    andrew@skamandros~$ xvidenc -sc
    
    -> Checking for 'MPlayer'..................... OK
    -> Checking for 'MEncoder'.................... OK
    -> Xvid video support in MEncoder............. YES
    -> AAC (FAAC) audio support in MEncoder....... YES
    -> MP3 (LAME) audio support in MEncoder....... YES
    -> AC3 (lavc) audio support in MEncoder....... YES
    -> PCM audio support in MEncoder.............. YES
    
    -> Checking for 'bc'.......................... OK
    -> Checking for 'pv'.......................... FAILED! [no support for DVD ISO dumps]
    -> Checking for 'dd'.......................... OK
    -> Checking for 'neroAacEnc'.................. OK
    -> Checking for 'aacplusenc'.................. FAILED! [no support for AAC+ audio]
    -> Checking for 'oggenc'...................... OK
    -> Checking for 'flac'........................ OK
    -> Checking for 'less'........................ OK
    -> Checking for 'lsdvd'....................... OK
    -> Checking for 'dvdxchap' (from ogmtools).... FAILED! [no support for DVD chapters export]
    -> Checking for 'mkvmerge' (from mkvtoolnix).. OK
    -> Checking for 'ogmmerge' (from ogmtools).... FAILED! [no support for the OGM container]
    -> Checking for 'MP4Box' (from gpac).......... OK
    
    If you have installed a required program but the script
    can't find it, run 'xvidenc -r' to reset the config file.
    If you have to add a couple of libraries don't forget the xvidenc -r command to reset the config file...
    You think that's air you're breathing now?

  9. #9
    Join Date
    Aug 2006
    Beans
    311

    Re: xvidenc syntax

    I'll give that a try. Thanks!

    That sad, I am REALLY surprised to learn that a missing library doesn't result in an error message though.

    Or is it possible that something else is amiss - some cunning code on the DVD for instance ...

  10. #10
    Join Date
    Aug 2006
    Beans
    311

    Re: xvidenc syntax

    O.k. Done.

    Everything "o.k." except:

    -> Checking for 'neroAacEnc'.................. FAILED! [no support for AAC+ audio]
    -> Checking for 'aacplusenc'.................. FAILED! [no support for AAC+ audio]

    One of which I see you have too. And one which you don't.

    So! This leads me to 2 questions. 1 - is it possible/likely that it (aacplusenc) is the cause of the no audio problem? 2 - what can/do I do about it.

    Thanks in anticipation yet again.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •