Page 4 of 11 FirstFirst ... 23456 ... LastLast
Results 31 to 40 of 107

Thread: fglrx in raring

  1. #31
    Join Date
    Aug 2006
    Location
    Just call me J
    Beans
    1,053
    Distro
    Ubuntu Development Release

    Re: fglrx in raring

    New package for 12.11 coming shortly:

    Code:
    fglrx-installer (2:9.010-0ubuntu1) raring; urgency=low
    
      * New upstream release.
      * debian/dkms.conf.in,
        replace-archdata.acpi_handle-with-acpi_node.handle.patch:
        - Add support for Linux 3.8 (LP: #1095755).
          Thanks to Robert Hooker for the patch.
      * debian/substvars:
        - Remove versioned dependency on xserver-xorg-core.
      * debian/10fglrx.in, debian/rules:
        - Fix paths which prevented OpenGL operations on hybrid systems
          on amd64 (LP: #1068661). Thanks to Nick Andrik for the patch.
    
    Date: Tue, 08 Jan 2013 16:12:09 +0100
    1) MSI GT70: i7-3650, 16GB, GTX680M, XFCE@Manjaro-x64
    2) Dell Studio 1749
    : i5-540, 8GB, ATi 5650, Intel 5300AGN XFCE@Manjaro-x64
    3) Lenovo X61: C2D T7200, 2GB, Intel HDA, iwlwifi, XFCE@Manjaro-x64-OpenRC

  2. #32
    Join Date
    Mar 2012
    Beans
    28

    Re: fglrx in raring

    Quote Originally Posted by jfernyhough View Post
    New package for 12.11 coming shortly:

    Code:
    fglrx-installer (2:9.010-0ubuntu1) raring; urgency=low
    
      * New upstream release.
      * debian/dkms.conf.in,
        replace-archdata.acpi_handle-with-acpi_node.handle.patch:
        - Add support for Linux 3.8 (LP: #1095755).
          Thanks to Robert Hooker for the patch.
      * debian/substvars:
        - Remove versioned dependency on xserver-xorg-core.
      * debian/10fglrx.in, debian/rules:
        - Fix paths which prevented OpenGL operations on hybrid systems
          on amd64 (LP: #1068661). Thanks to Nick Andrik for the patch.
    
    Date: Tue, 08 Jan 2013 16:12:09 +0100
    it gave me the unsupported hardware watermark on a HD 6950

  3. #33
    Join Date
    Sep 2010
    Beans
    26

    Re: fglrx in raring

    Quote Originally Posted by Nemesis2012 View Post
    it gave me the unsupported hardware watermark on a HD 6950
    I get that as well with my HD 6870..seems pretty good otherwise.

    edit: I found that the old fix to remove it still works fine, but make a backup copy of fglrx_drv.so to be safe.

    Code:
    #!/bin/sh
    DRIVER=/usr/lib/fglrx/xorg/modules/drivers/fglrx_drv.so
    for x in $(objdump -d $DRIVER|awk '/call/&&/EnableLogo/{print "\\x"$2"\\x"$3"\\x"$4"\\x"$5"\\x"$6}'); do
    sed -i "s/$x/\x90\x90\x90\x90\x90/g" $DRIVER
    done
    Last edited by MadNachos; January 11th, 2013 at 06:34 AM. Reason: added info

  4. #34
    Join Date
    Mar 2012
    Beans
    28

    Re: fglrx in raring

    Quote Originally Posted by MadNachos View Post
    I get that as well with my HD 6870..seems pretty good otherwise.

    edit: I found that the old fix to remove it still works fine, but make a backup copy of fglrx_drv.so to be safe.

    Code:
    #!/bin/sh
    DRIVER=/usr/lib/fglrx/xorg/modules/drivers/fglrx_drv.so
    for x in $(objdump -d $DRIVER|awk '/call/&&/EnableLogo/{print "\\x"$2"\\x"$3"\\x"$4"\\x"$5"\\x"$6}'); do
    sed -i "s/$x/\x90\x90\x90\x90\x90/g" $DRIVER
    done
    its not letting me see my temp as well

  5. #35
    Join Date
    Nov 2012
    Beans
    3

    Re: fglrx in raring

    Quote Originally Posted by Nemesis2012 View Post
    its not letting me see my temp as well
    I can se my temp. 7770

  6. #36
    Join Date
    Aug 2006
    Location
    Just call me J
    Beans
    1,053
    Distro
    Ubuntu Development Release

    Re: fglrx in raring

    Quote Originally Posted by MadNachos View Post
    I get that as well with my HD 6870..seems pretty good otherwise.

    edit: I found that the old fix to remove it still works fine, but make a backup copy of fglrx_drv.so to be safe.

    Code:
    #!/bin/sh
    DRIVER=/usr/lib/fglrx/xorg/modules/drivers/fglrx_drv.so
    for x in $(objdump -d $DRIVER|awk '/call/&&/EnableLogo/{print "\\x"$2"\\x"$3"\\x"$4"\\x"$5"\\x"$6}'); do
    sed -i "s/$x/\x90\x90\x90\x90\x90/g" $DRIVER
    done
    Or you could just replace /etc/ati/control with a release version?
    1) MSI GT70: i7-3650, 16GB, GTX680M, XFCE@Manjaro-x64
    2) Dell Studio 1749
    : i5-540, 8GB, ATi 5650, Intel 5300AGN XFCE@Manjaro-x64
    3) Lenovo X61: C2D T7200, 2GB, Intel HDA, iwlwifi, XFCE@Manjaro-x64-OpenRC

  7. #37
    Join Date
    Sep 2010
    Beans
    26

    Re: fglrx in raring

    Quote Originally Posted by jfernyhough View Post
    Or you could just replace /etc/ati/control with a release version?
    Are you asking? 'Cus I don't know.

  8. #38
    Join Date
    Aug 2006
    Location
    Just call me J
    Beans
    1,053
    Distro
    Ubuntu Development Release

    Re: fglrx in raring

    Apologies. Instead of manually binary patching the driver you can just replace the control file which tells the driver which card IDs are supported. Given that the latest driver is based on a driver for embedded devices most normal desktop parts aren't supported by that driver. Replacing the control file with one from a desktop release simply replaces the compatible ID list.

    In theory there may be incompatibilities between the beta driver releases and unsupported devices, which is why you get the watermark, but in practice the drivers have been pretty much the same.
    1) MSI GT70: i7-3650, 16GB, GTX680M, XFCE@Manjaro-x64
    2) Dell Studio 1749
    : i5-540, 8GB, ATi 5650, Intel 5300AGN XFCE@Manjaro-x64
    3) Lenovo X61: C2D T7200, 2GB, Intel HDA, iwlwifi, XFCE@Manjaro-x64-OpenRC

  9. #39
    Join Date
    Jun 2005
    Location
    Boston, MA via Donegal
    Beans
    452
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Question Re: fglrx in raring

    Will these drivers work with older ATI graphics card such as the Mobility Radeon HD 3400 Series?

    Thanks!

  10. #40
    Join Date
    Aug 2006
    Location
    Just call me J
    Beans
    1,053
    Distro
    Ubuntu Development Release

    Re: fglrx in raring

    Quote Originally Posted by bettlebrox View Post
    Will these drivers work with older ATI graphics card such as the Mobility Radeon HD 3400 Series?
    No. There are not any fglrx drivers for cards older than the 5000-series which work with xserver 1.13.

    If you want fglrx you'll have to stick with Precise; if you want to run Raring you can use the open-source drivers (which should by now perform about as well as well as the proprietary ones for most stuff).
    1) MSI GT70: i7-3650, 16GB, GTX680M, XFCE@Manjaro-x64
    2) Dell Studio 1749
    : i5-540, 8GB, ATi 5650, Intel 5300AGN XFCE@Manjaro-x64
    3) Lenovo X61: C2D T7200, 2GB, Intel HDA, iwlwifi, XFCE@Manjaro-x64-OpenRC

Page 4 of 11 FirstFirst ... 23456 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •