Page 2 of 11 FirstFirst 1234 ... LastLast
Results 11 to 20 of 107

Thread: fglrx in raring

  1. #11
    Join Date
    Oct 2005
    Location
    Estonia / Sweden
    Beans
    2,332
    Distro
    Ubuntu Development Release

    Re: fglrx in raring

    So what is the proper approach to get HD4xxx working? There used to be some legacy drivers, but does anyone know what is the status on this?

  2. #12
    Join Date
    Feb 2007
    Beans
    Hidden!

    Re: fglrx in raring

    Quote Originally Posted by meborc View Post
    So what is the proper approach to get HD4xxx working? There used to be some legacy drivers, but does anyone know what is the status on this?
    Still not upgraded to X-server 1.13 but there's a working legacy driver for Radeon HD 2xxx-4xxx series cards.

    PPA: AMD Catalyst Legacy :
    https://launchpad.net/~makson96/+archive/fglrx
    The PPA downgrades X-server and includes a patch for the 3.5 kernel.

    How To Install AMD Catalyst Legacy Drivers in Ubuntu 12.10
    http://www.ubuntuvibes.com/2012/10/h...st-legacy.html

  3. #13
    Join Date
    Jan 2006
    Location
    Denmark
    Beans
    571
    Distro
    Ubuntu Development Release

    Re: fglrx in raring

    @Bowmore
    Thanks a lot for the provided links
    Works perfectly with my Radeon HD 4670
    ( well the AMD/ATI driver never was and never will be perfect , but it works mostly)
    Even got my splash screen back, it is missing when you use the open source driver.

    I tried with these two:

    flight-of-the-navigator
    and
    Lights from Ellie Goulding
    Attached Images Attached Images
    Last edited by Stinger; December 8th, 2012 at 06:39 PM. Reason: Added Catalyst control center

  4. #14
    Join Date
    Dec 2012
    Beans
    1

    Re: fglrx in raring

    Thanks. Works perfectly with my HD 5870.
    Last edited by 4ss4ssini; December 9th, 2012 at 01:15 PM.

  5. #15
    Join Date
    Aug 2006
    Location
    Just call me JF
    Beans
    1,052
    Distro
    Ubuntu Development Release

    Re: fglrx in raring

    There's a new fglrx package in X-Swat (https://launchpad.net/~ubuntu-x-swat/+archive/x-updates) : fglrx-installer-experimental-9. Current version is 2:9.010.12-0ubuntu0~xup1 and it's built for raring so it should work with kernel 3.7.

    $ sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
    $ sudo apt-get update
    $ sudo apt-get install fglrx-installer-experimental-9

    Giving it a go myself now.

    Currently 64-bit package is not built. Give it a minute.
    Last edited by jfernyhough; December 13th, 2012 at 12:31 AM.
    1) Dell Studio 1749: i5 540 (2.5GHz), 8GB, ATi 5650, Intel 5300AGN XFCE@Manjaro-x64
    2) Lenovo X61: C2D T7200, 2GB, Intel HDA, iwlwifi, XFCE@Manjaro-x64
    3) Compaq Mini 311c: Atom N270 (OC@2.0GHz), 3GB, Nvidia ION, Broadcom G+BT XFCE@13.10x32

  6. #16
    Join Date
    Mar 2012
    Beans
    28

    Re: fglrx in raring

    Quote Originally Posted by jfernyhough View Post
    There's a new fglrx package in X-Swat (https://launchpad.net/~ubuntu-x-swat/+archive/x-updates) : fglrx-installer-experimental-9. Current version is 2:9.010.12-0ubuntu0~xup1 and it's built for raring so it should work with kernel 3.7.

    $ sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
    $ sudo apt-get update
    $ sudo apt-get install fglrx-installer-experimental-9

    Giving it a go myself now.

    Currently 64-bit package is not built. Give it a minute.
    no 64bit just upgraded to 13.04 64bit last night been trying to install the beta catalyst no luck so far going to try to patch it and see if it works

    i found the “xorg crack pushers” team xorg-edgers fresh X crack https://launchpad.net/~xorg-edgers/+archive/ppa
    Last edited by Nemesis2012; December 13th, 2012 at 05:06 PM. Reason: found one for 64bit embedded only?

  7. #17
    Join Date
    Aug 2006
    Location
    Just call me JF
    Beans
    1,052
    Distro
    Ubuntu Development Release

    Re: fglrx in raring

    I always forget about Edgers... not sure why.

    Their fglrx is "based on new upstream release: 12.12" (2:9.010.12-0ubuntu1~xedgers~raring1) so it's newer than the beta on the AMD site. Interesting.

    I've added that PPA so let's see what happens...

    --edit
    Grr... "Unsupported hardware" watermark...

    Ah ha! A new embedded driver for 12.12: http://support.amd.com/us/gpudownloa...ded_linux.aspx
    http://www2.ati.com/drivers/embedded...EDG_Direct.zip

    This would explain the watermark. Now to find which file to replace... I think it's /etc/ati/control

    Yup, copying the control from 12.11b11 sorts out the watermark (attached).
    Attached Files Attached Files
    Last edited by jfernyhough; December 13th, 2012 at 02:34 PM.
    1) Dell Studio 1749: i5 540 (2.5GHz), 8GB, ATi 5650, Intel 5300AGN XFCE@Manjaro-x64
    2) Lenovo X61: C2D T7200, 2GB, Intel HDA, iwlwifi, XFCE@Manjaro-x64
    3) Compaq Mini 311c: Atom N270 (OC@2.0GHz), 3GB, Nvidia ION, Broadcom G+BT XFCE@13.10x32

  8. #18
    Join Date
    Mar 2012
    Beans
    28

    Re: fglrx in raring

    Quote Originally Posted by jfernyhough View Post
    I always forget about Edgers... not sure why.

    Their fglrx is "based on new upstream release: 12.12" (2:9.010.12-0ubuntu1~xedgers~raring1) so it's newer than the beta on the AMD site. Interesting.

    I've added that PPA so let's see what happens...

    --edit
    Grr... "Unsupported hardware" watermark...

    Ah ha! A new embedded driver for 12.12: http://support.amd.com/us/gpudownloa...ded_linux.aspx
    http://www2.ati.com/drivers/embedded...EDG_Direct.zip

    This would explain the watermark. Now to find which file to replace... I think it's /etc/ati/control

    Yup, copying the control from 12.11b11 sorts out the watermark (attached).
    i installed the beta catalyst for my 6950 form amd.com using Vi0l0's patch i seen the drivers form the repo's was embedded as well Vi0l0's patch let me install the beta catalyst on kernel 3.7 looks like its is working just fine so far on ubuntu 13.04

  9. #19
    Join Date
    May 2008
    Beans
    41

    Re: fglrx in raring

    i installed the drivers from ppa: xorg-edgers/ppa

    but i have a serious memory leak in xorg with these drivers
    (dont know if its driver related or xorg related but its a memory leak alright)

    specs :

    acer 522 amd c-60
    xubuntu 13.04
    AMD Radeon HD 6290 Graphics
    catalyst version 12.9
    driver packaging version 9.01-121106a-150335C-EDG_Direct

    kernel :
    Code:
    uname -a
    Linux Aspire-One-522 3.7.0-7-generic #15-Ubuntu SMP Sat Dec 15 14:13:08 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

  10. #20
    Join Date
    Feb 2007
    Beans
    192

    Re: fglrx in raring

    Anybody got 12.12 working with the 3.8 kernel?
    Clevo/Sager i7-2670 | 8gb ram | ATI 6970 | SSD drive | [I] Ubuntu: 14.04 / 13.10 /

Page 2 of 11 FirstFirst 1234 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •