Results 1 to 4 of 4

Thread: 12.10 starts only with nomodeset

  1. #1
    Join Date
    Jan 2009
    Beans
    Hidden!
    Distro
    Ubuntu 11.04 Natty Narwhal

    12.10 starts only with nomodeset

    When I installed Lubuntu 12.04 (amd64) I had that infamous B43 firmware problem, but I was able to find a workaround.

    This time, installing Lubuntu 12.10 (amd64) I wasn't able to find a solution for the B43 firmware problem.

    I've tried the same steps that have worked for many other users, as you can find here http://ubuntuforums.org/showpost.php...44&postcount=6 and here http://ubuntuforums.org/showpost.php...51&postcount=9, just to name a few.

    Apart from blank screens or blinking dash, the only message that I got was
    Code:
    `yes' is an invalid parameter for `blacklist'
    despite having tried all the suggested combinations of positions of b43.blacklist=yes, spaces and so on.

    The only way I was able to install Lubuntu was by adding nomodeset to the boot options. Then I was able to start it, download the required drivers, reboot only to find out that I get a blank screen.

    The only way to get it working is by putting nomodeset in the grub options.

    On the other hand my Broadcom WiFi card works perfectly.

    My graphic card is an ATI Mobibility Radeon X700 and I don't have fglrx installed, but I don't remember to having installed it in the past.

    I've been googling and searching here for a while but I came up with no solution, so I decided to open this thread.

    Thanks in advance for you help!

  2. #2
    Join Date
    May 2007
    Beans
    12,426

    Re: 12.10 starts only with nomodeset

    The radeon X700 series hasn't been supported with AMD drivers for years. The default Radeon driver SHOULD work, but it doesn't work for me and others are reporting problems as well.
    Ubuntu 14.04, Mint 17; MS Win 8.1.
    Will not respond to PM requests for support -- use the forums.

  3. #3
    Join Date
    Jan 2009
    Beans
    Hidden!
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: 12.10 starts only with nomodeset

    Quote Originally Posted by Mark Phelps View Post
    The radeon X700 series hasn't been supported with AMD drivers for years. The default Radeon driver SHOULD work, but it doesn't work for me and others are reporting problems as well.
    I know, but it has been working for years, up to the 12.10 version.

    Looks like it's time to look for another distro.

  4. #4
    Join Date
    Apr 2006
    Location
    Ubuntuland
    Beans
    2,118
    Distro
    Ubuntu 13.10 Saucy Salamander

    Lightbulb Re: 12.10 starts only with nomodeset

    Quote Originally Posted by Blitz Tungsten View Post
    I know, but it has been working for years, up to the 12.10 version.

    Looks like it's time to look for another distro.
    This is not something surprising or new. OS's only support old hardware for so long. Sounds like 12.04.01 would be a better choice for that hardware.
    24 beers in a case, 24 hours in a day. Coincidence? I think not!

    Saucy Salamander 64 bit, AMD Phenom II 955 Quad Core 3.2GHz, GeForce 8300
    8G PC2-6400 RAM, 128 GB SSD, Twin 1TB SATA 7200 RPM RAID0

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •