Results 1 to 3 of 3

Thread: Disabling internal laptop speakers when I connect the headphone jack

  1. #1
    Join Date
    Aug 2011
    Beans
    9

    Disabling internal laptop speakers when I connect the headphone jack

    Hi all,

    I have a Toshiba C665-P5010 laptop, and I'm running Ubuntu 10.04 LTS. When I connect the headphones, the internal speakers were not getting muted, and I was getting output from both the speakers and the headphones. I tried the steps outlined here:

    http://playingwithsid.blogspot.in/20...in-ubuntu.html

    But the issue remained.

    I tried the steps here:

    http://www.stchman.com/feisty_tips.html
    (section "Mute speakers when headphones are used")

    Now, it appears my soundcard is completely disabled (When I click on the speaker icon and go to "Sound Preferences", there is no device in the "Hardware" tab, and on the "Output" tab, there is only one entry "Dummy Output").

    How can I reverse this process, and get my original issue solved?

    Thanks,
    akhil520c

  2. #2
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Disabling internal laptop speakers when I connect the headphone jack

    Quote Originally Posted by akhil520c View Post
    How can I reverse this process, and get my original issue solved?

    Thanks,
    akhil520c
    If all you did was follow the procedure in that link, then you should be able to just edit the /etc/modprobe.d/alsa-base.conf file, remove the entry you added, and reboot.

    You might also want to try this entry in that file instead:
    Code:
    options snd-hda-intel model=ideapad
    Reference link: http://www.linlap.com/wiki/toshiba+satellite+c655d

    EDIT: If still no luck, try running the following command from a terminal window:
    Code:
    wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
    ...choose the upload option and post back the link provided.
    Last edited by Toz; February 9th, 2012 at 06:00 AM.

  3. #3
    Join Date
    Aug 2011
    Beans
    9

    Re: Disabling internal laptop speakers when I connect the headphone jack

    Hi Toz

    Sorry for the very delayed reply, but here is the link to my alsa information.

    http://www.alsa-project.org/db/?f=82...83493d76c803e6

    The headphone jack sense works on windows (for your information). Thanks in advance.

    -akhil520c

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •