Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: mythlogserver 100% cpu

  1. #1
    Join Date
    May 2006
    Beans
    Hidden!
    Distro
    Kubuntu 13.04 Raring Ringtail

    mythlogserver 100% cpu

    Upgraded to 0.26 yesterday using the mythbuntu ppa.

    randomly mythlogserver is hitting 100% cpu, anyone else had this problem?

    got a bash script killing it if it goes above 40% but that's not ideal is it.

  2. #2
    Join Date
    Oct 2008
    Beans
    308

    Re: mythlogserver 100% cpu

    Quote Originally Posted by deadite66 View Post
    Upgraded to 0.26 yesterday using the mythbuntu ppa.

    randomly mythlogserver is hitting 100% cpu, anyone else had this problem?

    got a bash script killing it if it goes above 40% but that's not ideal is it.
    I have the same issue with 12.10

  3. #3
    Join Date
    Nov 2012
    Beans
    6

    Re: mythlogserver 100% cpu

    Quote Originally Posted by deadite66 View Post
    Upgraded to 0.26 yesterday using the mythbuntu ppa.

    randomly mythlogserver is hitting 100% cpu, anyone else had this problem?

    got a bash script killing it if it goes above 40% but that's not ideal is it.
    Would you mind sharing that script as a quickfix?
    I'm a newbie and I am also having this problem.
    It causes my backend box to get very loud .

  4. #4
    Join Date
    May 2006
    Beans
    Hidden!
    Distro
    Kubuntu 13.04 Raring Ringtail

    Re: mythlogserver 100% cpu

    sure, i run this as root every 5 minutes.
    if the service is more than 40% it will be killed and email will be sent to my root Maildir, shouldn't be too hard to adjust as needed.

    Code:
    #!/bin/bash
    mythlogload=`top -b -n1 |grep mythlogserver |head -n1 |awk -F' ' '{ print $9 }'`
    #echo $mythlogload
    
    if [ $mythlogload -gt 40 ]; then
    	kill `pidof mythlogserver`
    	echo "Killed mythlogserver" |mailx -s 'Killed mythlogserver' root@sakura
    fi

  5. #5
    Join Date
    Nov 2012
    Beans
    6

    Cool Re: mythlogserver 100% cpu

    I kept getting an error about it expecting an integer, so I modified it.
    I hope this works.

    Code:
    #!/bin/bash
    mythlogload=`top -b -n1 |grep mythlogserver |head -n1 |awk -F' ' '{ print $9 }'`
    mythlogload=$( printf "%.0f" $mythlogload)
    
    if [ $mythlogload -gt 80 ]; then
         kill `pidof mythlogserver`
         echo "Killed mythlogserver"
    fi
    Last edited by Hidyman; November 27th, 2012 at 03:55 AM.

  6. #6
    Join Date
    Nov 2012
    Beans
    6

    Re: mythlogserver 100% cpu

    Quote Originally Posted by Hidyman View Post
    I kept getting an error about it expecting an integer, so I modified it.
    I hope this works.

    Code:
    #!/bin/bash
    mythlogload=`top -b -n1 |grep mythlogserver |head -n1 |awk -F' ' '{ print $9 }'`
    mythlogload=$( printf "%.0f" $mythlogload)
    
    if [ $mythlogload -gt 80 ]; then
         kill `pidof mythlogserver`
         echo "Killed mythlogserver"
    fi
    Somehow I typed 80 instead of 40 should be:

    Code:
    #!/bin/bash
    mythlogload=`top -b -n1 |grep mythlogserver |head -n1 |awk -F' ' '{ print $9 }'`
    mythlogload=$( printf "%.0f" $mythlogload)
    
    if [ $mythlogload -gt 40 ]; then
         kill `pidof mythlogserver`
         echo "Killed mythlogserver"
    fi
    I foud this out because myhtlogserver was hovering at 70 so it never flagged the script to kill it.
    Just wanted to update in case someone else is having this problem.

    I have experienced a new problem though, once in a while I'll have about 20 mythlogserver instances running, each using %4 or so.
    I'm about to research and see if I can remove logging altogether.

  7. #7
    Join Date
    Aug 2006
    Beans
    Hidden!

    Re: mythlogserver 100% cpu

    Please keep us posted Hidyman. I've been trying things like crazy for the last week and can't solve this problem. It causes serious problems on my (admittedly under-powered system). Commercial flagging is at <2fps for instance.

    So far I've tried setting --nodblog and setting --loglevel err
    These two seem to reduce the frequency of the problem, but it still happens within an hour. Note: I haven't actually timed it, so it could be placebo effect here.

    I've also tried switching to the syslog-ng for the logging backend (--syslog local7). This did not help at all.



    *EDIT:
    So, I just removed the mythlogserver executable. So far I haven't noticed any problems (other then the fact that myth is no longer logging anything, but what's the point of logging if it causes my system to cease functioning?).

    I'll update if I notice any complications.
    Last edited by luciferin; February 13th, 2013 at 06:15 AM.

  8. #8
    Join Date
    May 2006
    Beans
    Hidden!
    Distro
    Kubuntu 13.04 Raring Ringtail

    Re: mythlogserver 100% cpu

    Shame their doesn't seem to be much interest from the devs to sort this problem.

  9. #9
    Join Date
    Nov 2012
    Beans
    6

    Re: mythlogserver 100% cpu

    Quote Originally Posted by luciferin View Post
    Please keep us posted Hidyman. I've been trying things like crazy for the last week and can't solve this problem. It causes serious problems on my (admittedly under-powered system). Commercial flagging is at <2fps for instance.

    So far I've tried setting --nodblog and setting --loglevel err
    These two seem to reduce the frequency of the problem, but it still happens within an hour. Note: I haven't actually timed it, so it could be placebo effect here.

    I've also tried switching to the syslog-ng for the logging backend (--syslog local7). This did not help at all.



    *EDIT:
    So, I just removed the mythlogserver executable. So far I haven't noticed any problems (other then the fact that myth is no longer logging anything, but what's the point of logging if it causes my system to cease functioning?).

    I'll update if I notice any complications.
    Thanks for the info.

    Instead of deleting the file i used chmod -x to make it unable to execute.

    For other people having this problem, it is located in /usr/bin
    Go to /usr/bin and sudo chmod -x mythlogserver
    I haven't found any problems in doing this yet.
    An update could reset the file permissions. I'll keep an eye out for that.

    I wish the developers would make this an option that we can control in setup.
    I understand the need for logging, but if the logging itself is causing the problem then something is wrong.
    If my setup is working as expected, I should be able to turn logging off altogether.

    A disclaimer: I'm a real newbie when it comes to Linux so if I'm doing something dumb, please let me know.

    I'll update if anything changes.

  10. #10
    Join Date
    Nov 2006
    Location
    Oregon
    Beans
    4,360
    Distro
    Ubuntu Development Release

    Re: mythlogserver 100% cpu

    Quote Originally Posted by deadite66 View Post
    Shame their doesn't seem to be much interest from the devs to sort this problem.
    Is there a bug report?
    *Don't PM me directly for support, open a new thread
    *Looking for a MythTV quick start guide?

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •