Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 36

Thread: Quantal (12.10) PHP 5.4 downgrade to 5.3

  1. #21
    Join Date
    Nov 2012
    Beans
    1

    Wink Re: Quantal (12.10) PHP 5.4 downgrade to 5.3

    Thank's ... excelent script ...

  2. #22
    Join Date
    Feb 2007
    Beans
    9

    Re: Quantal (12.10) PHP 5.4 downgrade to 5.3

    Thanks a million ! You are a lifesaver !!!!!

  3. #23
    Join Date
    Jan 2013
    Beans
    1

    Re: Quantal (12.10) PHP 5.4 downgrade to 5.3

    Thanks! Just upgraded to Ubuntu 12.10, my phprecipedb stopped working. Figured out that it was PHP, did a google search and BAM! Running the script now, we will see what happens.

    Also just joined the forum. I will be investigating a lot here.

  4. #24
    Join Date
    Jan 2013
    Beans
    1

    Re: Quantal (12.10) PHP 5.4 downgrade to 5.3

    Ah, thank you! That's extremely helpful.

    Panels for Drupal 6 doesn't work well with PHP 5.4, and this has solved my problem.

  5. #25
    Join Date
    Jan 2013
    Beans
    1

    Re: Quantal (12.10) PHP 5.4 downgrade to 5.3

    Thank you very much. Worked well. PHP 5.3 is still recommended for Drupal 6 and 7.

    Does it also prevent PHP from being upgraded automatically by the update manager?

  6. #26
    Join Date
    Dec 2007
    Beans
    27

    Re: Quantal (12.10) PHP 5.4 downgrade to 5.3

    i did the downgrade, turns out it made my problems worse.

    now i can't php back up again. huge problem.

    Code:
    vm@vmserver:~$ sudo apt-get install php5 -f
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     php5 : Depends: libapache2-mod-php5 (>= 5.4.6-1ubuntu1.1) but 5.3.10-1ubuntu3 is to be installed or
                     libapache2-mod-php5filter (>= 5.4.6-1ubuntu1.1) but it is not going to be installed or
                     php5-cgi (>= 5.4.6-1ubuntu1.1) but it is not going to be installed or
                     php5-fpm (>= 5.4.6-1ubuntu1.1) but it is not going to be installed
            Depends: php5-common (>= 5.4.6-1ubuntu1.1) but 5.3.10-1ubuntu3 is to be installed
    E: Unable to correct problems, you have held broken packages.
    vm@vmserver:~$

  7. #27
    Join Date
    Feb 2013
    Beans
    2

    Re: Quantal (12.10) PHP 5.4 downgrade to 5.3

    How to install PHP 5.3.20?

  8. #28
    Join Date
    May 2009
    Beans
    3

    Re: Quantal (12.10) PHP 5.4 downgrade to 5.3

    Thank you all.

    Some packages give Depends problem:

    apt-get install php5-curl
    ..............
    ..............
    The following packages have unmet dependencies:
    php5-curl : Depends: phpapi-20100525
    Depends: php5-common (= 5.4.6-1ubuntu1.1) but 5.3.10-1ubuntu3 is to be installed
    E: Unable to correct problems, you have held broken packages.


    Just to note first of all to check is it they exist in /etc/apt/preferences.d/php5_3 file ...

    in my case i just add follow

    Package: php5-curl
    Pin: release a=precise
    Pin-Priority: 991

    Then:
    #apt-get update
    #apt-get install php5-curl

    and work fine. It could help and for other PHP 5.3 packages

  9. #29
    Join Date
    Mar 2013
    Beans
    1

    Re: Quantal (12.10) PHP 5.4 downgrade to 5.3

    Thank you for this script! It saved me a ton of time.

    After the script finished, apache2 failed to restart, showing me "apache2ctl: command not found." I was able to resolve this by reinstalling apache2:

    $ sudo apt-get install apache2

  10. #30
    Join Date
    Mar 2013
    Beans
    2

    Re: Quantal (12.10) PHP 5.4 downgrade to 5.3

    Thank you for the script, it worked. However, When I tried to install other packages like GD, I got the following error:


    Code:
    The following packages have unmet dependencies:
     php5-gd : Depends: phpapi-20100525
               Depends: php5-common (= 5.4.6-1ubuntu1.2) but 5.3.10-1ubuntu3 is to be installed
    E: Unable to correct problems, you have held broken packages.
    Below post from "foxy202" helped me to fix the issue to install php5-gd.

    Quote Originally Posted by foxy202 View Post
    Thank you all.

    Some packages give Depends problem:

    apt-get install php5-curl
    ..............
    ..............
    The following packages have unmet dependencies:
    php5-curl : Depends: phpapi-20100525
    Depends: php5-common (= 5.4.6-1ubuntu1.1) but 5.3.10-1ubuntu3 is to be installed
    E: Unable to correct problems, you have held broken packages.


    Just to note first of all to check is it they exist in /etc/apt/preferences.d/php5_3 file ...

    in my case i just add follow

    Package: php5-curl
    Pin: release a=precise
    Pin-Priority: 991

    Then:
    #apt-get update
    #apt-get install php5-curl

    and work fine. It could help and for other PHP 5.3 packages

Page 3 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •