Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 29

Thread: Select desktop environment not working - Ubuntu 12.10

  1. #11
    Join Date
    Aug 2012
    Location
    Dallas, Texas
    Beans
    Hidden!
    Distro
    Ubuntu Studio 12.10 Quantal Quetzal

    Re: Select desktop environment not working - Ubuntu 12.10

    Quote Originally Posted by Canaryguy View Post
    Well, I found out what the problem was. It sounds really stupid hahaha.

    Well, I had installed different desktop environments so when I logged out to use one of them I saw the list but I couldn't see the OK button because my screen is not big enough (I'm using a netbook). I thought I had just to click on the desired desktop enviroment but, as Nick Payne said, you also have to click on the OK button (which it was not displayed).

    Well mystery solved.

    Thank you guys for your help.
    Thought I had said that
    But glad you got it working!

  2. #12
    Join Date
    Jan 2009
    Beans
    1

    Re: Select desktop environment not working - Ubuntu 12.10

    Hi
    Where is that ok button supposed to be?
    I can not see it

  3. #13
    Join Date
    Mar 2009
    Location
    Canary Islands, Spain
    Beans
    116
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Select desktop environment not working - Ubuntu 12.10

    Quote Originally Posted by Miles_T View Post
    Hi
    Where is that ok button supposed to be?
    I can not see it
    When you install another desktop environment like Gnome Shell once you log out you click on the Ubuntu logo and then you see the list of options to change to Gnome Shell. The last option from the list is the OK button to confirm your option. This is happening in Ubuntu 12.10. In previous versions of Ubuntu you just needed to click on the the desired Desktop environment without confirming it with the OK button.

  4. #14
    Join Date
    May 2008
    Location
    /dev/null
    Beans
    216
    Distro
    Ubuntu

    Re: Select desktop environment not working - Ubuntu 12.10

    how can I get on ok button if it is not visible on display ?

  5. #15
    Join Date
    Mar 2009
    Location
    Canary Islands, Spain
    Beans
    116
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Select desktop environment not working - Ubuntu 12.10

    Quote Originally Posted by masuch View Post
    how can I get on ok button if it is not visible on display ?
    Did you installed different desktops? I did and when I was going to choose one of them I couldn't see the OK button because there were too many options.

    You can use the tab key to move through the options and Enter to select it.

  6. #16
    Join Date
    May 2008
    Location
    /dev/null
    Beans
    216
    Distro
    Ubuntu

    Re: Select desktop environment not working - Ubuntu 12.10

    Quote Originally Posted by Canaryguy View Post
    Did you installed different desktops? I did and when I was going to choose one of them I couldn't see the OK button because there were too many options.

    You can use the tab key to move through the options and Enter to select it.
    Yes, I have read that I have to click on OK button otherwise it is not going to switch to that desktop - some new stuff in 12.10 against 12.04 . did not try ? Why ?
    Because the bigger problem for me is if I do it how can I switch back to xfce desktop if it is not visible on display !?
    if it is possible to switching between default environment from terminal before to get on login screen I would much appreciate if you can share those information - in such case I would be afraid of not to get back to my xfce desktop which is only desktop mainly used by me.

  7. #17
    Join Date
    Mar 2009
    Location
    Canary Islands, Spain
    Beans
    116
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Select desktop environment not working - Ubuntu 12.10

    Quote Originally Posted by masuch View Post
    Yes, I have read that I have to click on OK button otherwise it is not going to switch to that desktop - some new stuff in 12.10 against 12.04 . did not try ? Why ?
    Because the bigger problem for me is if I do it how can I switch back to xfce desktop if it is not visible on display !?
    if it is possible to switching between default environment from terminal before to get on login screen I would much appreciate if you can share those information - in such case I would be afraid of not to get back to my xfce desktop which is only desktop mainly used by me.
    I'm not sure but maybe this thread can be of help.

    http://ubuntuforums.org/showthread.php?t=940287

  8. #18
    Join Date
    May 2008
    Location
    /dev/null
    Beans
    216
    Distro
    Ubuntu

    Re: Select desktop environment not working - Ubuntu 12.10

    Quote Originally Posted by Canaryguy View Post
    I'm not sure but maybe this thread can be of help.

    http://ubuntuforums.org/showthread.php?t=940287
    Hi,

    Thanks , it solved problem how to setup default display manager from command line "/etc/X11/default-display-manager". That is good to know as well, thanks for tip.
    What I am looking for is how to setup default desktop environment. I have a list of desktop environments - I believe it has to be stored somewhere. And somewhere has to setup default desktop environment.

  9. #19
    Join Date
    Jun 2010
    Location
    London, England
    Beans
    6,686
    Distro
    Ubuntu Development Release

    Re: Select desktop environment not working - Ubuntu 12.10

    The last used desktop environment becomes the default environment automatically.

    Go to file system /etc/lightdm/lightdm.conf and you will see what the user-session and what the greeter-session are listed as.

    This is what controls the default session (I think) but it is re-written when we select a different user session at login.

    Regards.
    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530


  10. #20
    Join Date
    May 2008
    Location
    /dev/null
    Beans
    216
    Distro
    Ubuntu

    Question Re: Select desktop environment not working - Ubuntu 12.10

    Quote Originally Posted by grahammechanical View Post
    The last used desktop environment becomes the default environment automatically.

    Go to file system /etc/lightdm/lightdm.conf and you will see what the user-session and what the greeter-session are listed as.

    This is what controls the default session (I think) but it is re-written when we select a different user session at login.

    Regards.
    There is:
    [SeatDefaults]
    greeter-session=unity-greeter
    user-session=ubuntu

    how can I setup default xfce dektop environment within login screen ? It is not there even if I am using it. it has to be somewhere else.

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •