Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 36

Thread: mount error: could not resolve address for Diskstation: Unknown error

  1. #11
    Join Date
    Jan 2010
    Beans
    22

    Re: mount error: could not resolve address for Diskstation: Unknown error

    Hi bab1,

    I did the test as you described, and I could contact my NAS. This is the result:
    Code:
    alfons@alfons-laptop:~$ sudo mount -t cifs //diskstation/home /mnt/samba
    Password: 
    mount error(13): Permission denied
    I still have to find out the account details as you can see, but that shouldn't be a problem. So I need to setup a DNS in my network?

    Thanks,

    Alfons

  2. #12
    Join Date
    May 2008
    Location
    SoCal
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: mount error: could not resolve address for Diskstation: Unknown error

    Quote Originally Posted by ffonz View Post
    Hi bab1,

    I did the test as you described, and I could contact my NAS. This is the result:
    Code:
    alfons@alfons-laptop:~$ sudo mount -t cifs //diskstation/home /mnt/samba
    Password: 
    mount error(13): Permission denied
    it does appear that the there is no LAN DNS running (on your local network). But you now know how to cure that.

    I still have to find out the account details as you can see, but that shouldn't be a problem.
    Do you have a way to configure your Diskstation's users. If this is just for you you might just allow everyone.
    So I need to setup a DNS in my network?

    Thanks,

    Alfons
    That's really a question only you can answer. Technically no. As you can see you can manually just add a mapping in all the /etc/hosts files of all your machines. It becomes a problem when you have a lot of machines to add the mapping to. With DNS you just add the mapping in one file on one system and it is available for all machines. You might look into DNSmasq for a small network DNS.
    -BAB1

  3. #13
    Join Date
    Jan 2010
    Beans
    22

    Re: mount error: could not resolve address for Diskstation: Unknown error

    Thanks bab1 for the information.

    I know now how to figure it out.

    Alfons

  4. #14
    Join Date
    Jul 2011
    Beans
    14

    Re: mount error: could not resolve address for Diskstation: Unknown error

    Hello,

    I have exactly this same problem. However, I do find it hard to believe that I must have a local DNS server OR that I edit the /etc/hosts file in order to make it work. It just sounds way too primitive, manual and cumbersome. Besides, the machines I want to mount are laptops or other computers with dynamic IP addresses. So having a thing that converts names to static IP addresses is not really a solution.

    Is there not really a way of mounting a server using the server's name other than by setting up a local DNS server? It really sounds too odd as smbtree, smbclient and nmblookup can clearly see the server via its name without employing DNS server of any kind. Surely this should be able to happen when mounting the server. Basically what I'm saying is that if there's NETBIOS resolution, then the mounting process should be able to work with that NETBIOS resolution.

  5. #15
    Join Date
    May 2008
    Location
    SoCal
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: mount error: could not resolve address for Diskstation: Unknown error

    Quote Originally Posted by MonoAM View Post
    Hello,

    I have exactly this same problem. However, I do find it hard to believe that I must have a local DNS server OR that I edit the /etc/hosts file in order to make it work. It just sounds way too primitive, manual and cumbersome. Besides, the machines I want to mount are laptops or other computers with dynamic IP addresses. So having a thing that converts names to static IP addresses is not really a solution.
    I'll bet you don't have the exact same problem, but rather the same symptoms. All IP traffic that has a destination that is identified with a human readable name (i.e. destination, DESTINATION, etc.) must first be resolved to an IP address. This is can be achived either by IP to hostname (FQDN) with DNS or its primative, hostnames, via /etc/hosts or by NETBIOS name to IP address with a WINS server or by broadcasting NETBIOS names. In simple terms a chart would look like this
    Code:
    IP to FQND (hostname) = DNS (hostname.domain.tld) 
    IP to hostname = hosts via /etc/hosts (hostname)
    
    NETBIOS name to IP address = WINS (NETBIOS name)
    NETBIOS NAME TO IP address = broadcasts
    Whether it's primitive or not is irrelevent. It is what it is. No one said that DNS names can't be resolved. Most modern DNS iplimentations can do this. This can be done by NETBIOS. In fact resolving the NETBIOS name to a IP address was the original intention. A dynamic address is not a problem as the NAME is mapped to whatever IP address the host is using.
    Is there not really a way of mounting a server using the server's name other than by setting up a local DNS server? It really sounds too odd as smbtree, smbclient and nmblookup can clearly see the server via its name without employing DNS server of any kind. Surely this should be able to happen when mounting the server. Basically what I'm saying is that if there's NETBIOS resolution, then the mounting process should be able to work with that NETBIOS resolution.
    It's more a matter of how the NETBIOS resolution is handled and whether you have control of the host that is resolving the NETBIOS names. The OP was not in control of the NAS unit. The most simple method for him was to resolve the IP address to that specific host via the /etc/hosts entry on his local host. If you want to browse Samba shares then the hostname (or FQDN) must be resolved to the NETBIOS name. ALL browisng is via NETBIOS names. This is handled by the Samba daemon NMBD. In that sense you are correct as the resolution is somewhat convoluted. You can think of it as this
    Code:
    hostname to NETBIOS name to IP address
    ...that's really simplistic but it is basically right.

    If you want to have dynamic IP addressing and use NETBIOS to resolve the COMPUTER name for Samba browsing see here.

    Read ALL of it before doing anything. Ask questions if you don't understand.
    -BAB1

  6. #16
    Join Date
    Jul 2011
    Beans
    14

    Re: mount error: could not resolve address for Diskstation: Unknown error

    Hi bab1,

    Thanks for your help. Now I think I understand a little bit better how this works. I read the other thread you pointed to and yes, it looks like my problem is more similar to the one described in that thread. So, I followed the whole thread but it still doesn't work. The conclusion of that thread was that there was a problem in the (windows) client machine configuration that couldn't connect to the (ubuntu) samba server machine. Well, it looks like I might have the same problem, except that in my case both machines are Ubuntu.

    So, I have one server machine (which is just a laptop with a shared drive) on which I've made all the changes suggested in the tread you pointed me to, namely:

    Code:
    netbios name = COMPUTER_NAME
    # What naming service and in what order should we use to resolve host names
    # to IP addresses
    name resolve order = bcast
    I made the same changes in the client computer (obviously the client's name), but without any success in mounting the servers' drive on the client machine.

    Another question, how do you reload the smbd daemon as everytime I make a change I have to reboot the machine?

    Thanks a lot in advance for your help!!!

    A

  7. #17
    Join Date
    May 2008
    Location
    SoCal
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: mount error: could not resolve address for Diskstation: Unknown error

    Quote Originally Posted by MonoAM View Post
    Hi bab1,

    Thanks for your help. Now I think I understand a little bit better how this works. I read the other thread you pointed to and yes, it looks like my problem is more similar to the one described in that thread. So, I followed the whole thread but it still doesn't work. The conclusion of that thread was that there was a problem in the (windows) client machine configuration that couldn't connect to the (ubuntu) samba server machine. Well, it looks like I might have the same problem, except that in my case both machines are Ubuntu.
    Maybe, maybe not. I would say you need to diagose the problem rather than jumping to conclusions based on symptoms.

    So, I have one server machine (which is just a laptop with a shared drive) on which I've made all the changes suggested in the tread you pointed me to, namely:

    Code:
    netbios name = COMPUTER_NAME
    # What naming service and in what order should we use to resolve host names
    # to IP addresses
    name resolve order = bcast
    I made the same changes in the client computer (obviously the client's name), but without any success in mounting the servers' drive on the client machine.
    What failed? What error messages did you have? I suggest diagnosing one machine at a time.

    Another question, how do you reload the smbd daemon as everytime I make a change I have to reboot the machine?
    Everytime you reconfigure the smb.conf file you need to reload the smbd daemon.

    Let's work only with the Samba server. What is the output of this
    Code:
    smbtree -d3
    What is the output of this
    Code:
    cat /etc/samba/smb.conf
    -BAB1

  8. #18
    Join Date
    Jul 2011
    Beans
    14

    Re: mount error: could not resolve address for Diskstation: Unknown error

    Hi,

    Quote Originally Posted by bab1 View Post
    What failed? What error messages did you have?
    So this is the command I run and the error I get:
    Code:
    sudo mount -t cifs //PHOENIX/hitachi /media/phoenix
    mount error: could not resolve address for PHOENIX: Unknown error
    PHOENIX is the samba server.

    Outputs:
    Code:
    smbtree -d3
    Code:
    lp_load_ex: refreshing parameters
    Initialising global parameters
    rlimit_max: rlimit_max (1024) below minimum Windows limit (16384)
    params.c:pm_process() - Processing configuration file "/etc/samba/smb.conf"
    Processing section "[global]"
    added interface eth0 ip=fe80::211:43ff:fe4b:d6ec%eth0 bcast=fe80::ffff:ffff:ffff:ffff%eth0 netmask=ffff:ffff:ffff:ffff::
    added interface eth1 ip=fe80::212:f0ff:fe02:47bd%eth1 bcast=fe80::ffff:ffff:ffff:ffff%eth1 netmask=ffff:ffff:ffff:ffff::
    added interface eth1 ip=192.168.1.5 bcast=192.168.1.63 netmask=255.255.255.192
    added interface eth0 ip=192.168.1.15 bcast=192.168.1.63 netmask=255.255.255.192
    Enter amguerra's password: 
    tdb(unnamed): tdb_open_ex: could not open file /var/run/samba/gencache.tdb: Permission denied
    name_resolve_bcast: Attempting broadcast lookup for name WORKGROUP<0x1d>
    Got a positive name query response from 192.168.1.5 ( 192.168.1.15 )
    tdb(unnamed): tdb_open_ex: could not open file /var/run/samba/unexpected.tdb: No such file or directory
    tdb(unnamed): tdb_open_ex: could not open file /var/run/samba/unexpected.tdb: No such file or directory
    tdb(unnamed): tdb_open_ex: could not open file /var/run/samba/unexpected.tdb: No such file or directory
    Connecting to host=192.168.1.15
    Connecting to 192.168.1.15 at port 445
    Doing spnego session setup (blob length=58)
    got OID=1.3.6.1.4.1.311.2.2.10
    got principal=NONE
    Got challenge flags:
    Got NTLMSSP neg_flags=0x608a8215
    NTLMSSP: Set final flags:
    Got NTLMSSP neg_flags=0x60088215
    NTLMSSP Sign/Seal - Initialising with flags:
    Got NTLMSSP neg_flags=0x60088215
    name_resolve_bcast: Attempting broadcast lookup for name __MSBROWSE__<0x1>
    Got a positive name query response from 192.168.1.5 ( 192.168.1.15 )
    tdb(unnamed): tdb_open_ex: could not open file /var/run/samba/unexpected.tdb: No such file or directory
    tdb(unnamed): tdb_open_ex: could not open file /var/run/samba/unexpected.tdb: No such file or directory
    tdb(unnamed): tdb_open_ex: could not open file /var/run/samba/unexpected.tdb: No such file or directory
    name_resolve_bcast: Attempting broadcast lookup for name WORKGROUP<0x1d>
    Got a positive name query response from 192.168.1.5 ( 192.168.1.15 )
    tdb(unnamed): tdb_open_ex: could not open file /var/run/samba/unexpected.tdb: No such file or directory
    tdb(unnamed): tdb_open_ex: could not open file /var/run/samba/unexpected.tdb: No such file or directory
    tdb(unnamed): tdb_open_ex: could not open file /var/run/samba/unexpected.tdb: No such file or directory
    Connecting to host=192.168.1.15
    Connecting to 192.168.1.15 at port 445
    Doing spnego session setup (blob length=58)
    got OID=1.3.6.1.4.1.311.2.2.10
    got principal=NONE
    Got challenge flags:
    Got NTLMSSP neg_flags=0x608a8215
    NTLMSSP: Set final flags:
    Got NTLMSSP neg_flags=0x60088215
    NTLMSSP Sign/Seal - Initialising with flags:
    Got NTLMSSP neg_flags=0x60088215
    WORKGROUP
    name_resolve_bcast: Attempting broadcast lookup for name WORKGROUP<0x1d>
    Got a positive name query response from 192.168.1.5 ( 192.168.1.15 )
    tdb(unnamed): tdb_open_ex: could not open file /var/run/samba/unexpected.tdb: No such file or directory
    tdb(unnamed): tdb_open_ex: could not open file /var/run/samba/unexpected.tdb: No such file or directory
    tdb(unnamed): tdb_open_ex: could not open file /var/run/samba/unexpected.tdb: No such file or directory
    Connecting to host=192.168.1.15
    Connecting to 192.168.1.15 at port 445
    Doing spnego session setup (blob length=58)
    got OID=1.3.6.1.4.1.311.2.2.10
    got principal=NONE
    Got challenge flags:
    Got NTLMSSP neg_flags=0x608a8215
    NTLMSSP: Set final flags:
    Got NTLMSSP neg_flags=0x60088215
    NTLMSSP Sign/Seal - Initialising with flags:
    Got NTLMSSP neg_flags=0x60088215
    	\\PHOENIX        		phoenix server (Samba, Ubuntu)
    Connecting to host=PHOENIX
    name_resolve_bcast: Attempting broadcast lookup for name PHOENIX<0x20>
    Got a positive name query response from 192.168.1.5 ( 192.168.1.15 )
    tdb(unnamed): tdb_open_ex: could not open file /var/run/samba/unexpected.tdb: No such file or directory
    tdb(unnamed): tdb_open_ex: could not open file /var/run/samba/unexpected.tdb: No such file or directory
    tdb(unnamed): tdb_open_ex: could not open file /var/run/samba/unexpected.tdb: No such file or directory
    Connecting to 192.168.1.15 at port 445
    Doing spnego session setup (blob length=58)
    got OID=1.3.6.1.4.1.311.2.2.10
    got principal=NONE
    Got challenge flags:
    Got NTLMSSP neg_flags=0x608a8215
    NTLMSSP: Set final flags:
    Got NTLMSSP neg_flags=0x60088215
    NTLMSSP Sign/Seal - Initialising with flags:
    Got NTLMSSP neg_flags=0x60088215
    		\\PHOENIX\amguerra       	Home Directories
    		\\PHOENIX\IPC$           	IPC Service (phoenix server (Samba, Ubuntu))
    		\\PHOENIX\print$         	Printer Drivers
    		\\PHOENIX\hitachi        	Hitachi external hard drive
    		\\PHOENIX\homes          	Home Directories
    Code:
    cat /etc/samba/smb.conf
    Code:
    #
    # Sample configuration file for the Samba suite for Debian GNU/Linux.
    #
    #
    # This is the main Samba configuration file. You should read the
    # smb.conf(5) manual page in order to understand the options listed
    # here. Samba has a huge number of configurable options most of which 
    # are not shown in this example
    #
    # Some options that are often worth tuning have been included as
    # commented-out examples in this file.
    #  - When such options are commented with ";", the proposed setting
    #    differs from the default Samba behaviour
    #  - When commented with "#", the proposed setting is the default
    #    behaviour of Samba but the option is considered important
    #    enough to be mentioned here
    #
    # NOTE: Whenever you modify this file you should run the command
    # "testparm" to check that you have not made any basic syntactic 
    # errors. 
    # A well-established practice is to name the original file
    # "smb.conf.master" and create the "real" config file with
    # testparm -s smb.conf.master >smb.conf
    # This minimizes the size of the really used smb.conf file
    # which, according to the Samba Team, impacts performance
    # However, use this with caution if your smb.conf file contains nested
    # "include" statements. See Debian bug #483187 for a case
    # where using a master file is not a good idea.
    #
    
    #======================= Global Settings =======================
    
    [global]
    
    ## Browsing/Identification ###
    
    # Change this to the workgroup/NT-domain name your Samba server will part of
       workgroup = WORKGROUP
    
    # server string is the equivalent of the NT Description field
       server string = %h server (Samba, Ubuntu)
    
    # Windows Internet Name Serving Support Section:
    # WINS Support - Tells the NMBD component of Samba to enable its WINS Server
    #   wins support = no
    
    # WINS Server - Tells the NMBD components of Samba to be a WINS Client
    # Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
    ;   wins server = w.x.y.z
    
    # This will prevent nmbd to search for NetBIOS names through DNS.
       dns proxy = no
    
    netbios name = PHOENIX
    # previous line: alfredo added 13-Nov-2012
    # What naming service and in what order should we use to resolve host names
    # to IP addresses
    # OLD:   name resolve order = bcast lmhosts host wins
       name resolve order = bcast
    
    #### Networking ####
    
    # The specific set of interfaces / networks to bind to
    # This can be either the interface name or an IP address/netmask;
    # interface names are normally preferred
    ;   interfaces = 127.0.0.0/8 eth0
    
    # Only bind to the named interfaces and/or networks; you must use the
    # 'interfaces' option above to use this.
    # It is recommended that you enable this feature if your Samba machine is
    # not protected by a firewall or is a firewall itself.  However, this
    # option cannot handle dynamic or non-broadcast interfaces correctly.
    ;   bind interfaces only = yes
    
    
    
    #### Debugging/Accounting ####
    
    # This tells Samba to use a separate log file for each machine
    # that connects
       log file = /var/log/samba/log.%m
    
    # Cap the size of the individual log files (in KiB).
       max log size = 1000
    
    # If you want Samba to only log through syslog then set the following
    # parameter to 'yes'.
    #   syslog only = no
    
    # We want Samba to log a minimum amount of information to syslog. Everything
    # should go to /var/log/samba/log.{smbd,nmbd} instead. If you want to log
    # through syslog you should set the following parameter to something higher.
       syslog = 0
    
    # Do something sensible when Samba crashes: mail the admin a backtrace
       panic action = /usr/share/samba/panic-action %d
    
    
    ####### Authentication #######
    
    # "security = user" is always a good idea. This will require a Unix account
    # in this server for every user accessing the server. See
    # /usr/share/doc/samba-doc/htmldocs/Samba3-HOWTO/ServerType.html
    # in the samba-doc package for details.
    
    security = user
    username map = /e/samba/smbusers
    
    # You may wish to use password encryption.  See the section on
    # 'encrypt passwords' in the smb.conf(5) manpage before enabling.
       encrypt passwords = true
    
    # If you are using encrypted passwords, Samba will need to know what
    # password database type you are using.  
       passdb backend = tdbsam
    
       obey pam restrictions = yes
    
    # This boolean parameter controls whether Samba attempts to sync the Unix
    # password with the SMB password when the encrypted SMB password in the
    # passdb is changed.
       unix password sync = yes
    
    # For Unix password sync to work on a Debian GNU/Linux system, the following
    # parameters must be set (thanks to Ian Kahan <<kahan@informatik.tu-muenchen.de> for
    # sending the correct chat script for the passwd program in Debian Sarge).
       passwd program = /usr/bin/passwd %u
       passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
    
    # This boolean controls whether PAM will be used for password changes
    # when requested by an SMB client instead of the program listed in
    # 'passwd program'. The default is 'no'.
       pam password change = yes
    
    # This option controls how unsuccessful authentication attempts are mapped 
    # to anonymous connections
       map to guest = bad user
    
    ########## Domains ###########
    
    # Is this machine able to authenticate users. Both PDC and BDC
    # must have this setting enabled. If you are the BDC you must
    # change the 'domain master' setting to no
    #
    ;   domain logons = yes
    #
    # The following setting only takes effect if 'domain logons' is set
    # It specifies the location of the user's profile directory
    # from the client point of view)
    # The following required a [profiles] share to be setup on the
    # samba server (see below)
    ;   logon path = \\%N\profiles\%U
    # Another common choice is storing the profile in the user's home directory
    # (this is Samba's default)
    #   logon path = \\%N\%U\profile
    
    # The following setting only takes effect if 'domain logons' is set
    # It specifies the location of a user's home directory (from the client
    # point of view)
    ;   logon drive = H:
    #   logon home = \\%N\%U
    
    # The following setting only takes effect if 'domain logons' is set
    # It specifies the script to run during logon. The script must be stored
    # in the [netlogon] share
    # NOTE: Must be store in 'DOS' file format convention
    ;   logon script = logon.cmd
    
    # This allows Unix users to be created on the domain controller via the SAMR
    # RPC pipe.  The example command creates a user account with a disabled Unix
    # password; please adapt to your needs
    ; add user script = /usr/sbin/adduser --quiet --disabled-password --gecos "" %u
    
    # This allows machine accounts to be created on the domain controller via the 
    # SAMR RPC pipe.  
    # The following assumes a "machines" group exists on the system
    ; add machine script  = /usr/sbin/useradd -g machines -c "%u machine account" -d /var/lib/samba -s /bin/false %u
    
    # This allows Unix groups to be created on the domain controller via the SAMR
    # RPC pipe.  
    ; add group script = /usr/sbin/addgroup --force-badname %g
    
    ########## Printing ##########
    
    # If you want to automatically load your printer list rather
    # than setting them up individually then you'll need this
    #   load printers = yes
    
    # lpr(ng) printing. You may wish to override the location of the
    # printcap file
    ;   printing = bsd
    ;   printcap name = /etc/printcap
    
    # CUPS printing.  See also the cupsaddsmb(8) manpage in the
    # cupsys-client package.
    ;   printing = cups
    ;   printcap name = cups
    
    ############ Misc ############
    
    # Using the following line enables you to customise your configuration
    # on a per machine basis. The %m gets replaced with the netbios name
    # of the machine that is connecting
    ;   include = /home/samba/etc/smb.conf.%m
    
    # Most people will find that this option gives better performance.
    # See smb.conf(5) and /usr/share/doc/samba-doc/htmldocs/Samba3-HOWTO/speed.html
    # for details
    # You may want to add the following on a Linux system:
    #         SO_RCVBUF=8192 SO_SNDBUF=8192
    #   socket options = TCP_NODELAY
    
    # The following parameter is useful only if you have the linpopup package
    # installed. The samba maintainer and the linpopup maintainer are
    # working to ease installation and configuration of linpopup and samba.
    ;   message command = /bin/sh -c '/usr/bin/linpopup "%f" "%m" %s; rm %s' &
    
    # Domain Master specifies Samba to be the Domain Master Browser. If this
    # machine will be configured as a BDC (a secondary logon server), you
    # must set this to 'no'; otherwise, the default behavior is recommended.
    #   domain master = auto
    
    # Some defaults for winbind (make sure you're not using the ranges
    # for something else.)
    ;   idmap uid = 10000-20000
    ;   idmap gid = 10000-20000
    ;   template shell = /bin/bash
    
    # The following was the default behaviour in sarge,
    # but samba upstream reverted the default because it might induce
    # performance issues in large organizations.
    # See Debian bug #368251 for some of the consequences of *not*
    # having this setting and smb.conf(5) for details.
    ;   winbind enum groups = yes
    ;   winbind enum users = yes
    
    # Setup usershare options to enable non-root users to share folders
    # with the net usershare command.
    
    # Maximum number of usershare. 0 (default) means that usershare is disabled.
    ;   usershare max shares = 100
    
    # Allow users who've been granted usershare privileges to create
    # public shares, not just authenticated ones
       usershare allow guests = yes
    
    #======================= Share Definitions =======================
    
    # Un-comment the following (and tweak the other settings below to suit)
    # to enable the default home directory shares.  This will share each
    # user's home directory as \\server\username
    [homes]
       comment = Home Directories
       browseable = yes
       writeable = Yes
       valid users = amguerra
    
    [hitachi]
      comment = Hitachi external hard drive
      browseable = yes
      path = /media/HITACHI
      writeable = Yes
      valid users = amguerra
    
    # By default, the home directories are exported read-only. Change the
    # next parameter to 'no' if you want to be able to write to them.
    ;   read only = yes
    
    # File creation mask is set to 0700 for security reasons. If you want to
    # create files with group=rw permissions, set next parameter to 0775.
    ;   create mask = 0700
    
    # Directory creation mask is set to 0700 for security reasons. If you want to
    # create dirs. with group=rw permissions, set next parameter to 0775.
    ;   directory mask = 0700
    
    # By default, \\server\username shares can be connected to by anyone
    # with access to the samba server.  Un-comment the following parameter
    # to make sure that only "username" can connect to \\server\username
    # This might need tweaking when using external authentication schemes
    ;   valid users = %S
    
    # Un-comment the following and create the netlogon directory for Domain Logons
    # (you need to configure Samba to act as a domain controller too.)
    ;[netlogon]
    ;   comment = Network Logon Service
    ;   path = /home/samba/netlogon
    ;   guest ok = yes
    ;   read only = yes
    ;   share modes = no
    
    # Un-comment the following and create the profiles directory to store
    # users profiles (see the "logon path" option above)
    # (you need to configure Samba to act as a domain controller too.)
    # The path below should be writable by all users so that their
    # profile directory may be created the first time they log on
    ;[profiles]
    ;   comment = Users profiles
    ;   path = /home/samba/profiles
    ;   guest ok = no
    ;   browseable = no
    ;   create mask = 0600
    ;   directory mask = 0700
    
    [printers]
       comment = All Printers
       browseable = no
       path = /var/spool/samba
       printable = yes
       guest ok = no
       read only = yes
       create mask = 0700
    
    # Windows clients look for this share name as a source of downloadable
    # printer drivers
    [print$]
       comment = Printer Drivers
       path = /var/lib/samba/printers
       browseable = yes
       read only = yes
       guest ok = no
    # Uncomment to allow remote administration of Windows print drivers.
    # You may need to replace 'lpadmin' with the name of the group your
    # admin users are members of.
    # Please note that you also need to set appropriate Unix permissions
    # to the drivers directory for these users to have write rights in it
    ;   write list = root, @lpadmin
    
    # A sample share for sharing your CD-ROM with others.
    ;[cdrom]
    ;   comment = Samba server's CD-ROM
    ;   read only = yes
    ;   locking = no
    ;   path = /cdrom
    ;   guest ok = yes
    
    # The next two parameters show how to auto-mount a CD-ROM when the
    #	cdrom share is accesed. For this to work /etc/fstab must contain
    #	an entry like this:
    #
    #       /dev/scd0   /cdrom  iso9660 defaults,noauto,ro,user   0 0
    #
    # The CD-ROM gets unmounted automatically after the connection to the
    #
    # If you don't want to use auto-mounting/unmounting make sure the CD
    #	is mounted on /cdrom
    #
    ;   preexec = /bin/mount /cdrom
    ;   postexec = /bin/umount /cdrom
    Quote Originally Posted by bab1 View Post
    Everytime you reconfigure the smb.conf file you need to reload the smbd daemon.
    What's the command to do that?

  9. #19
    Join Date
    May 2008
    Location
    SoCal
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: mount error: could not resolve address for Diskstation: Unknown error

    Quote Originally Posted by MonoAM View Post
    ...this is the command I run and the error I get:
    Code:
    sudo mount -t cifs //PHOENIX/hitachi /media/phoenix
    mount error: could not resolve address for PHOENIX: Unknown error
    PHOENIX is the samba server.

    Outputs:
    Code:
    smbtree -d3
    Code:
    ...
    
    		\\PHOENIX\amguerra       	Home Directories
    		\\PHOENIX\IPC$           	IPC Service (phoenix server (Samba, Ubuntu))
    		\\PHOENIX\print$         	Printer Drivers
    		\\PHOENIX\hitachi        	Hitachi external hard drive
    		\\PHOENIX\homes          	Home Directories
    Code:
    cat /etc/samba/smb.conf
    Code:
    ...
    #======================= Share Definitions =======================
    
    # Un-comment the following (and tweak the other settings below to suit)
    # to enable the default home directory shares.  This will share each
    # user's home directory as \\server\username
    [homes]
       comment = Home Directories
       browseable = yes
       writeable = Yes
       valid users = amguerra
    
    [hitachi]
      comment = Hitachi external hard drive
      browseable = yes
      path = /media/HITACHI
      writeable = Yes
      valid users = amguerra
    
    # By default, the home directories are exported read-only. Change the
    # next parameter to 'no' if you want to be able to write to them.
    ;   read only = yes
    
    # File creation mask is set to 0700 for security reasons. If you want to
    # create files with group=rw permissions, set next parameter to 0775.
    ;   create mask = 0700
    
    # Directory creation mask is set to 0700 for security reasons. If you want to
    # create dirs. with group=rw permissions, set next parameter to 0775.
    ;   directory mask = 0700
    
    # By default, \\server\username shares can be connected to by anyone
    # with access to the samba server.  Un-comment the following parameter
    # to make sure that only "username" can connect to \\server\username
    # This might need tweaking when using external authentication schemes
    ;   valid users = %S
    
    ...


    What's the command to do that?
    The smb.conf file looks fine until we get to this
    Code:
    [homes]
       comment = Home Directories
       browseable = yes
       writeable = Yes
       valid users = amguerra
    
    [hitachi]
      comment = Hitachi external hard drive
      browseable = yes
      path = /media/HITACHI
      writeable = Yes
      valid users = amguerra
    
    # By default, the home directories are exported read-only. Change the
    # next parameter to 'no' if you want to be able to write to them.
    ;   read only = yes
    
    # File creation mask is set to 0700 for security reasons. If you want to
    # create files with group=rw permissions, set next parameter to 0775.
    ;   create mask = 0700
    
    # Directory creation mask is set to 0700 for security reasons. If you want to
    # create dirs. with group=rw permissions, set next parameter to 0775.
    ;   directory mask = 0700
    
    # By default, \\server\username shares can be connected to by anyone
    # with access to the samba server.  Un-comment the following parameter
    # to make sure that only "username" can connect to \\server\username
    # This might need tweaking when using external authentication schemes
    ;   valid users = %S
    I believe it should be this
    Code:
    [homes]
       comment = Home Directories
       browseable = yes
       writeable = Yes
       valid users = amguerra
    
    # By default, the home directories are exported read-only. Change the
    # next parameter to 'no' if you want to be able to write to them.
    ;   read only = yes
    
    # File creation mask is set to 0700 for security reasons. If you want to
    # create files with group=rw permissions, set next parameter to 0775.
    ;   create mask = 0700
    
    # Directory creation mask is set to 0700 for security reasons. If you want to
    # create dirs. with group=rw permissions, set next parameter to 0775.
    ;   directory mask = 0700
    
    # By default, \\server\username shares can be connected to by anyone
    # with access to the samba server.  Un-comment the following parameter
    # to make sure that only "username" can connect to \\server\username
    # This might need tweaking when using external authentication schemes
    ;   valid users = %S
    
    [hitachi]
      comment = Hitachi external hard drive
      browseable = yes
      path = /media/HITACHI
      writeable = Yes
      valid users = amguerra
    You will always have wierd problems when you create a share in the middle of another share. I have put the share [hitachi] at the end (in red).

    When the Samba daemon encounters a share name ([share]) it starts a new share and all the parameters are to that share until it encouters another share name definition ([share2]). Additionally you have made the [homes] share browseable. Did you mean to do that? You also made the user amguerra the only valid user for all [homes] shares. You should not do that. Read this for the correct method
    Code:
    # By default, \\server\username shares can be connected to by anyone
    # with access to the samba server.  Un-comment the following parameter
    # to make sure that only "username" can connect to \\server\username
    # This might need tweaking when using external authentication schemes
    ;   valid users = %S
    In fact, you should read all of the comments to setup the [homes] share. You can set up all users private home shares with 1 [homes] share.

    I think we should stick to diagnosing one machine at a time here. Although it appears that NETBIOS naming is working I'd like to be sure. These are the incantations to reload Samba
    Code:
    sudo service smbd restart
    sudo service nmbd restart
    From the host phoenix what do you get with these 2 commands
    Code:
    smbclient -L phoenix
    ...and
    Code:
    testparm -s
    For completeness what is the output of these 2 commands
    Code:
    hostname
    ...and
    Code:
    cat /etc/hosts
    I see that smbtree browses the network correctly. I also regularly mount a Samba share via /etc/fstab so I know that part will work once we figure out what is going on with your naming services.
    -BAB1

  10. #20
    Join Date
    Jul 2011
    Beans
    14

    Re: mount error: could not resolve address for Diskstation: Unknown error

    Quote Originally Posted by bab1 View Post
    You will always have wierd problems when you create a share in the middle of another share. I have put the share [hitachi] at the end (in red).
    I've placed the [hitachi] share at the end as indicated.

    Quote Originally Posted by bab1 View Post
    Additionally you have made the [homes] share browseable. Did you mean to do that? You also made the user amguerra the only valid user for all [homes] shares. You should not do that. Read this for the correct method
    Code:
    # By default, \\server\username shares can be connected to by anyone
    # with access to the samba server.  Un-comment the following parameter
    # to make sure that only "username" can connect to \\server\username
    # This might need tweaking when using external authentication schemes
    ;   valid users = %S
    In fact, you should read all of the comments to setup the [homes] share. You can set up all users private home shares with 1 [homes] share.
    Well, I'm the only person who uses that machine, so I just wanted to *make sure that only my username can connect to the server*. I realise this is not the best practice, but since I'm the only user I thought that would be OK.

    Here's the output to the commands you asked me to run:

    Code:
    amguerra@phoenix:~$ smbclient -L phoenix
    Enter amguerra's password: 
    Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.4.7]
    
    	Sharename       Type      Comment
    	---------       ----      -------
    	homes           Disk      Home Directories
    	hitachi         Disk      Hitachi external hard drive
    	print$          Disk      Printer Drivers
    	IPC$            IPC       IPC Service (phoenix server (Samba, Ubuntu))
    	Canon-i560      Printer   Canon i560
    	amguerra        Disk      Home Directories
    Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.4.7]
    
    	Server               Comment
    	---------            -------
    	PHOENIX              phoenix server (Samba, Ubuntu)
    
    	Workgroup            Master
    	---------            -------
    	WORKGROUP            PHOENIX

    Code:
    amguerra@phoenix:~$ testparm -s
    Load smb config files from /etc/samba/smb.conf
    rlimit_max: rlimit_max (1024) below minimum Windows limit (16384)
    Processing section "[homes]"
    Processing section "[hitachi]"
    Processing section "[printers]"
    Processing section "[print$]"
    Loaded services file OK.
    Server role: ROLE_STANDALONE
    [global]
    	server string = %h server (Samba, Ubuntu)
    	map to guest = Bad User
    	obey pam restrictions = Yes
    	pam password change = Yes
    	passwd program = /usr/bin/passwd %u
    	passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
    	username map = /e/samba/smbusers
    	unix password sync = Yes
    	syslog = 0
    	log file = /var/log/samba/log.%m
    	max log size = 1000
    	name resolve order = bcast
    	dns proxy = No
    	usershare allow guests = Yes
    	panic action = /usr/share/samba/panic-action %d
    
    [homes]
    	comment = Home Directories
    	valid users = amguerra
    	read only = No
    
    [hitachi]
    	comment = Hitachi external hard drive
    	path = /media/HITACHI
    	valid users = amguerra
    	read only = No
    
    [printers]
    	comment = All Printers
    	path = /var/spool/samba
    	create mask = 0700
    	printable = Yes
    	browseable = No
    	browsable = No
    
    [print$]
    	comment = Printer Drivers
    	path = /var/lib/samba/printers
    Code:
    amguerra@phoenix:~$ hostname
    phoenix

    Code:
    amguerra@phoenix:~$ cat /etc/hosts
    127.0.0.1	localhost
    127.0.1.1	phoenix
    
    # The following lines are desirable for IPv6 capable hosts
    ::1     localhost ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    Thanks!

Page 2 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •