Results 1 to 8 of 8

Thread: 12.10 - Nvidia driver ignores "nvidiaXineramaInfo" option

  1. #1
    Join Date
    Jun 2006
    Beans
    8

    Unhappy 12.10 - Nvidia driver ignores "nvidiaXineramaInfo" option

    http://us.download.nvidia.com/XFree8...igoptions.html

    Does anybody know how to disable XineramaInfo on the new Nvidia drivers?
    I have a monitor (IBM T221) that uses multiple DVI connections to drive one display: each conection corresponds to a section of the monitor. It should not be treated like separate monitors.

    Previously, in 12.04, I configured TwinView and used the "NoTwinViewXineramaInfo" option to get the behavior I wanted.
    My old xorg.conf had:
    Code:
    Section "Screen"
    ...
        Option         "NoTwinViewXineramaInfo" "True"
    ...
    The new driver seems to ignore this setting. TwinView works fine, but programs behave like I have two monitors: Some fullscreen apps, like VLC or XBMC only use one section. KDE thinks I have multiple monitors, so it sets up different backgrounds for each section, windows are maximized to one section, etc..

    Reading the documentation for the driver (http://us.download.nvidia.com/XFree8...igoptions.html), the option has been renamed (though the old name is kept for backwards compatibility): "nvidiaXineramaInfo" "off". The described behavior is the same, but setting the option in xorg.conf also apparently does nothing:
    Code:
    Section "Screen"
    ...
        Option         "nvidiaXineramaInfo" "off"
    ...
    How can I get the driver to present my TwinView configuration as one logical monitor like I had it in 12.04?
    Attached Files Attached Files
    Last edited by nerd65536; October 19th, 2012 at 10:37 AM.

  2. #2
    Join Date
    Oct 2008
    Beans
    10

    Re: 12.10 - Nvidia driver ignores "nvidiaXineramaInfo" option

    Shot in the dark here for you, since I'm having the same sort of problem with nvidiaXinerama settings being ignored...

    http://us.download.nvidia.com/XFree8...igoptions.html indicates that the setting for nvidiaXineramaInfo is a boolean, but you're using "off". I don't know how the conf is parsed, but perhaps try False/0?

    My post is here if you happen to figure anything out: http://askubuntu.com/posts/202702/

  3. #3
    Join Date
    Jun 2006
    Beans
    8

    Re: 12.10 - Nvidia driver ignores "nvidiaXineramaInfo" option

    From the manpage for xorg.conf:

    Code:
           Boolean  options  may  optionally have a value specified.
           When no value is specified, the option's value is TRUE.
           The following boolean option values are recognised as TRUE:
    
               1, on, true, yes
    
           and the following boolean option values are recognised as FALSE:
    
               0, off, false, no
    That being said, I just tried a zero with the same result.
    Code:
    Section "Screen"
    ...
        Option         "nvidiaXineramaInfo" "0"
    ...
    with the same result.

  4. #4
    Join Date
    Oct 2008
    Beans
    10

    Re: 12.10 - Nvidia driver ignores "nvidiaXineramaInfo" option

    Also seeing a similar problem here: http://www.nvnews.net/vbulletin/show...05#post2578805

    As this is cropping up a whole bunch of different ways, it may be a real live bug and not my usual PEBKAC!

  5. #5
    Join Date
    Jun 2008
    Beans
    3

    Re: 12.10 - Nvidia driver ignores "nvidiaXineramaInfo" option

    Me too affected this bug. anybody know solution?

  6. #6
    Join Date
    Jun 2008
    Beans
    3

    Re: 12.10 - Nvidia driver ignores "nvidiaXineramaInfo" option

    I think I found a solution, at least for me it works
    looks a bit illogical, but nonetheless.

    here is my config
    Code:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 270.29  (buildd@allspice)  Fri Feb 25 14:42:07 UTC 2011
    
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 270.41.06  (buildmeister@swio-display-x86-rhel47-08.nvidia.com)  Mon Apr 18 15:14:00 PDT 2011
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
    # commented out by update-manager, HAL is now used and auto-detects devices
    # Keyboard settings are now read from /etc/default/console-setup
    #    InputDevice    "Keyboard0" "CoreKeyboard"
    # commented out by update-manager, HAL is now used and auto-detects devices
    # Keyboard settings are now read from /etc/default/console-setup
    #    InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "1"
    EndSection
    
    Section "Files"
    EndSection
    
    # commented out by update-manager, HAL is now used and auto-detects devices
    # Keyboard settings are now read from /etc/default/console-setup
    #Section "InputDevice"
    #
    #    # generated from default
    #    Identifier     "Mouse0"
    #    Driver         "mouse"
    #    Option         "Protocol" "auto"
    #    Option         "Device" "/dev/psaux"
    #    Option         "Emulate3Buttons" "no"
    #    Option         "ZAxisMapping" "4 5"
    #EndSection
    
    # commented out by update-manager, HAL is now used and auto-detects devices
    # Keyboard settings are now read from /etc/default/console-setup
    #Section "InputDevice"
    #
    #    # generated from default
    #    Identifier     "Keyboard0"
    #    Driver         "kbd"
    #EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "CRT-0"
        HorizSync       28.0 - 33.0
        VertRefresh     43.0 - 72.0
        Option         "DPMS"
    Option "CustomEDID" "CRT-0:/etc/X11/edid.bin"
    ##Option "UseEDID" "False"
    EndSection
    
    Section "Device"
    
    # Removed Option "TwinView" "True"
    # Removed Option "MetaModes" "1280x1024,1280x1024"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 9500 GT"
        Option         "TwinViewOrientation" "RightOf"
    #	Option "UseEdidFreqs" "True"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
    #    Option         "TwinView" "1"
        Option         "TwinViewXineramaInfoOrder" "CRT-1"
        Option         "nvidiaXineramaInfo" "true"
    #    Option         "NoTwinViewXineramaInfo" "1"
    #    Option         "nvidiaXineramaInfo" "0"
        Option         "metamodes" "CRT-0: nvidia-auto-select +1280+0, CRT-1: 1280x1024 +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    I commented out the following lines
    Code:
    #    Option         "TwinView" "1"
    #    Option         "NoTwinViewXineramaInfo" "1"
    #    Option         "nvidiaXineramaInfo" "0"
    and change
    Code:
        Option         "Xinerama" "0"
    to
    Code:
        Option         "Xinerama" "1"
    and now everything works as before (almost)
    gnome crash if you try to use the corners for maximizing windows to half or full screen, other than that, everything is working well

    sorry for my english

  7. #7
    Join Date
    Jun 2006
    Beans
    8

    Re: 12.10 - Nvidia driver ignores "nvidiaXineramaInfo" option

    Quote Originally Posted by mikes-rus View Post
    ...
    Code:
        Option         "Xinerama" "1"
    and now everything works as before (almost)
    gnome crash if you try to use the corners for maximizing windows to half or full screen, other than that, everything is working well

    sorry for my english
    Enabling the Xserver's builtin Xinerama extension does override the Nvidia info, but it causes kded to segfault. Since I'm using KDE Plasma as my desktop, not having kded running renders my desktop completely useless.

  8. #8
    Join Date
    Oct 2008
    Beans
    10

    Re: 12.10 - Nvidia driver ignores "nvidiaXineramaInfo" option

    The best I've been able to find on this is that randr is being respected and any Xinerama override info is basically being nuked by what X is getting from randr. Unfortunately I don't have enough background in that to be able to think up a good workaround.

    However, here is a possible workaround/fix that doesn't require that, depending on your needs:

    1. Install the compizconfig-settings-manager package, if you don't have it already.
    2. Run it and go to General Options > Display Settings
    3. Add outputs as desired (in my case with two DVI connections I have it as 1920x1080+0+0 and 1920x1080+1920+0)
    4. Uncheck the "Detect Outputs" option above the output list


    Caveat: This will NOT fix the issue with the panel spanning multiple desktops, only that of maximized windows spanning both screens. I had forgotten completely about compizconfig's ability to do this.

    Any input on splitting the panel per output using this approach? It would be nice to have the menu on the same screen as the active window.
    Last edited by AvatarKava; November 6th, 2012 at 10:03 AM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •