Page 3 of 6 FirstFirst 12345 ... LastLast
Results 21 to 30 of 56

Thread: Can't install ATI proprietary drivers in 12.10. Unity is Missing

  1. #21
    Join Date
    Oct 2009
    Beans
    133
    Distro
    Ubuntu Studio 10.04 Lucid Lynx

    Re: Can't install ATI proprietary drivers in 12.10. Unity is Missing

    i got this
    mjhouska@mjhouska-A780L3G:~$ sudo apt-get install fglrx-legacy
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    fglrx-legacy : Depends: xserver-xorg-core (>= 3:1.12) but 2:1.13.0-0ubuntu6 is to be installed
    E: Unable to correct problems, you have held broken package

  2. #22
    Join Date
    Apr 2012
    Beans
    7

    Re: Can't install ATI proprietary drivers in 12.10. Unity is Missing

    These steps did not work for me. I have a laptop with a 6490M with switchable graphics. It'd be nice to get the proprietary drivers working because with the open source ones I only get roughly 1 hour of battery life...

  3. #23
    Join Date
    Aug 2007
    Location
    Sweden
    Beans
    60
    Distro
    Xubuntu 11.10 Oneiric Ocelot

    Re: Can't install ATI proprietary drivers in 12.10. Unity is Missing

    Quote Originally Posted by YannB View Post
    It seems that "older" generations of AMD chipsets (2000 to 4000 series) are no longer supported in the latest generation of drivers. If you have such a chipset you will need the legacy FGLRX drivers. Unfortunately the legacy drivers are not compatible with the new Xorg 1.13 which comes with Ubuntu 12.10. So you will need to downgrade to 1.12 of Xorg.

    The good news is that someone set up a PPA for this purpose:
    ppa:makson96/fglrx
    This worked for me, following the instructions in the PPA descriptions. Thank you, you made my laptop usable again after the upgrade Was a few days away from re-installing 12.04.

    (ATI Mobility Radeon HD4250)

  4. #24
    Join Date
    Apr 2012
    Beans
    10

    Angry Re: Can't install ATI proprietary drivers in 12.10. Unity is Missing

    Quote Originally Posted by Noccy View Post
    This worked for me, following the instructions in the PPA descriptions. Thank you, you made my laptop usable again after the upgrade Was a few days away from re-installing 12.04.

    (ATI Mobility Radeon HD4250)
    Well I have an ATI Mobility Radeon HD4650 and installing the fglrx-legacy didn't work for me... The resolution seems fixed but I don't have unity, window borders and the UI is laggy...

    Do you know any way to fix this??

    I am on linux image 3.5.0.17.19 with the linux image generic installed.

    Cheers and thank you all.

    EDIT: And btw AMD Catalyst Center works, but still...
    Last edited by spirosbond; October 23rd, 2012 at 08:48 PM.

  5. #25
    Join Date
    Aug 2007
    Location
    Sweden
    Beans
    60
    Distro
    Xubuntu 11.10 Oneiric Ocelot

    Re: Can't install ATI proprietary drivers in 12.10. Unity is Missing

    Quote Originally Posted by spirosbond View Post
    <Well I have an ATI Mobility Radeon HD4650 and installing the fglrx-legacy didn't work for me... The resolution seems fixed but I don't have unity, window borders and the UI is laggy...

    Do you know any way to fix this??
    Did you downgrade your X per the instructions in the PPA? Sounds like you got the patched kernel driver working (CCC working) but not the X driver (which is incompatible with the version of X shipped).

  6. #26
    Join Date
    Jan 2008
    Beans
    2

    Re: Can't install ATI proprietary drivers in 12.10. Unity is Missing

    Ubuntu 12.10 doesn't support AMD/ATI drivers (called fglrx). If you install them, Unity and xserver won't work!

    If using AMD/ATI GPU drivers: Run the following command to remove them, and reboot:

    Code:
    sudo sh /usr/share/ati/fglrx-uninstall.sh
    sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*
    
    sudo rm /etc/X11/xorg.conf
    
    sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx libgl1-mesa-dri libgl1-mesa-glx libgl1-mesa-dri
    sudo dpkg-reconfigure xserver-xorg
    
    sudo reboot
    Wait for AMD or Canonical or a PPA to release an update that sets the things right.Automated installer and Display Drivers for Xorg 6.9 to Xserver 1.12 and Kernel version up to 3.4 are currently supported. 12.10 uses Kernel version 3.5.

    Source: http://support.amd.com/us/gpudownloa...eon_linux.aspx

  7. #27
    Join Date
    Apr 2012
    Beans
    10

    Re: Can't install ATI proprietary drivers in 12.10. Unity is Missing

    Quote Originally Posted by Noccy View Post
    Did you downgrade your X per the instructions in the PPA? Sounds like you got the patched kernel driver working (CCC working) but not the X driver (which is incompatible with the version of X shipped).
    I only did that:

    sudo add-apt-repository ppa:makson96/fglrx
    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get install fglrx-legacy

    how should I check if my X-server has downgraded? The repo here:

    https://launchpad.net/~makson96/+archive/fglrx

    does this automatically!?!?!

    Cheers


    Quote Originally Posted by ayyala View Post
    Ubuntu 12.10 doesn't support AMD/ATI drivers (called fglrx). If you install them, Unity and xserver won't work!

    If using AMD/ATI GPU drivers: Run the following command to remove them, and reboot:

    Code:
    sudo sh /usr/share/ati/fglrx-uninstall.sh
    sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*
    
    sudo rm /etc/X11/xorg.conf
    
    sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx libgl1-mesa-dri libgl1-mesa-glx libgl1-mesa-dri
    sudo dpkg-reconfigure xserver-xorg
    
    sudo reboot
    Wait for AMD or Canonical or a PPA to release an update that sets the things right.Automated installer and Display Drivers for Xorg 6.9 to Xserver 1.12 and Kernel version up to 3.4 are currently supported. 12.10 uses Kernel version 3.5.

    Source: http://support.amd.com/us/gpudownloa...eon_linux.aspx
    Is there any way to use these drivers

    https://launchpad.net/~makson96/+archive/fglrx

    with kernel 3.2.0-32 which I have also installed at my 12.10? I tried booting with it but nothing changed.

    Is there any other way to have my graphics working? Gnome doesn't work correctly either. I have the AMD Mobility 4650HD Graphics card btw.

    Thank you



    EDIT:
    I did this
    Code:
    sudo sh /usr/share/ati/fglrx-uninstall.sh
    sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*
    
    sudo rm /etc/X11/xorg.conf
    
    sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx libgl1-mesa-dri libgl1-mesa-glx libgl1-mesa-dri
    sudo dpkg-reconfigure xserver-xorg
    
    sudo reboot
    as suggested and I now have working unity and no lag at all. Thank you sir and lovely linux community

    Cheers
    Last edited by spirosbond; October 26th, 2012 at 06:53 PM.

  8. #28
    Join Date
    Jul 2007
    Location
    Nashville TN
    Beans
    130
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Can't install ATI proprietary drivers in 12.10. Unity is Missing

    RS880M [Mobility Radeon HD 4200 Series]

    I clean-reinstalled 12.10 and am running the OSS driver (and yes, cpu a little hotter.) Downgrading X.org and fglrx, and possible the kernel is all too scary for me, as I don't know how it will effect updates and the next ubuntu upgrade.

    All these video driver issues stem from Canonical's decision to transition from X.org to the new Wayland video server:

    https://wiki.ubuntu.com/Wayland

    Not great news for those trying to hang on and keep older hardware running. I think I remember seeing somewhere that AMD was not planning to continue to support radeon 2xxx-4xxx in their fglrx driver. I may eventually have to switch to a more legacy-friendly distro.

  9. #29
    Join Date
    Sep 2010
    Location
    Russia, Rostov-on-Don
    Beans
    2
    Distro
    Ubuntu Development Release

    Re: Can't install ATI proprietary drivers in 12.10. Unity is Missing

    Solution for me:

    1. remove current fglrx
    Code:
    sudo sh /usr/share/ati/fglrx-uninstall.sh
    Code:
    sudo apt-get remove --purge fglrx*
    2. add ppa repository
    Code:
    sudo apt-add-repository ppa:andrikos/ppa
    3. update packages list
    Code:
    sudo apt-get update
    4. install packages
    Code:
    sudo apt-get install fglrx-updates
    Last edited by DsXack; November 9th, 2012 at 11:25 PM.

  10. #30
    Join Date
    Apr 2012
    Beans
    10

    Re: Can't install ATI proprietary drivers in 12.10. Unity is Missing

    Quote Originally Posted by DsXack View Post
    Solution for me:

    1. remove current fglrx
    Code:
    sudo sh /usr/share/ati/fglrx-uninstall.sh
    Code:
    sudo apt-get remove --purge fglrx*
    2. add ppa repository
    Code:
    sudo apt-add-repository ppa:andrikos/ppa
    3. update packages list
    Code:
    sudo apt-get update
    4. install packages
    Code:
    sudo apt-get install fglrx-updates
    Which card are you using? What cards does this ppa support?

    Thank you

Page 3 of 6 FirstFirst 12345 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •