Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: configuring VMPK and Qsynth

  1. #1
    Join Date
    Dec 2010
    Beans
    38

    configuring VMPK and Qsynth

    I installed VMPK (Virtual MIDI Piano Keyboard), and am trying to play notes from it thru my USB earphones--the earphones are working (at least, with Skype). When I click on a piano key in VMPK, the small green pilot light at the lower left corner in Qsynth flashes, but there's no sound via the earphones. Any hints?

  2. #2
    Join Date
    Nov 2009
    Beans
    1,879
    Distro
    Ubuntu Studio 9.10 Karmic Koala

    Re: configuring VMPK and Qsynth

    Qsynth requires a soundfont in order to make sounds, there are plenty free ones out there on google. Anything in .sf2 format will work.
    If you already have loaded a soundfont, please post what settings you are using.

  3. #3
    Join Date
    Dec 2010
    Beans
    38

    Re: configuring VMPK and Qsynth

    In Qsynth:
    MIDI tab: Enable MIDI Input box checked
    ALSA Sequencer Client ID: Qsynth1
    Audio tab: Audio driver: alsa
    Soundfonts tab: SFID 1; Name /usr/share/sounds/sf2/FluidR3_GM.sf2; Offset 0

    In VMPK: -->Edit -->Connections: "Enable Thru on MIDI Output" checked
    Input MIDI Connection <blank>
    Output MIDI Connection FLUID Synth (Qsynth1):0

  4. #4
    Join Date
    Nov 2009
    Beans
    1,879
    Distro
    Ubuntu Studio 9.10 Karmic Koala

    Re: configuring VMPK and Qsynth

    I usually use qsynth with jack, but I have just had success with these settings using ALSA only:

    VMPK:
    In Connections unchecked both boxes, fluid synth as output

    Qsynth:
    In setup>MIDI, use alsa_seq driver, client ID:pid

    Use channels to select the soundfont, some only have a limited range of a few notes.

  5. #5
    Join Date
    Dec 2010
    Beans
    38

    Re: configuring VMPK and Qsynth

    Tried what you suggest, but still no sound via headphones. Perhaps if I use jack? What settings should I try with jack, perhaps that will do it.....

  6. #6
    Join Date
    Nov 2009
    Beans
    1,879
    Distro
    Ubuntu Studio 9.10 Karmic Koala

    Re: configuring VMPK and Qsynth

    I don't think jack will help as it can only use one sound device at a time, and I think your USB phones will count as a separate device. Could you post the result of aplay -l from a terminal?

  7. #7
    Join Date
    Dec 2010
    Beans
    38

    Re: configuring VMPK and Qsynth

    card 0: ICH7 [Intel ICH7], device 0: Intel ICH [Intel ICH7]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 0: ICH7 [Intel ICH7], device 4: Intel ICH - IEC958 [Intel ICH7 - IEC958]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 1: Headset [Logitech USB Headset], device 0: USB Audio [USB Audio]
    Subdevices: 1/1
    Subdevice #0: subdevice #0

  8. #8
    Join Date
    Nov 2009
    Beans
    1,879
    Distro
    Ubuntu Studio 9.10 Karmic Koala

    Re: configuring VMPK and Qsynth

    Under qsynth setup>audio, try typing in hw:1 as the audio device.

  9. #9
    Join Date
    Dec 2010
    Beans
    38

    Re: configuring VMPK and Qsynth

    Thanks for your patience.....here's what I get:

    p, li { white-space: pre-wrap; } Qsynth1: Failed to create the audio driver (alsa).

    Cannot continue without it.


    and in the Qsynth log:



    p, li { white-space: pre-wrap; } 13:59:23.289 Qsynth1: Failed to create the audio driver (alsa). Cannot continue without it.
    fluidsynth: warning: Failed to pin the sample data to RAM; swapping is possible.
    fluidsynth: error: The "hw:1" audio device is used by another application

  10. #10
    Join Date
    Nov 2009
    Beans
    1,879
    Distro
    Ubuntu Studio 9.10 Karmic Koala

    Re: configuring VMPK and Qsynth

    fluidsynth: error: The "hw:1" audio device is used by another application
    Did you have anything else open when trying this out? Shut down anything using sound.

    If this still doesn't work try using hw:1,1 instead of hw:1.

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •