Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: long delay at shutdown/reboot

  1. #1
    Join Date
    Feb 2007
    Location
    Rome, Italy
    Beans
    2,184

    long delay at shutdown/reboot

    there is a long delay when shutting down or restarting the system.
    it looks like the network-manager service hangs when stopping in init6.

    * Asking all remaining processes to terminate... [OK]
    * Killing all remaining processes... [fail]
    nmdispatcher.action caught signal 15 shutting down ...

    If I manually stop the network-manager service before shutdown/restart then everything works fine

    this bug is probably related to this old one (solved in 12.04):
    https://bugs.launchpad.net/ubuntu/+s...er/+bug/869635

    new bug reported:
    https://bugs.launchpad.net/ubuntu/+s...r/+bug/1066484

  2. #2
    Join Date
    Jul 2008
    Location
    Canada
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: long delay at shutdown/reboot

    I was shutting down in 3 seconds with 12.10 until a week a go. Now it's about 15 seconds. With 12.04 my 4 laptops all stopped shutting down a few months after it was released. I hope 12.10 doesn’t follow 12.04. It's does seem to be with Network Manager.
    UsingTheTerminal and PopularPages A very handy Documentation Search Tool used by many.

    Smile today, cry tomorrow!
    ( Read this everyday )

  3. #3
    dino99's Avatar
    dino99 is offline Ubuntu addict and loving it
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: long delay at shutdown/reboot

    same thing here too: stop a few seconds at "remaining services" and have also some initctl unknown jobs (K20plymouth K20networking).

    using bum, i've uncheck them (K20...) so now its cleaner, but still not perfect.
    Last edited by dino99; October 15th, 2012 at 01:03 PM.

  4. #4
    Join Date
    Sep 2011
    Location
    india
    Beans
    297
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: long delay at shutdown/reboot

    Quote Originally Posted by sammiev View Post
    i was shutting down in 3 seconds with 12.10 until a week a go. Now it's about 15 seconds. With 12.04 my 4 laptops all stopped shutting down a few months after it was released. I hope 12.10 doesn’t follow 12.04. It's does seem to be with network manager.

    +1
    core i3, 4gb ram, OCZ agility 3 ssd ,ati radeon -- ubuntu 13.04
    acer aspire 4752 -, ubuntu 12.10


    Faith is miraculous if it is accompanied by dedicated efforts

  5. #5
    Join Date
    Aug 2010
    Location
    Arizona USA
    Beans
    2,868
    Distro
    Ubuntu Development Release

    Re: long delay at shutdown/reboot

    A couple of thoughts...

    Yes, shutdown/reboot is V slow on 12.10! I don't know why this is, however, I've noticed there is a torrent of HDD activity during shutdown. Sometimes, my HDD activity light is lit-up solid for several minutes. And, it's particularly slow and lumbering if I've been using Banshee (a Mono app).

    I've also noticed that the length of time it takes to shutdown/reboot, and the amount of HDD activity that takes place seems to be directly related to how much time I've spent in a session. If I've only been in a session for a few minutes, shutdown/reboot is very quick. If I've been in a session for (say) 12 hours, it takes a considerably longer amount of time to shutdown. Sometimes, I leave the room, and come back later, to make sure my PC shutdown -- that's how long it takes.

    As an aside, I booted into Ubu 10.10 last night, to make sure my new Conky script worked on Gnome 2/Linux 2.6. I was shocked at how fast it shutdown when I was done! So, it is not hardware related.
    Intel ® P4 Extreme Edition 3.4 (Gallatin) || DFI ® LanParty PRO875B rev B1
    Crucial ® Ballistix Tracer PC4000 1GB || Mountain Mods U2-UFO Opti-1203
    XFX 7600GT 560M AGP (PV-T73A-UDF3) || Corsair HX520W Modular PSU

  6. #6
    Join Date
    Jul 2007
    Location
    UK
    Beans
    16,867
    Distro
    Ubuntu Development Release

    Re: long delay at shutdown/reboot

    This network manager thing hanging is a pain shutting down. It gets fixed only to creep back in again and again.

    I've added myself to the new bug.
    Last edited by philinux; October 15th, 2012 at 12:50 PM.

  7. #7
    Join Date
    Feb 2007
    Location
    Rome, Italy
    Beans
    2,184

    Re: long delay at shutdown/reboot

    Quote Originally Posted by philinux View Post
    This network manager thing hanging is a pain shutting down. It gets fixed only to creep back in again and again.

    I've added myself to the new bug.
    A never ending story ...

  8. #8
    Join Date
    May 2007
    Location
    Midlands UK
    Beans
    291
    Distro
    Ubuntu

    Re: long delay at shutdown/reboot

    I get a similar problem trying to restart (ie. after an update requiring so). I have to shutdown completely and reboot. Selecting 'restart now' ends in a black screen hang. Unless I disconnect network before doing so. I have added 'me too' to a bug report.
    = Fit as a butcher's dog =

  9. #9
    Join Date
    Mar 2008
    Location
    Germany
    Beans
    171
    Distro
    Xubuntu 12.10 Quantal Quetzal

    Exclamation Re: long delay at shutdown/reboot

    Affects me too. Hope it will be fixed soon.
    If you can't explain it simply, you don't understand it well enough. - A. Einstein

  10. #10
    Join Date
    Jun 2007
    Location
    Porirua, New Zealand
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: long delay at shutdown/reboot

    Seeing this thread stirred recollections of another thread: http://ubuntuforums.org/showthread.php?t=1134201
    Forum DOs and DON'Ts
    Never assume that information you find using a search engine is up-to-date.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •