Results 1 to 2 of 2

Thread: Dell XPS 1530m Display Problem

  1. #1
    Join Date
    May 2008
    Location
    Ontario, Canada
    Beans
    Hidden!
    Distro
    Ubuntu

    Exclamation Dell XPS 1530m Display Problem

    Hey everyone,

    I have an older dell laptop. xps 1530m with the nvidia 8400m GS.
    The screen on the laptop is broken, but the external display still seems to work.

    I have installed Debian Wheezy to it. Grub shows up fine, and I can select either recovery mode or the default option. I then see a whole lot of

    ...loading "something" [OK]
    After it loads GDM3 (Gnome Display Manager), the external screen turns black. (The primary display is cracked and never displays anything)

    I can remote into the laptop via ssh.

    UPDATE::
    [My Previous Request was for a xorg configuration file that disables the internal LCD]

    I am now in the process of making a such a file, but I require some help. This is what I currently have.

    Section "Monitor"
    Identifier "External HDMI"
    Option "Enable" "true"
    Option "PreferredMode" "1920x1080"
    EndSection

    Section "Monitor"
    Identifier "Integrated LCD"
    Option "Ignore" "true"
    [COLOR="rgb(72, 61, 139)"]EndSection[/COLOR]

    Section "Device"
    Identifier "Card0"
    VendorName "nVidia Corporation"
    BoardName "GeForce 8400M GS"
    Driver "nouveau"
    BusID "01.00.0"
    Option "Monitor-HDMI1" "External HDMI"
    Option "Monitor-LVDS1" "Integrated LCD"
    EndSection

    Section "Screen"
    Identifier "screen0"
    Device "Card0"
    Monitor "External HDMI"
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection

    SubSection "Display"
    Viewport 0 0
    Depth 32
    EndSubSection

    EndSection

    Section "ServerLayout"
    Identifier "layout0"
    Screen "screen0"
    EndSection

    Section "Files"
    ModulePath "/usr/lib/xorg/modules"
    FontPath "/usr/share/fonts/X11/misc"
    FontPath "/usr/share/fonts/X11/100dpi"
    FontPath "/usr/share/fonts/X11/75dpi"
    FontPath "/usr/share/fonts/X11/Type1"
    FontPath "built-ins"
    EndSection

    and this is the error I receive now

    Code:
    Fatal server error:
    [ 312.888] xf86OpenConsole: Cannot find a free VT
    Last edited by vandorjw; October 14th, 2012 at 03:13 AM.

  2. #2
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    6,614
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Dell XPS 1530m Display Problem

    Hi cc7gir.

    Could you post the content of this file?
    Code:
    /var/log/Xorg.0.log
    Please paste it here: http://paste.ubuntu.com/, and then post back the link here.

    Regards.

    BTW, your post is marked as SOLVED, you won't get much attention to your problem that way.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •