Quote Originally Posted by NikTh View Post
. We have the same dual-boot (except mine is triple boot , Windows too).

Arch not switched yet in systemd as I know. This option in grub IS NOT as switching in systemd (I know that for sure). It is just a test of systemd . Yes , test it first and then you must delete-remove this option from grub and switch to a pure systemd.
Please read the Wiki : https://wiki.archlinux.org/index.php/Systemd



Edit the grub in Arch Linux
Code:
sudo nano /etc/default/grub
and add the option in the appropriate position.
Then update the grub
Code:
sudo grub-mkconfig -o /boot/grub/grub.cfg
Then boot to ubuntu and mount the partition with Arch and update the grub.

Example if Arch is on /dev/sda3

Code:
sudo mount /dev/sda3 /mnt 
sudo update-grub
and I think you will be fine.

If above not working , then modify the Ubuntu's grub.cfg manually.
Code:
sudo nano /boot/grub/grub.cfg
find the Arch Linux entry and add the option manually.
Thanks
Well, if I don't add this: init=/usr/lib/systemd/systemd to the linux line of /boot/grub/grub.cfg my Arch still boots but it uses the old systemV initscripts. In order to use systemd GRUB issues this call explicitly.

Arch site just announced that systemd is default.