Results 1 to 2 of 2

Thread: GRUB not detecting Windows 7 (surprise!)

  1. #1
    Join Date
    Jan 2010
    Beans
    12

    GRUB not detecting Windows 7 (surprise!)

    BOOOOORING, I know! But I'm ONE MORE guy who can't quite figure out how to boot my win7 partition. It's been two months now and I have to get back in there for some proprietary stuff that just doesn't work in wine.

    I can mount the partition, access the files, but os-prober just will not see it. I'm scared to even place the windows restore CD in my optical drive, because Precise is running oh-so-nicely and I don't want to screw it all up!

    The output of sudo fdisk -l:

    Code:
    Disk /dev/sda: 500.1 GB, 500107862016 bytes
    255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x07f2837e
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1              63      208844      104391   de  Dell Utility
    /dev/sda2          208896    41172991    20482048   83  Linux
    /dev/sda3   *    41172992   216954241    87890625    7  HPFS/NTFS/exFAT
    /dev/sda4       216954878   976771071   379908097    5  Extended
    /dev/sda5       216954880   951328767   367186944   83  Linux
    /dev/sda6       951330816   964028415     6348800   82  Linux swap / Solaris
    /dev/sda7       964030464   976771071     6370304   82  Linux swap / Solaris
    my bootinfo URL: http://paste.ubuntu.com/1276068/

    What should I do? Try the windows CD and hope for the best? Is it possible the problem is in the VBR of /dev/sda3? If so, how can I replace just that?

    Cheers, thanks for taking the time to help aNOTHER guy through this common stumbling block.

    -Kip

  2. #2
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: GRUB not detecting Windows 7 (surprise!)

    Moved to other OS as it really is a Windows repair issue.

    It probably is fixable, but you over wrote the Windows boot partition. Normal installs of Windows 7 have a hidden 100MB boot/repair partition and the main install. You are missing two key boot files.

    Windows Boot files:
    WinXP
    /boot.ini /ntldr /NTDETECT.COM
    Vista/7 (with 7 the first two files are usually in a separate 100MB boot partition)
    /bootmgr /Boot/BCD /Windows/System32/winload.exe

    You are missing bootmgr & the BCD. I did see one user who just copied bootmgr & the BCD into his system from his repairCD. But of course he then had to edit the BCD as the defaults were the repair not the install.

    For Windows repair to work you also need the boot flag (in Windows make active) on your sda3. It was on the now missing Windows boot partition. Windows will only repair the boot of the partition with the boot flag. And that partition has to be formated NTFS and a primary partition (which yours is).

    You do have a Windows repairCD or USB? You need a current version repairCD or Linux liveCD for every operating system you have installed. If you have access to another Windows 7 same 64 or 32 bit version you can make a repair CD.

    Make your own Windows repairCD (not vendor recovery):
    http://windows.microsoft.com/en-GB/w...em-repair-disc
    http://forums.techarena.in/guides-tutorials/1114725.htm

    Windows 7 repair USB, Also Vista if service pack installed
    http://www.intowindows.com/how-to-re...tion-dvd-disc/
    http://www.webupd8.org/2010/10/creat...usb-drive.html
    Windows 8 UEFI repair USB must be FAT32
    http://social.msdn.microsoft.com/For...-166dddf32205/

    How to Boot to the System Recovery Options in Windows 7
    http://www.sevenforums.com/tutorials...y-options.html
    http://www.sevenforums.com/tutorials...ot-record.html
    http://windows7ultimate.windowsreins...indexthumbs.ht
    fix boot loader With screen shots from full Windows install media
    http://www.howtogeek.com/howto/32523...ader-problems/
    For info on UEFI boot install & repair - Updated Mar 2015:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •